aboutsummaryrefslogtreecommitdiff
path: root/mail/mu/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2015-04-23 14:14:21 +0000
committerWen Heping <wen@FreeBSD.org>2015-04-23 14:14:21 +0000
commit8da2be79759f05ba3a800cd69015e5c8e1647293 (patch)
treedf6c22494320d3fba32fecb58d9d4d957d15acac /mail/mu/Makefile
parentc5388b442f5beb941ed5cb921d602b64229d3bac (diff)
downloadports-8da2be79759f05ba3a800cd69015e5c8e1647293.tar.gz
ports-8da2be79759f05ba3a800cd69015e5c8e1647293.zip
Notes
Diffstat (limited to 'mail/mu/Makefile')
-rw-r--r--mail/mu/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/mail/mu/Makefile b/mail/mu/Makefile
index aa04db4b8a47..6dce4f31dc0b 100644
--- a/mail/mu/Makefile
+++ b/mail/mu/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= mu
-PORTVERSION= 0.9.10
+PORTVERSION= 0.9.11
+DISTVERSIONPREFIX= v
CATEGORIES= mail
-MASTER_SITES= GHL
+MASTER_SITES= GH
MAINTAINER= ports@FreeBSD.org
COMMENT= Mail searching frontend for Xapian
@@ -16,9 +17,6 @@ LIB_DEPENDS= libxapian.so:${PORTSDIR}/databases/xapian-core \
USE_GITHUB= yes
GH_ACCOUNT= djcb
-GH_PROJECT= ${PORTNAME}
-GH_TAGNAME= ${PORTVERSION:S/^/v/}
-GH_COMMIT= 7888ba3
USES= autoreconf gmake libtool makeinfo pkgconfig
USE_GNOME= glib20
@@ -36,13 +34,19 @@ GUILE_LIB_DEPENDS= libguile-2.0.so:${PORTSDIR}/lang/guile2
GUILE_USE= ldconfig=yes
GUILE_CONFIGURE_ENABLE= guile
GUILE_INFO= mu-guile
-MU4E_DESC= Email cluent for Emacs
+MU4E_DESC= Email client for Emacs
MU4E_USE= emacs=yes
MU4E_CONFIGURE_ENABLE= mu4e
MU4E_INFO= mu4e
+.include <bsd.port.options.mk>
+
post-install:
(cd ${FILESDIR} && ${INSTALL_SCRIPT} mu-ask \
${STAGEDIR}${PREFIX}/bin)
+.if ${PORT_OPTIONS:MGUILE}
+ (${FIND} ${STAGEDIR}${PREFIX}/lib -name "*.so.*" -type f | \
+ ${XARGS} ${STRIP_CMD})
+.endif
.include <bsd.port.mk>