aboutsummaryrefslogtreecommitdiff
path: root/mail/mu4e
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2016-05-17 07:46:04 +0000
committerHiroki Sato <hrs@FreeBSD.org>2016-05-17 07:46:04 +0000
commit5fc2b7d89b2c1b2ccc43db3f61f506478b80af4f (patch)
tree5872a65cca7bc8aec004c4e7304ce19838de054a /mail/mu4e
parentf42114dab613902b59d6c0ec972c49cd41f5f9c8 (diff)
downloadports-5fc2b7d89b2c1b2ccc43db3f61f506478b80af4f.tar.gz
ports-5fc2b7d89b2c1b2ccc43db3f61f506478b80af4f.zip
Fix build.
Notes
Notes: svn path=/head/; revision=415376
Diffstat (limited to 'mail/mu4e')
-rw-r--r--mail/mu4e/files/patch-configure.ac59
1 files changed, 57 insertions, 2 deletions
diff --git a/mail/mu4e/files/patch-configure.ac b/mail/mu4e/files/patch-configure.ac
index eae4c8acb748..c71047d62662 100644
--- a/mail/mu4e/files/patch-configure.ac
+++ b/mail/mu4e/files/patch-configure.ac
@@ -34,7 +34,7 @@
# check for makeinfo
AC_CHECK_PROG(have_makeinfo,makeinfo,yes,no)
-@@ -110,16 +110,16 @@ AS_IF([test "x$PKG_CONFIG" = "xno"],[
+@@ -110,36 +110,36 @@ AS_IF([test "x$PKG_CONFIG" = "xno"],[
# glib2?
# we need 2.14 at least, because we use GRegex
@@ -55,7 +55,62 @@
# xapian checking - we need 1.2.x at least
-@@ -246,26 +246,9 @@ AS_IF([test "x$PMCCABE" = "xno"],[
+-AC_CHECK_PROG(XAPIAN_CONFIG,xapian-config,xapian-config,no)
+-AM_CONDITIONAL(HAVE_XAPIAN,test "x$XAPIAN_CONFIG" != "xno")
+-AS_IF([test "x$XAPIAN_CONFIG" = "xno"],[
+- AC_MSG_ERROR([
+- *** xapian could not be found; please install it
+- *** e.g., in debian/ubuntu the package would be 'libxapian-dev'
+- *** If you compiled it yourself, you should ensure that xapian-config
+- *** is in your PATH.])],
+- [xapian_version=$($XAPIAN_CONFIG --version | sed -e 's/.* //')])
+-AS_CASE([$xapian_version],
+- [1.[[2-9]].[[0-9]]*], [],
+- [AC_MSG_ERROR([*** xapian version >= 1.2 needed,
+- but version $xapian_version found.])])
+-
+-XAPIAN_CXXFLAGS="`$XAPIAN_CONFIG --cxxflags`"
+-XAPIAN_LIBS="`$XAPIAN_CONFIG --libs`"
+-have_xapian="yes"
++#AC_CHECK_PROG(XAPIAN_CONFIG,xapian-config,xapian-config,no)
++#AM_CONDITIONAL(HAVE_XAPIAN,test "x$XAPIAN_CONFIG" != "xno")
++#AS_IF([test "x$XAPIAN_CONFIG" = "xno"],[
++# AC_MSG_ERROR([
++# *** xapian could not be found; please install it
++# *** e.g., in debian/ubuntu the package would be 'libxapian-dev'
++# *** If you compiled it yourself, you should ensure that xapian-config
++# *** is in your PATH.])],
++# [xapian_version=$($XAPIAN_CONFIG --version | sed -e 's/.* //')])
++#AS_CASE([$xapian_version],
++# [1.[[2-9]].[[0-9]]*], [],
++# [AC_MSG_ERROR([*** xapian version >= 1.2 needed,
++# but version $xapian_version found.])])
++#
++#XAPIAN_CXXFLAGS="`$XAPIAN_CONFIG --cxxflags`"
++#XAPIAN_LIBS="`$XAPIAN_CONFIG --libs`"
++#have_xapian="yes"
+
+ AC_SUBST(XAPIAN_CXXFLAGS)
+ AC_SUBST(XAPIAN_LIBS)
+@@ -235,37 +235,20 @@ AC_SUBST(MU_DOC_DIR, "${prefix}/share/do
+
+ ###############################################################################
+ # check for pmccabe
+-AC_PATH_PROG([PMCCABE],[pmccabe],[no])
+-AS_IF([test "x$PMCCABE" = "xno"],[
+- have_pmccabe="no"
+- AC_MSG_WARN([
+- *** Developers: you do not seem to have the pmccabe tool installed.
+- *** Please install it if you want to run the automated code checks])
+-],[have_pmccabe="yes"])
++#AC_PATH_PROG([PMCCABE],[pmccabe],[no])
++#AS_IF([test "x$PMCCABE" = "xno"],[
++# have_pmccabe="no"
++# AC_MSG_WARN([
++# *** Developers: you do not seem to have the pmccabe tool installed.
++# *** Please install it if you want to run the automated code checks])
++#],[have_pmccabe="yes"])
+ ###############################################################################
AC_CONFIG_FILES([
Makefile