aboutsummaryrefslogtreecommitdiff
path: root/mail/mu
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-09 19:42:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-09 19:42:46 +0000
commit30a00f2227a3e53b607331247c81c2911c1e98ef (patch)
treeb3bdcd25b598432ef78aefb0f72e9412f429eee4 /mail/mu
parentfc3bdd2b5bc1f418653dc07e3f7734890f957654 (diff)
downloadports-30a00f2227a3e53b607331247c81c2911c1e98ef.tar.gz
ports-30a00f2227a3e53b607331247c81c2911c1e98ef.zip
Most commonly used build systems support silent builds, when they
hide actual commands executed and only show short summary line (like "CC foo.c"). CMake and ninja enable this by default, some autotools using ports do as well. This is unacceptable because we need complete build logs at any time, so we now switch to verbose build logs unconditionally. Note that this change deliberately affects ALL builds and not only package builds on cluster, because we need to be sure that user experiencing failure can always provide informative build log regardless of settings and without rerunning the build. Change summary: - Always do verbose builds for cmake, ninja and GNU configure (the latter includes check if --disable-silent-rules is actually supported by the configure script; there are isolated cases when it's not true) - Remove CMAKE_VERBOSE, NINJA_VERBOSE and CONFIGURE_ARGS=--disable-silent-rules from all ports which set them for this is no longer needed - Revert hacks for --disable-silent-rules support priorly committed to biology/ncbi-blast+ and net-p2p/mldonkey - no longer needed as well Submitted by: amdmi3 Reviewed by: mat Exp-run by: antoine Approved by: portmgr (mat, antoine) Differential Revision: D7534
Notes
Notes: svn path=/head/; revision=421635
Diffstat (limited to 'mail/mu')
-rw-r--r--mail/mu/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/mail/mu/Makefile b/mail/mu/Makefile
index 9871dbd59713..a52e4ad6b87c 100644
--- a/mail/mu/Makefile
+++ b/mail/mu/Makefile
@@ -21,7 +21,7 @@ GH_ACCOUNT= djcb
USES= autoreconf gmake libtool makeinfo pkgconfig
USE_GNOME= glib20
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules --disable-gtk --disable-mu4e
+CONFIGURE_ARGS= --disable-gtk --disable-mu4e
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= DOCS GUILE