aboutsummaryrefslogtreecommitdiff
path: root/mail/mu
diff options
context:
space:
mode:
authorEygene Ryabinkin <rea@FreeBSD.org>2012-11-07 06:24:50 +0000
committerEygene Ryabinkin <rea@FreeBSD.org>2012-11-07 06:24:50 +0000
commit7b914b4667b857f92b8f865ea4a37ce040254520 (patch)
tree6b1abf6db2171f9f01ffd8309969210dfbc7f251 /mail/mu
parent8ba5b30b504e12a831af1e84777be3848a8322fc (diff)
downloadports-7b914b4667b857f92b8f865ea4a37ce040254520.tar.gz
ports-7b914b4667b857f92b8f865ea4a37ce040254520.zip
mail/mu: upgrade to 0.9.9
Changelog entries since 0.9.8.1: - remove --summary (use --summary-len instead) - add --after for mu find, to limit to messages after T - add new command `mu verify', to verify signatures - fix iso-2022-jp decoding (and other 7-bit clean non-ascii) - add support for X-keywords - performance improvements for threaded display (~ 25% for 23K msgs) - mu improved user-help (and the 'mu help' command) - toys/mug2 replaces toys/mug - support .noupdate files (parallel to .noindex, dir is ignored unless we're doing a --rebuild). - append all inline text parts, when getting the text body - respect custom maildir flags - correctly handle the case where g_utf8_strdown (str) > len (str) - make gtk, guile, webkit dependency optional, even if they are installed - fix for opening files with non-ascii names - much improved support for searching non-Latin (Cyrillic etc.) languages we can now match 'Тесла' or 'Аркона' without problems - smarter escaping (fixes issues with finding message ids) - fixes for queries with brackets - allow --summary-len for the length of message summaries - numerous other small fixes - much improved searching for GMail folders (i.e. maildir:/ matching); this requires a 'mu index --rebuild' - correctly handle utf-8 messages, even if they don't specify this explicitly - fix compiler warnings for newer/older gcc and clang/clang++ - fix unit tests (and some code) for Ubuntu 10.04 and FreeBSD9 - fix warnings for compilation with GTK+ 3.2 and recent glib (g_set_error) - fix mu_msg_move_to_maildir for top-level messages - fix in maildir scanning - plug some memleaks - fix output for some non-UTF8 locales - open ('play') file names with spaces - don't show unnecessary errors for --format=links - make build warning-free for clang/clang++ - allow for slightly older autotools - fix unit tests for some hidden assumptions (locale, dir structure etc.) - some documentation updates / clarifications Feature safe: yes
Notes
Notes: svn path=/head/; revision=307115
Diffstat (limited to 'mail/mu')
-rw-r--r--mail/mu/Makefile5
-rw-r--r--mail/mu/distinfo4
-rw-r--r--mail/mu/files/patch-mu-cmd-find.c11
3 files changed, 4 insertions, 16 deletions
diff --git a/mail/mu/Makefile b/mail/mu/Makefile
index 48fe8d2bf9cf..4df90f01c02a 100644
--- a/mail/mu/Makefile
+++ b/mail/mu/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mu
-PORTVERSION= 0.9.8.1
-PORTREVISION= 1
+PORTVERSION= 0.9.9
CATEGORIES= mail
MASTER_SITES= http://mu0.googlecode.com/files/
@@ -34,7 +33,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-gui=none
do-install:
- cd ${WRKSRC}/src && ${INSTALL_PROGRAM} mu ${PREFIX}/bin
+ cd ${WRKSRC}/mu && ${INSTALL_PROGRAM} mu ${PREFIX}/bin
cd ${FILESDIR} && ${INSTALL_SCRIPT} mu-ask ${PREFIX}/bin
cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1
cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN5} ${MANPREFIX}/man/man5
diff --git a/mail/mu/distinfo b/mail/mu/distinfo
index f01344761239..4ff9fbb1d288 100644
--- a/mail/mu/distinfo
+++ b/mail/mu/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mu-0.9.8.1.tar.gz) = 03423eb633e50ce589212001123dd12c8b09484f68ab1e33f5a8d2e203ea7963
-SIZE (mu-0.9.8.1.tar.gz) = 1004294
+SHA256 (mu-0.9.9.tar.gz) = 83f8e2814ba1a89a3153ab3dcd21105cc62e1386c176c5312ccb6bae0af02013
+SIZE (mu-0.9.9.tar.gz) = 1185624
diff --git a/mail/mu/files/patch-mu-cmd-find.c b/mail/mu/files/patch-mu-cmd-find.c
deleted file mode 100644
index 6b1b9d049cd2..000000000000
--- a/mail/mu/files/patch-mu-cmd-find.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/mu-cmd-find.c.orig 2012-03-02 23:03:51.892426975 +0400
-+++ src/mu-cmd-find.c 2012-03-02 23:04:27.156423697 +0400
-@@ -476,7 +476,7 @@
- return FALSE;
- }
-
-- if (count) {
-+ if (!count) {
- g_set_error (err, 0, MU_ERROR_NO_MATCHES,
- "no existing matches for search expression");
- return FALSE;