aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2019-08-14 19:20:15 +0000
committerAlex Kozlov <ak@FreeBSD.org>2019-08-14 19:20:15 +0000
commit623e89af516c93970827b31b3a87d4c3c2f2eee7 (patch)
tree0d125cc067da03b7939778b43f7b7b9545a9a329 /mail/mutt
parent395c588262fe759fce6395615e2c113444d191ea (diff)
downloadports-623e89af516c93970827b31b3a87d4c3c2f2eee7.tar.gz
ports-623e89af516c93970827b31b3a87d4c3c2f2eee7.zip
- Unbreak nntp patch
- Replace local vvv.quote patch with upstream one PR: 239864 Approved by: Derek Schrock <dereks@lifeofadishwasher.com> (maintainer)
Notes
Notes: svn path=/head/; revision=508963
Diffstat (limited to 'mail/mutt')
-rw-r--r--mail/mutt/Makefile7
-rw-r--r--mail/mutt/distinfo12
-rw-r--r--mail/mutt/files/extra-patch-vvv.quote81
3 files changed, 10 insertions, 90 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index a35d5d4e21c5..199b80e5a6c7 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -167,10 +167,9 @@ SMTP_CONFIGURE_ENABLE= smtp
GREETING_PATCH_PATCHFILES= mutt-${GREETING_PATCH_VERSION}.vc.greeting:vc
-QUOTE_PATCH_PATCHFILES= patch-${VVV_PATCH_VERSION}.vvv.initials.xz:vvv
-QUOTE_PATCH_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-vvv.quote
+QUOTE_PATCH_PATCHFILES= patch-${VVV_PATCH_VERSION}.vvv.initials.xz:vvv \
+ patch-${VVV_PATCH_VERSION}.vvv.quote.xz:vvv
-NNTP_BROKEN= NNTP broken with 1.12.0
NNTP_PATCHFILES= patch-${VVV_PATCH_VERSION}.vvv.nntp.xz:-p1:vvv
NNTP_EXTRA_PATCHES= ${PATCHDIR}/extra-nntp-depfiles
NNTP_CONFIGURE_ON= --enable-nntp
@@ -183,7 +182,7 @@ DOCS_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-doc-ref
.include <bsd.port.options.mk>
# un/comment as each VERSION is created for PORTVERSION
-VVV_PATCH_VERSION= 1.11.1
+#VVV_PATCH_VERSION= 1.12.1
GREETING_PATCH_VERSION= 1.12.0
.if !defined(VVV_PATCH_VERSION)
diff --git a/mail/mutt/distinfo b/mail/mutt/distinfo
index 46e825ef00a9..ab10e93129f2 100644
--- a/mail/mutt/distinfo
+++ b/mail/mutt/distinfo
@@ -1,9 +1,11 @@
-TIMESTAMP = 1560623854
+TIMESTAMP = 1565808330
SHA256 (mutt/mutt-1.12.1.tar.gz) = 01c565406ec4ffa85db90b45ece2260b25fac3646cc063bbc20a242c6ed4210c
SIZE (mutt/mutt-1.12.1.tar.gz) = 4675166
SHA256 (mutt/mutt-1.12.0.vc.greeting) = 7596d930447e9834567c0cfddf9ac023ecbb99add64bee4131d87e0260eec591
SIZE (mutt/mutt-1.12.0.vc.greeting) = 4559
-SHA256 (mutt/patch-1.11.1.vvv.nntp.xz) = 2a6386a82cbf9afde162bfb1989e545fb222bf40c5f6fac169d9249d4c904c79
-SIZE (mutt/patch-1.11.1.vvv.nntp.xz) = 49384
-SHA256 (mutt/patch-1.11.1.vvv.initials.xz) = af45defbda3a85f86db3f8ef5235ddb6613a36fdc35540cdc9afa38409114a07
-SIZE (mutt/patch-1.11.1.vvv.initials.xz) = 712
+SHA256 (mutt/patch-1.12.1.vvv.nntp.xz) = 9c420584d549ac0bb49c52ddfd2ab5bee0f89e59cb938673444ec27ad7c782ad
+SIZE (mutt/patch-1.12.1.vvv.nntp.xz) = 49672
+SHA256 (mutt/patch-1.12.1.vvv.initials.xz) = 6c66fe6c23362b0f4970a5028a75a33454e1e53ba178e5801113939f1bc22920
+SIZE (mutt/patch-1.12.1.vvv.initials.xz) = 724
+SHA256 (mutt/patch-1.12.1.vvv.quote.xz) = 365200817a203a892094062445865b7b8f9ab37e8214ec526082876ffd0d8ab4
+SIZE (mutt/patch-1.12.1.vvv.quote.xz) = 1332
diff --git a/mail/mutt/files/extra-patch-vvv.quote b/mail/mutt/files/extra-patch-vvv.quote
deleted file mode 100644
index 6e8f7c059233..000000000000
--- a/mail/mutt/files/extra-patch-vvv.quote
+++ /dev/null
@@ -1,81 +0,0 @@
---- PATCHES.orig 2019-06-15 21:17:01 UTC
-+++ PATCHES
-@@ -0,0 +1 @@
-+vvv.quote
---- handler.c.orig 2019-05-31 16:21:33 UTC
-+++ handler.c
-@@ -1593,7 +1593,31 @@ static int text_plain_handler (BODY *b, STATE *s)
- buf[--l] = 0;
- }
- if (s->prefix)
-- state_puts (s->prefix, s);
-+ {
-+ int i;
-+ char qbuf[2 * LONG_STRING];
-+ int j = 0, offset = 0;
-+ regmatch_t pmatch[1];
-+
-+ while (regexec ((regex_t *) QuoteRegexp.rx, &buf[offset], 1, pmatch, 0) == 0)
-+ offset += pmatch->rm_eo;
-+
-+ if (!option (OPTQUOTEEMPTY) && !*buf)
-+ strcpy (qbuf, buf);
-+ else if (option (OPTQUOTEQUOTED) && offset)
-+ {
-+ for (i = 0; i < offset; i++)
-+ if (buf[i] != ' ')
-+ j = i;
-+ strncpy (qbuf, buf, j + 1);
-+ strcpy (qbuf + j + 1, buf + j);
-+ }
-+ else
-+ snprintf (qbuf, sizeof (qbuf), "%s%s", NONULL(s->prefix), buf);
-+
-+ state_puts (qbuf, s);
-+ }
-+ else
- state_puts (buf, s);
- state_putc ('\n', s);
- }
-@@ -1779,7 +1803,7 @@ int mutt_body_handler (BODY *b, STATE *s)
- */
- if ((WithCrypto & APPLICATION_PGP) && mutt_is_application_pgp (b))
- encrypted_handler = handler = crypt_pgp_application_pgp_handler;
-- else if (option(OPTREFLOWTEXT) && ascii_strcasecmp ("flowed", mutt_get_parameter ("format", b->parameter)) == 0)
-+ else if (option(OPTREFLOWTEXT) && ascii_strcasecmp ("flowed", mutt_get_parameter ("format", b->parameter)) == 0 && !s->prefix)
- handler = rfc3676_handler;
- else
- handler = text_plain_handler;
---- init.h.orig 2019-06-15 21:17:01 UTC
-+++ init.h
-@@ -2745,6 +2745,19 @@ struct option_t MuttVars[] = {
- ** have no effect, and if it is set to \fIask-yes\fP or \fIask-no\fP, you are
- ** prompted for confirmation when you try to quit.
- */
-+ { "quote_empty", DT_BOOL, R_NONE, OPTQUOTEEMPTY, 1 },
-+ /*
-+ ** .pp
-+ ** Controls whether or not empty lines will be quoted using
-+ ** ``$indent_string''.
-+ */
-+ { "quote_quoted", DT_BOOL, R_NONE, OPTQUOTEQUOTED, 0 },
-+ /*
-+ ** .pp
-+ ** Controls how quoted lines will be quoted. If set, one quote
-+ ** character will be added to the end of existing prefix. Otherwise,
-+ ** quoted lines will be prepended by ``$indent_string''.
-+ */
- { "quote_regexp", DT_RX, R_PAGER, UL &QuoteRegexp, UL "^([ \t]*[|>:}#])+" },
- /*
- ** .pp
---- mutt.h.orig 2019-06-14 01:29:29 UTC
-+++ mutt.h
-@@ -479,6 +479,8 @@ enum
- OPTPRINTDECODE,
- OPTPRINTSPLIT,
- OPTPROMPTAFTER,
-+ OPTQUOTEEMPTY,
-+ OPTQUOTEQUOTED,
- OPTREADONLY,
- OPTREFLOWSPACEQUOTES,
- OPTREFLOWTEXT,