aboutsummaryrefslogtreecommitdiff
path: root/mail/neomutt
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-11-16 13:23:15 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-11-16 13:23:15 +0000
commit170f3fe4a8ca48c1e8e107cbb29aa635e9bd353e (patch)
tree73dfcde5ebbd044994edcfc17d6facb3805dbaab /mail/neomutt
parentedb15ab4e1fd8b3dddbe941edf3b593918f00297 (diff)
downloadports-170f3fe4a8ca48c1e8e107cbb29aa635e9bd353e.tar.gz
ports-170f3fe4a8ca48c1e8e107cbb29aa635e9bd353e.zip
Notes
Diffstat (limited to 'mail/neomutt')
-rw-r--r--mail/neomutt/Makefile28
1 files changed, 19 insertions, 9 deletions
diff --git a/mail/neomutt/Makefile b/mail/neomutt/Makefile
index a16ce2fb22e0..adb6fa7e543c 100644
--- a/mail/neomutt/Makefile
+++ b/mail/neomutt/Makefile
@@ -3,13 +3,13 @@
PORTNAME= neomutt
PORTVERSION= 20161104
DISTVERSIONPREFIX= ${PORTNAME}-
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail
MAINTAINER= bapt@FreeBSD.org
COMMENT= Bringing together all the Mutt Code
-LICENSE= GPLv1
+LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.md
RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:misc/mime-support \
@@ -26,13 +26,16 @@ SHEBANG_FILES= smime_keys.pl
OPTIONS_DEFINE= NLS DOCS SASL ICONV IDN FLOCK GPGME NOTMUCH
OPTIONS_DEFAULT=SASL TOKYOCABINET NOTMUCH GPGME
OPTIONS_RADIO= HCACHE
-OPTIONS_RADIO_HCACHE= TOKYOCABINET LMDB
+OPTIONS_RADIO_HCACHE= BDB GDBM KYOTOCABINET LMDB QDBM TOKYOCABINET
FLOCK_DESC= Use flock() to lock files
GPGME_DESC= Use gpgme to handle pgp
NOTMUCH_DESC= Use notmuch for tagging and searching
-TOKYOCABINET_DESC= Use TokyoCabinet as header-cache backend
-LMDB_DESC= Use LMDB as header-cache backend
+HCACHE_DESC= Header-cache backend
+KYOTOCABINET_DESC= Kyoto Cabinet support
+LMDB_DESC= Lightning Memory-Mapped Database support
+QDBM_DESC= Quick DataBase Manager support
+TOKYOCABINET_DESC= Tokyo Cabinet support
CONFIGURE_ARGS= --disable-dependency-tracking \
--with-docdir="${DOCSDIR}" \
@@ -44,16 +47,23 @@ CONFIGURE_ARGS= --disable-dependency-tracking \
--enable-compressed \
--enable-hcache \
--enable-sidebar \
- --without-qdbm \
--disable-fcntl \
--enable-external-dotlock
+# Header cache
+BDB_CONFIGURE_WITH= bdb
+BDB_USES= bdb
+GDBM_CONFIGURE_WITH= gdbm
+GDBM_LIB_DEPENDS= libgdbm.so:databases/gdbm
+KYOTOCABINET_CONFIGURE_WITH= kyotocabinet
+KYOTOCABINET_LIB_DEPENDS= libkyotocabinet.so:databases/kyotocabinet
+LMDB_CONFIGURE_WITH= lmdb
+LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
+QDBM_CONFIGURE_WITH= qdbm
+QDBM_LIB_DEPENDS= libqdbm.so:databases/qdbm
TOKYOCABINET_CONFIGURE_WITH= tokyocabinet
TOKYOCABINET_LIB_DEPENDS= libtokyocabinet.so:databases/tokyocabinet
-LMDB_CONFIGURE_WITH= lmdb
-LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
-
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
NLS_IMPLIES= ICONV