aboutsummaryrefslogtreecommitdiff
path: root/mail/nocc
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-05-22 22:18:34 +0000
committerPatrick Li <pat@FreeBSD.org>2002-05-22 22:18:34 +0000
commit7b2d90e535d0cbed020891c747cf14ed8f01ec9a (patch)
treedf69e2c994bd0683609050660167c72c05b524a7 /mail/nocc
parent12e4d426455063c94a7d250bb68ca71e518d1522 (diff)
downloadports-7b2d90e535d0cbed020891c747cf14ed8f01ec9a.tar.gz
ports-7b2d90e535d0cbed020891c747cf14ed8f01ec9a.zip
- Correct PREFIX/LOCALBASE
- Install with apache2 - add pkg-message - Add PHP disclaimer for IMAP support and register_globals PR: 38367 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=59736
Diffstat (limited to 'mail/nocc')
-rw-r--r--mail/nocc/Makefile35
-rw-r--r--mail/nocc/pkg-message6
-rw-r--r--mail/nocc/pkg-plist4
3 files changed, 29 insertions, 16 deletions
diff --git a/mail/nocc/Makefile b/mail/nocc/Makefile
index 0377321fbf71..0a7426ce1e16 100644
--- a/mail/nocc/Makefile
+++ b/mail/nocc/Makefile
@@ -13,31 +13,36 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sysadmin@alexdupre.com
-LIB_DEPENDS= c-client4.8:${PORTSDIR}/mail/cclient
-RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= ${LOCALBASE}/bin/php-config:${PORTSDIR}/www/mod_php4
NO_BUILD= yes
+pre-everything:
+ @${ECHO} ""
+ @${ECHO} "You have to configure PHP with IMAP support in order"
+ @${ECHO} "to let Nocc connect to your POP3/IMAP server."
+ @${ECHO} ""
+ @${ECHO} "If you have already compiled PHP without IMAP,"
+ @${ECHO} "press CTRL+C now and rebuild it before installing Nocc."
+ @${ECHO} ""
+
do-install:
- ${MKDIR} ${LOCALBASE}/www/nocc
+ ${MKDIR} ${PREFIX}/www/nocc
${CP} -Rp ${WRKSRC}/html ${WRKSRC}/lang ${WRKSRC}/themes \
- ${LOCALBASE}/www/nocc
- ${CP} -p ${WRKSRC}/*.php ${LOCALBASE}/www/nocc
- ${CP} -p ${WRKSRC}/conf.php.dist ${LOCALBASE}/www/nocc/conf.php
- ${CHOWN} -R www:www ${LOCALBASE}/www/nocc
+ ${PREFIX}/www/nocc
+ ${CP} -p ${WRKSRC}/*.php ${PREFIX}/www/nocc
+ ${CP} -p ${WRKSRC}/conf.php.dist ${PREFIX}/www/nocc
+ @if [ ! -f ${PREFIX}/www/nocc/conf.php ]; then \
+ ${CP} ${PREFIX}/www/nocc/conf.php.dist \
+ ${PREFIX}/www/nocc/conf.php; \
+ fi
+ ${CHOWN} -R www:www ${PREFIX}/www/nocc
.if !defined(NOPORTDOCS)
${INSTALL} -d -o ${DOCOWN} -g ${DOCGRP} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
.endif
post-install:
- @${ECHO} "****************************************************************"
- @${ECHO} "Nocc has been installed in ${LOCALBASE}/www/nocc directory."
- @${ECHO} "Change into this directory and make changes to the config"
- @${ECHO} "file (conf.php). The file is fairly well documented."
-.if !defined(NOPORTDOCS)
- @${ECHO} "All documentation has been located in ${DOCSDIR}."
-.endif
- @${ECHO} "****************************************************************"
+ @${SED} 's|%%PREFIX%%|${PREFIX}|' ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/mail/nocc/pkg-message b/mail/nocc/pkg-message
new file mode 100644
index 000000000000..6186a0d5561e
--- /dev/null
+++ b/mail/nocc/pkg-message
@@ -0,0 +1,6 @@
+****************************************************************
+Nocc has been installed in %%PREFIX%%/www/nocc directory.
+Change into this directory and make changes to the config
+file (conf.php). The file is fairly well documented.
+Also be sure that register_globals = On in the Nocc directory.
+****************************************************************
diff --git a/mail/nocc/pkg-plist b/mail/nocc/pkg-plist
index fdf53094bbdf..9c9e338769a6 100644
--- a/mail/nocc/pkg-plist
+++ b/mail/nocc/pkg-plist
@@ -3,7 +3,9 @@ www/nocc/check.php
www/nocc/check_lang.php
www/nocc/class_send.php
www/nocc/class_smtp.php
-www/nocc/conf.php
+@unexec if cmp -s %D/www/nocc/conf.php %D/www/nocc/conf.php.dist; then rm -f %D/www/nocc/conf.php; fi
+www/nocc/conf.php.dist
+@exec [ -f %B/conf.php ] || cp %B/%f %B/conf.php
www/nocc/conf_lang.php
www/nocc/delete.php
www/nocc/download.php