aboutsummaryrefslogtreecommitdiff
path: root/mail/notmuch-mutt/Makefile
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2018-02-27 05:01:28 +0000
committerDima Panov <fluffy@FreeBSD.org>2018-02-27 05:01:28 +0000
commited2a6eb1387c9bf7f1ad02759ccf70e145a2e516 (patch)
treeb1d7da9b02b6d7dc8db35785f60c9ebeb7102edf /mail/notmuch-mutt/Makefile
parent4f1b9160a46d92a4b74d8df36158b9c219e21238 (diff)
downloadports-ed2a6eb1387c9bf7f1ad02759ccf70e145a2e516.tar.gz
ports-ed2a6eb1387c9bf7f1ad02759ccf70e145a2e516.zip
Notes
Diffstat (limited to 'mail/notmuch-mutt/Makefile')
-rw-r--r--mail/notmuch-mutt/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/mail/notmuch-mutt/Makefile b/mail/notmuch-mutt/Makefile
new file mode 100644
index 000000000000..40b75608c2ed
--- /dev/null
+++ b/mail/notmuch-mutt/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+CATEGORIES= mail
+PKGNAMESUFFIX= -mutt
+
+COMMENT= Integrates the Notmuch email search and tagging application with Mutt
+
+RUN_DEPENDS= mutt:mail/mutt \
+ notmuch:mail/notmuch \
+ p5-Mail-Box>0:mail/p5-Mail-Box \
+ p5-Mail-Tools>0:mail/p5-Mail-Tools \
+ p5-String-ShellQuote>0:textproc/p5-String-ShellQuote \
+ p5-Term-ReadLine-Gnu>0:devel/p5-Term-ReadLine-Gnu
+
+USES= gmake perl5
+
+MASTERDIR= ${.CURDIR}/../notmuch
+NO_ARCH= yes
+WRKSRC_SUBDIR= contrib/notmuch-mutt
+
+OPTIONS_DEFINE= EXAMPLES MANPAGES
+OPTIONS_DEFAULT= MANPAGES
+OPTIONS_SUB= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/notmuch-mutt ${STAGEDIR}${PREFIX}/bin
+
+do-install-EXAMPLES-on:
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/notmuch-mutt.rc ${STAGEDIR}${EXAMPLESDIR}/notmuch-mutt.rc
+
+do-install-MANPAGES-on:
+ ${INSTALL_MAN} ${WRKSRC}/notmuch-mutt.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include "${MASTERDIR}/Makefile"