aboutsummaryrefslogtreecommitdiff
path: root/mail/notmuch
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-03-04 04:35:13 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-03-04 04:35:13 +0000
commit68473044503f657cee9de1d6822e4250b99c1aa8 (patch)
tree30e6dd22a85e19e14a334164c22e1c6833c7198f /mail/notmuch
parent021f4bb6fb3936ea910661de5a3638699e06aea6 (diff)
downloadports-68473044503f657cee9de1d6822e4250b99c1aa8.tar.gz
ports-68473044503f657cee9de1d6822e4250b99c1aa8.zip
mail/notmuch: unbreak with libc++ 8
In file included from lib/database.cc:21: In file included from ./lib/database-private.h:39: In file included from /usr/local/include/xapian.h:56: In file included from /usr/local/include/xapian/error.h:30: In file included from /usr/include/c++/v1/string:505: In file included from /usr/include/c++/v1/string_view:176: In file included from /usr/include/c++/v1/__string:57: In file included from /usr/include/c++/v1/algorithm:640: In file included from /usr/include/c++/v1/initializer_list:47: In file included from /usr/include/c++/v1/cstddef:38: ./version:1:1: error: expected unqualified-id 0.28.1 ^ PR: 236192 Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=494546
Diffstat (limited to 'mail/notmuch')
-rw-r--r--mail/notmuch/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/mail/notmuch/Makefile b/mail/notmuch/Makefile
index 38dedd3bb68c..994e033d06d9 100644
--- a/mail/notmuch/Makefile
+++ b/mail/notmuch/Makefile
@@ -60,6 +60,11 @@ DOXYGEN_CONFIGURE_WITH= api-docs
MANPAGES_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
MANPAGES_CONFIGURE_WITH= docs
+post-patch:
+# Avoid conflict with C++20 <version> by ignoring <...> under WRKSRC
+ @${REINPLACE_CMD} -i .c++20 's/-I$$(srcdir)/-iquote$$(srcdir)/' \
+ ${WRKSRC}/*/Makefile.local
+
# Install bash completions without incurring a dependcy on
# shells/bash-completion. Also avoid automatic installation of
# info pages on FreeBSD 10.