aboutsummaryrefslogtreecommitdiff
path: root/mail/notmuch
diff options
context:
space:
mode:
authorMikhail Pchelin <misha@FreeBSD.org>2016-12-24 22:05:54 +0000
committerMikhail Pchelin <misha@FreeBSD.org>2016-12-24 22:05:54 +0000
commit71f5bf222b7cf7fba1ed972b211fed484996d253 (patch)
tree20229a7256c94a961b7c4aee7e8a7edfc20a121d /mail/notmuch
parent552d2124a77340e54f27b5b72da46556d32c00be (diff)
downloadports-71f5bf222b7cf7fba1ed972b211fed484996d253.tar.gz
ports-71f5bf222b7cf7fba1ed972b211fed484996d253.zip
- update from 0.23.3 to 0.23.4
- update TEST_DEPENDS - patch port's test infrastructure to use GNU coreutils Approved by: jpaetzel (mentor)
Notes
Notes: svn path=/head/; revision=429382
Diffstat (limited to 'mail/notmuch')
-rw-r--r--mail/notmuch/Makefile22
-rw-r--r--mail/notmuch/distinfo6
-rw-r--r--mail/notmuch/files/patch-test_test-lib-common.sh19
3 files changed, 35 insertions, 12 deletions
diff --git a/mail/notmuch/Makefile b/mail/notmuch/Makefile
index 1444f8da8c84..ba5c4a449b73 100644
--- a/mail/notmuch/Makefile
+++ b/mail/notmuch/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= notmuch
-PORTVERSION= 0.23.3
+PORTVERSION= 0.23.4
CATEGORIES= mail
MASTER_SITES= http://notmuchmail.org/releases/
@@ -19,7 +19,13 @@ LIB_DEPENDS= libgmime-2.6.so:mail/gmime26 \
TEST_DEPENDS= bash:shells/bash \
emacs:editors/emacs-nox11 \
dtach:misc/dtach \
- base64:converters/base64
+ gdate:sysutils/coreutils \
+ gbase64:sysutils/coreutils \
+ gwc:sysutils/coreutils \
+ gsed:sysutils/coreutils \
+ gsha256sum:sysutils/coreutils \
+ gpg:security/gnupg \
+ ${PREFIX}/bin/gdb:devel/gdb
BROKEN_powerpc64= Does not build
@@ -31,13 +37,11 @@ USE_LDCONFIG= yes
MAKE_ENV+= PYTHONCMD=${PYTHON_CMD}
-## a lot of tests are failing because they're Linux oriented and need
-## some tweaking to run on FreeBSD
-TEST_ENV+= NOTMUCH_SKIP_TESTS="basic new count insert tagging json sexp \
- emacs emacs-large-search-buffer crypto smime atomicity ruby \
- parse-time-string upgrade thread-search thread-breakage \
- message-property lock" V=1 \
- TEST_CFLAGS="-g -O0 -I${LOCALBASE}/include -L${LOCALBASE}/lib"
+TEST_ENV+= NOTMUCH_SKIP_TESTS="basic count insert smime atomicity \
+ message-property" \
+ V=1 \
+ TEST_CFLAGS="-g -O0 -I${LOCALBASE}/include -L${LOCALBASE}/lib" \
+ BSD_GDB=${PREFIX}/bin/gdb
TEST_TARGET= test
diff --git a/mail/notmuch/distinfo b/mail/notmuch/distinfo
index 8750636d9f1c..ed14ba2607a6 100644
--- a/mail/notmuch/distinfo
+++ b/mail/notmuch/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1481130627
-SHA256 (notmuch-0.23.3.tar.gz) = 0f5da5cf0203b774e345c50d56e975a87c2fc5407ef4ea284b6e2b55a8951882
-SIZE (notmuch-0.23.3.tar.gz) = 691361
+TIMESTAMP = 1482605015
+SHA256 (notmuch-0.23.4.tar.gz) = 106dd6e39c4955871a49a84488d06394c1cecf66c1542b11834f8e8d5c66453b
+SIZE (notmuch-0.23.4.tar.gz) = 691851
diff --git a/mail/notmuch/files/patch-test_test-lib-common.sh b/mail/notmuch/files/patch-test_test-lib-common.sh
new file mode 100644
index 000000000000..8da1d3e8cc57
--- /dev/null
+++ b/mail/notmuch/files/patch-test_test-lib-common.sh
@@ -0,0 +1,19 @@
+--- test/test-lib-common.sh.orig 2016-12-24 18:44:17 UTC
++++ test/test-lib-common.sh
+@@ -24,6 +24,16 @@
+ #
+ type die >/dev/null 2>&1 || die () { echo "$@" >&2; exit 1; }
+
++# allow using aliases in scripts
++shopt -s expand_aliases
++
++alias date=gdate
++alias base64=gbase64
++alias gdb=$BSD_GDB
++alias wc=gwc
++alias sed=gsed
++alias sha256sum=gsha256sum
++
+ find_notmuch_path ()
+ {
+ dir="$1"