aboutsummaryrefslogtreecommitdiff
path: root/mail/opendkim
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2018-10-20 10:51:30 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2018-10-20 10:51:30 +0000
commita4f96acfe1ba621a1648d5d21a1874c23d52ceec (patch)
treee9c1cde07acb2e80e2780298411f2880ace63889 /mail/opendkim
parentbb32f2bab837121f4bf472734c0173aaa9b34373 (diff)
downloadports-a4f96acfe1ba621a1648d5d21a1874c23d52ceec.tar.gz
ports-a4f96acfe1ba621a1648d5d21a1874c23d52ceec.zip
Update devel/py-pygit2 to version 0.27.2.
Changelog: https://github.com/libgit2/pygit2/blob/v0.27.2/CHANGELOG.rst Reported by: PORTSCOUT Approved by: mentors (implicit)
Notes
Notes: svn path=/head/; revision=482484
Diffstat (limited to 'mail/opendkim')
-rw-r--r--mail/opendkim/files/patch-configure.ac50
-rw-r--r--mail/opendkim/files/patch-opendkim_opendkim-crypto.c30
2 files changed, 80 insertions, 0 deletions
diff --git a/mail/opendkim/files/patch-configure.ac b/mail/opendkim/files/patch-configure.ac
new file mode 100644
index 000000000000..ee6e16d590b4
--- /dev/null
+++ b/mail/opendkim/files/patch-configure.ac
@@ -0,0 +1,50 @@
+--- configure.ac.orig 2015-05-12 18:43:09 UTC
++++ configure.ac
+@@ -860,26 +860,28 @@ then
+ AC_SEARCH_LIBS([ERR_peek_error], [crypto], ,
+ AC_MSG_ERROR([libcrypto not found]))
+
+- AC_SEARCH_LIBS([SSL_library_init], [ssl], ,
+- [
+- if test x"$enable_shared" = x"yes"
+- then
+- AC_MSG_ERROR([Cannot build shared opendkim
+- against static openssl libraries.
+- Configure with --disable-shared
+- to get this working or obtain a
+- shared libssl library for
+- opendkim to use.])
+- fi
+
+- # avoid caching issue - last result of SSL_library_init
+- # shouldn't be cached for this next check
+- unset ac_cv_search_SSL_library_init
+- LIBCRYPTO_LIBS="$LIBCRYPTO_LIBS -ldl"
+- AC_SEARCH_LIBS([SSL_library_init], [ssl], ,
+- AC_MSG_ERROR([libssl not found]), [-ldl])
+- ]
+- )
++ AC_LINK_IFELSE(
++ [AC_LANG_PROGRAM([[#include <openssl/ssl.h>]],
++ [[SSL_library_init();]])],
++ [od_have_ossl="yes";],
++ [od_have_ossl="no";])
++ if test x"$od_have_ossl" = x"no"
++ then
++ if test x"$enable_shared" = x"yes"
++ then
++ AC_MSG_ERROR([Cannot build shared opendkim
++ against static openssl libraries.
++ Configure with --disable-shared
++ to get this working or obtain a
++ shared libssl library for
++ opendkim to use.])
++ fi
++
++ LIBCRYPTO_LIBS="$LIBCRYPTO_LIBS -ldl"
++ AC_SEARCH_LIBS([SSL_library_init], [ssl], ,
++ AC_MSG_ERROR([libssl not found]), [-ldl])
++ fi
+
+ AC_CHECK_DECL([SHA256_DIGEST_LENGTH],
+ AC_DEFINE([HAVE_SHA256], 1,
diff --git a/mail/opendkim/files/patch-opendkim_opendkim-crypto.c b/mail/opendkim/files/patch-opendkim_opendkim-crypto.c
new file mode 100644
index 000000000000..db35223e00a5
--- /dev/null
+++ b/mail/opendkim/files/patch-opendkim_opendkim-crypto.c
@@ -0,0 +1,30 @@
+--- opendkim/opendkim-crypto.c.orig 2013-02-25 21:02:41 UTC
++++ opendkim/opendkim-crypto.c
+@@ -222,7 +222,11 @@ dkimf_crypto_free_id(void *ptr)
+ {
+ assert(pthread_setspecific(id_key, ptr) == 0);
+
++#if OPENSSL_VERSION_NUMBER >= 0x10100000
++ OPENSSL_thread_stop();
++#else
+ ERR_remove_state(0);
++#endif
+
+ free(ptr);
+
+@@ -392,11 +396,15 @@ dkimf_crypto_free(void)
+ {
+ if (crypto_init_done)
+ {
++#if OPENSSL_VERSION_NUMBER >= 0x10100000
++ OPENSSL_thread_stop();
++#else
+ CRYPTO_cleanup_all_ex_data();
+ CONF_modules_free();
+ EVP_cleanup();
+ ERR_free_strings();
+ ERR_remove_state(0);
++#endif
+
+ if (nmutexes > 0)
+ {