aboutsummaryrefslogtreecommitdiff
path: root/mail/opendmarc/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-03-16 10:59:17 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-03-16 10:59:17 +0000
commit1a7310b8abcd4407aa61892d13a194f30afa6c5a (patch)
treec15155ee45a65e408ba62dd13fa139d5030b6531 /mail/opendmarc/Makefile
parentaeb33cc3b4364944c90f83fdcf6ccbe48065137f (diff)
downloadports-1a7310b8abcd4407aa61892d13a194f30afa6c5a.tar.gz
ports-1a7310b8abcd4407aa61892d13a194f30afa6c5a.zip
Notes
Diffstat (limited to 'mail/opendmarc/Makefile')
-rw-r--r--mail/opendmarc/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/mail/opendmarc/Makefile b/mail/opendmarc/Makefile
index 9ecbf86a492b..bad83d78f83c 100644
--- a/mail/opendmarc/Makefile
+++ b/mail/opendmarc/Makefile
@@ -2,16 +2,16 @@
# $FreeBSD$
PORTNAME= opendmarc
-PORTVERSION= 1.1.3
+PORTVERSION= 1.2.0
CATEGORIES= mail security
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME} \
${PORTNAME}/Previous%20Releases
MAINTAINER= jaap@NLnetLabs.nl
-COMMENT= DMARC library an milter implementation
+COMMENT= DMARC library and milter implementation
-LICENSE= BSD SENDMAIL
+LICENSE= BSD3CLAUSE SENDMAIL
LICENSE_COMB= multi
LICENSE_FILE_SENDMAIL= ${WRKSRC}/LICENSE.Sendmail
@@ -19,20 +19,23 @@ LICENSE_GROUPS_SENDMAIL= FSF OSI
LICENSE_NAME_SENDMAIL= Sendmail Open Source License
LICENSE_PERMS_SENDMAIL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+USES= shebangfix
+SHEBANG_FILES= reports/opendmarc-expire.in \
+ reports/opendmarc-import.in \
+ reports/opendmarc-params.in \
+ reports/opendmarc-reports.in
+
USE_RC_SUBR= opendmarc
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
PORTDOCS= *
-MAN5= opendmarc.conf.5
-MAN8= opendmarc-check.8 opendmarc-expire.8 opendmarc-import.8 \
- opendmarc-params.8 opendmarc-reports.8 opendmarc.8
-NO_STAGE= yes
post-install:
- @${MKDIR} ${PREFIX}/etc/mail
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/mail
${INSTALL_DATA} \
- ${WRKSRC}/opendmarc/opendmarc.conf.sample ${PREFIX}/etc/mail
+ ${WRKSRC}/opendmarc/opendmarc.conf.sample ${STAGEDIR}${PREFIX}/etc/mail
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libopendmarc.so.1
.include <bsd.port.mk>