aboutsummaryrefslogtreecommitdiff
path: root/mail/opendmarc
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-10-27 05:04:54 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-10-27 05:04:54 +0000
commitbdb34983c48722373fc58c9f3434824981879f75 (patch)
tree6c133df63a95ae7c68f3cfb95128884a0ce0fd8d /mail/opendmarc
parent195392316e87580901f2a6f650ada9cdf4749924 (diff)
downloadports-bdb34983c48722373fc58c9f3434824981879f75.tar.gz
ports-bdb34983c48722373fc58c9f3434824981879f75.zip
mail/opendmarc: Add libspf2 as a run-time (library) dependency
libsfp2 is a build and run-time dependency for opendmarc. Currently libspf2 is declared a BUILD_DEPENDS, which results in the libspf2 package being removed by portmaster or pkg as an unecessary package when using -s argument or autoremove command respectively. This change correctly declares libspf2 as a LIB_DEPENDS, resulting in both build and run-time dependency registration. While I'm here: - Convert MSPF conditional to an option helper - Group and sort USE{S} entries - Whitespace align OPTIONS - Tweak SPF_DESC to match ./configure output for the option - Sort pkg-plist PR: 204050 Submitted by: Douglas <douglas douglasthrift net> Approved by: portmgr (blanket) MFH: 2015Q4
Notes
Notes: svn path=/head/; revision=400214
Diffstat (limited to 'mail/opendmarc')
-rw-r--r--mail/opendmarc/Makefile39
-rw-r--r--mail/opendmarc/pkg-plist14
2 files changed, 26 insertions, 27 deletions
diff --git a/mail/opendmarc/Makefile b/mail/opendmarc/Makefile
index 8e255081cfe5..032b1d075f5c 100644
--- a/mail/opendmarc/Makefile
+++ b/mail/opendmarc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= opendmarc
PORTVERSION= 1.3.1
+PORTREVISION= 1
CATEGORIES= mail security
MASTER_SITES= SF/${PORTNAME} \
SF/${PORTNAME}/Previous%20Releases
@@ -18,34 +19,32 @@ LICENSE_GROUPS_SENDMAIL= FSF OSI
LICENSE_NAME_SENDMAIL= Sendmail Open Source License
LICENSE_PERMS_SENDMAIL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-.if !exists( /usr/include/libmilter/mfapi.h )
-BUILD_DEPENDS+= ${LOCALBASE}/include/libmilter/mfapi.h:${PORTSDIR}/mail/sendmail
-CFLAGS+= -I${LOCALBASE}/include
-.endif
-
USES= libtool shebangfix
-SHEBANG_FILES= reports/opendmarc-expire.in \
- reports/opendmarc-import.in \
- reports/opendmarc-params.in \
- reports/opendmarc-reports.in
-
-USE_RC_SUBR= opendmarc
USE_LDCONFIG= yes
+USE_RC_SUBR= opendmarc
-GNU_CONFIGURE= yes
-
-PORTDOCS= *
+GNU_CONFIGURE= yes
-OPTIONS_DEFINE= SPF
+OPTIONS_DEFINE= SPF
OPTIONS_DEFAULT= SPF
-SPF_DESC= Include direct SPF checking support
-SPF_BUILD_DEPENDS+= libspf2>=1.2.5:${PORTSDIR}/mail/libspf2
+SPF_DESC= Enable support for SPF record checking
+
+SPF_LIB_DEPENDS= libspf2.so:${PORTSDIR}/mail/libspf2
+SPF_CONFIGURE_ON= --with-spf \
+ --with-spf2-include=${LOCALBASE}/include/spf2 \
+ --with-spf2-lib=${LOCALBASE}/lib
+
+SHEBANG_FILES= reports/opendmarc-expire.in \
+ reports/opendmarc-import.in \
+ reports/opendmarc-params.in \
+ reports/opendmarc-reports.in
-.include <bsd.port.options.mk>
+PORTDOCS= *
-.if ${PORT_OPTIONS:MSPF}
-CONFIGURE_ARGS+= --with-spf --with-spf2-include=${LOCALBASE}/include/spf2 --with-spf2-lib=${LOCALBASE}/lib
+.if !exists( /usr/include/libmilter/mfapi.h )
+BUILD_DEPENDS+= ${LOCALBASE}/include/libmilter/mfapi.h:${PORTSDIR}/mail/sendmail
+CFLAGS+= -I${LOCALBASE}/include
.endif
post-install:
diff --git a/mail/opendmarc/pkg-plist b/mail/opendmarc/pkg-plist
index 4d36d9bb653b..8d4e636e03c0 100644
--- a/mail/opendmarc/pkg-plist
+++ b/mail/opendmarc/pkg-plist
@@ -1,17 +1,17 @@
+etc/mail/opendmarc.conf.sample
+include/opendmarc/dmarc.h
+lib/libopendmarc.a
+lib/libopendmarc.so
+lib/libopendmarc.so.2
+lib/libopendmarc.so.2.0.1
man/man5/opendmarc.conf.5.gz
man/man8/opendmarc-check.8.gz
man/man8/opendmarc-expire.8.gz
man/man8/opendmarc-import.8.gz
+man/man8/opendmarc-importstats.8.gz
man/man8/opendmarc-params.8.gz
man/man8/opendmarc-reports.8.gz
man/man8/opendmarc.8.gz
-man/man8/opendmarc-importstats.8.gz
-etc/mail/opendmarc.conf.sample
-include/opendmarc/dmarc.h
-lib/libopendmarc.a
-lib/libopendmarc.so.2
-lib/libopendmarc.so.2.0.1
-lib/libopendmarc.so
sbin/opendmarc
sbin/opendmarc-check
sbin/opendmarc-expire