aboutsummaryrefslogtreecommitdiff
path: root/mail/opensmtpd-extras-filter-regex
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2016-04-16 16:49:21 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2016-04-16 16:49:21 +0000
commit24ea943106d3111a054d3475f3c6ec410461c037 (patch)
treec3f1da6a645db1459b206f63f511b29643afc195 /mail/opensmtpd-extras-filter-regex
parentf8eb8a9827942222faddbb7d15a7af9c41d0b328 (diff)
Notes
Diffstat (limited to 'mail/opensmtpd-extras-filter-regex')
-rw-r--r--mail/opensmtpd-extras-filter-regex/Makefile26
-rw-r--r--mail/opensmtpd-extras-filter-regex/pkg-plist4
2 files changed, 30 insertions, 0 deletions
diff --git a/mail/opensmtpd-extras-filter-regex/Makefile b/mail/opensmtpd-extras-filter-regex/Makefile
new file mode 100644
index 000000000000..82d05637c279
--- /dev/null
+++ b/mail/opensmtpd-extras-filter-regex/Makefile
@@ -0,0 +1,26 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PKGNAMESUFFIX= -filter-regex
+
+COMMENT= Regular expression filter for OpenSMTPD
+MAINTAINER= adamw@FreeBSD.org
+
+CONFIGURE_ARGS+= --with-filter-regex
+
+PLIST= ${.CURDIR}/pkg-plist
+MASTERDIR= ${.CURDIR}/../opensmtpd-extras
+SLAVE_PORT= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|/etc/mail/filter-regex.conf|${PREFIX}&|' \
+ ${WRKSRC}/extras/wip/filters/filter-regex/filter_regex.c \
+ ${WRKSRC}/extras/wip/filters/filter-regex/filter-regex.8
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/mail
+ ${INSTALL_DATA} ${WRKSRC}/extras/wip/filters/filter-regex/filter-regex.conf \
+ ${STAGEDIR}${PREFIX}/etc/mail/filter-regex.conf.sample
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/opensmtpd-extras-filter-regex/pkg-plist b/mail/opensmtpd-extras-filter-regex/pkg-plist
new file mode 100644
index 000000000000..f6f5757e5f51
--- /dev/null
+++ b/mail/opensmtpd-extras-filter-regex/pkg-plist
@@ -0,0 +1,4 @@
+@sample etc/mail/filter-regex.conf.sample
+libexec/opensmtpd/filter-regex
+man/man5/filter-regex.conf.5.gz
+man/man8/filter-regex.8.gz