aboutsummaryrefslogtreecommitdiff
path: root/mail/opensmtpd-filter-rspamd
diff options
context:
space:
mode:
authorEmmanuel Vadot <manu@FreeBSD.org>2020-01-18 16:17:30 +0000
committerEmmanuel Vadot <manu@FreeBSD.org>2020-01-18 16:17:30 +0000
commit70264ea69716b4516a9646142c81c7b43901cbfd (patch)
tree005e1c481a82b98e5d597b7f01441528ee563dc1 /mail/opensmtpd-filter-rspamd
parenteff8e4450cb03241436069e8061bde0438820f28 (diff)
downloadports-70264ea69716b4516a9646142c81c7b43901cbfd.tar.gz
ports-70264ea69716b4516a9646142c81c7b43901cbfd.zip
mail/opensmtpd-filter-rspamd: New Port
This filter can talk to rspamd and do spam filtering, dkim signing etc ...
Notes
Notes: svn path=/head/; revision=523421
Diffstat (limited to 'mail/opensmtpd-filter-rspamd')
-rw-r--r--mail/opensmtpd-filter-rspamd/Makefile28
-rw-r--r--mail/opensmtpd-filter-rspamd/distinfo3
-rw-r--r--mail/opensmtpd-filter-rspamd/pkg-descr4
3 files changed, 35 insertions, 0 deletions
diff --git a/mail/opensmtpd-filter-rspamd/Makefile b/mail/opensmtpd-filter-rspamd/Makefile
new file mode 100644
index 000000000000..48c3f8bcf0b0
--- /dev/null
+++ b/mail/opensmtpd-filter-rspamd/Makefile
@@ -0,0 +1,28 @@
+# Created by: Emmanuel Vadot <manu@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= opensmtpd-filter-rspamd
+PORTVERSION= 0.1.5
+CATEGORIES= mail
+
+MAINTAINER= manu@FreeBSD.Org
+COMMENT= OpenSMTPD filter integration for the Rspamd daemon
+
+LICENSE= ISCL
+
+RUN_DEPENDS= opensmtpd>=6.6.0:mail/opensmtpd \
+ rspamd>=0:mail/rspamd
+
+USES= go
+
+USE_GITHUB= yes
+GH_ACCOUNT= poolpOrg
+GH_PROJECT= filter-rspamd
+
+PLIST_FILES= libexec/opensmtpd/opensmtpd-filter-rspamd
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/opensmtpd/
+ ${INSTALL_PROGRAM} ${WRKDIR}/bin/opensmtpd-filter-rspamd ${STAGEDIR}${PREFIX}/libexec/opensmtpd/
+
+.include <bsd.port.mk>
diff --git a/mail/opensmtpd-filter-rspamd/distinfo b/mail/opensmtpd-filter-rspamd/distinfo
new file mode 100644
index 000000000000..055252a753ec
--- /dev/null
+++ b/mail/opensmtpd-filter-rspamd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579362884
+SHA256 (poolpOrg-filter-rspamd-0.1.5_GH0.tar.gz) = adb781be19952718bb240bea3d6368a71f0ecf22cb14f647ba99330035c20621
+SIZE (poolpOrg-filter-rspamd-0.1.5_GH0.tar.gz) = 5314
diff --git a/mail/opensmtpd-filter-rspamd/pkg-descr b/mail/opensmtpd-filter-rspamd/pkg-descr
new file mode 100644
index 000000000000..3c26d015d408
--- /dev/null
+++ b/mail/opensmtpd-filter-rspamd/pkg-descr
@@ -0,0 +1,4 @@
+This filter implements the Rspamd protocol and allows OpenSMTPD to request an
+Rspamd analysis of an SMTP transaction before a message is committed to queue.
+
+WWW: https://github.com/poolpOrg/filter-rspamd