aboutsummaryrefslogtreecommitdiff
path: root/mail/opensmtpd
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-19 12:40:53 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-19 12:40:53 +0000
commit8b127f2619ddc8606b517b3afe38803c947da3ec (patch)
treebe003283f4d6d47d28fc77ec937cea8ca2403ca2 /mail/opensmtpd
parent40a7fe6dcb048791000a443cb2ce81033ec2ccd2 (diff)
downloadports-8b127f2619ddc8606b517b3afe38803c947da3ec.tar.gz
ports-8b127f2619ddc8606b517b3afe38803c947da3ec.zip
- Drop dependency on autoconf and automake
- Use correct form of OPTIONS_SUB - Remove FreeBSD 7 support - Remove post-deinstall (handled by pkg)
Notes
Notes: svn path=/head/; revision=368555
Diffstat (limited to 'mail/opensmtpd')
-rw-r--r--mail/opensmtpd/Makefile16
1 files changed, 2 insertions, 14 deletions
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index a0be309f12ea..500f3c57833c 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -24,7 +24,7 @@ OPTIONS_DEFAULT= CA_BUNDLE PAM
CA_BUNDLE_DESC= Install CA bundle for OpenSSL
USES= libtool
-USE_AUTOTOOLS= autoconf:env automake:env
+USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libevent-dir=${LOCALBASE} --sysconfdir=${PREFIX}/etc/mail/ \
--with-mailwrapper
@@ -37,7 +37,7 @@ CONFLICTS_INSTALL= postfix-[0-9]* sendmail-[0-9]* opensmtpd-devel-[0-9]*
USERS= _smtpd _smtpq
GROUPS= _smtpd
-OPTIONS_SUB= MYSQL SQLITE PGSQL LDAP REDIS
+OPTIONS_SUB= yes
CA_BUNDLE_CONFIGURE_ON= --with-ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
@@ -62,16 +62,4 @@ PAM_CONFIGURE_ON= --with-pam --with-pam-service=smtpd
REDIS_LIB_DEPENDS= libhiredis.so:${PORTSDIR}/databases/hiredis
REDIS_CONFIGURE_ON= --with-experimental-redis
-.include <bsd.port.options.mk>
-
-USE_OPENSSL= yes
-
-# FreeBSD 7.3 and earlier need to use OpenSSL from ports
-.if ${OSVERSION} < 704000
-WITH_OPENSSL_PORT= yes
-.endif
-
-post-deinstall:
- @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-DEINSTALL
-
.include <bsd.port.mk>