aboutsummaryrefslogtreecommitdiff
path: root/mail/opensmtpd
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2016-02-25 14:19:16 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2016-02-25 14:19:16 +0000
commitc204955df419d0348787c1143e1904d4a8c69a25 (patch)
tree1762c8923fc25ac6e4c66dea09b952309e5986a8 /mail/opensmtpd
parenta274b094df9a743487dc9055cac92fcc80f44ce7 (diff)
downloadports-c204955df419d0348787c1143e1904d4a8c69a25.tar.gz
ports-c204955df419d0348787c1143e1904d4a8c69a25.zip
- Add SSL_PORT option to specify if OpenSSL from ports is to be used[1]
- Make option descriptions generic[1] - Cleanup OPTIONS[1] - Enforce SSL_PORT for 9.x[1] - Mark as broken with LIBASRDEVEL option, due to incompatibility PR: 206523[1] Submitted by: Andrey Fesenko <andrey at bsdnir dot info>[1]
Notes
Notes: svn path=/head/; revision=409520
Diffstat (limited to 'mail/opensmtpd')
-rw-r--r--mail/opensmtpd/Makefile25
1 files changed, 18 insertions, 7 deletions
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index 1cc659091c65..3573ca2e6020 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= opensmtpd
PORTVERSION= 5.7.3
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
@@ -18,18 +18,18 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
-OPTIONS_DEFINE= CA_BUNDLE LIBASRDEVEL MAILERCONF PAM TABLE_DB
+OPTIONS_DEFINE= CA_BUNDLE LIBASRDEVEL MAILERCONF PAM SSL_PORT TABLE_DB
OPTIONS_DEFAULT= CA_BUNDLE PAM TABLE_DB
-CA_BUNDLE_DESC= Install CA bundle for OpenSSL
+CA_BUNDLE_DESC= Install CA bundle for SSL
LIBASRDEVEL_DESC= Use development version of libasr
MAILERCONF_DESC= Activate OpenSMTPD in mailer.conf(5)
+SSL_PORT_DESC= SSL/TLS support via OpenSSL/LibreSSL from port
TABLE_DB_DESC= Build table-db plugin (aliases)
USES= cpe libtool
USE_OPENSSL= yes
-WITH_OPENSSL_PORT= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libevent-dir=${LOCALBASE} --sysconfdir=${PREFIX}/etc/mail/ \
--with-mailwrapper --with-ssl-dir=${OPENSSLBASE}
@@ -46,14 +46,25 @@ GROUPS= _smtpd
OPTIONS_SUB= yes
-CA_BUNDLE_CONFIGURE_ON= --with-ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
+CA_BUNDLE_CONFIGURE_WITH= ca-file=${LOCALBASE}/share/certs/ca-root-nss.crt
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
LIBASRDEVEL_LIB_DEPENDS_OFF= libasr.so:${PORTSDIR}/dns/libasr
LIBASRDEVEL_LIB_DEPENDS= libasr.so:${PORTSDIR}/dns/libasr-devel
+LIBASRDEVEL_BROKEN= incompatible with libasr-devel
+
+PAM_CONFIGURE_WITH= pam pam-service=smtpd
+
+TABLE_DB_CONFIGURE_ENABLE= table-db
-PAM_CONFIGURE_ON= --with-pam --with-pam-service=smtpd
+.include <bsd.port.options.mk>
-TABLE_DB_CONFIGURE_ON= --enable-table-db
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000 && ! ${PORT_OPTIONS:MSSL_PORT}
+WITH_OPENSSL_PORT= yes
+.endif
+
+.if ${PORT_OPTIONS:MSSL_PORT}
+WITH_OPENSSL_PORT= yes
+.endif
.include <bsd.port.mk>