aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Email-Date
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-07-26 22:11:18 +0000
committerLars Thegler <lth@FreeBSD.org>2004-07-26 22:11:18 +0000
commite68b94fa0801ac021037399be304d6cc977fbc7b (patch)
tree380388c4285f3faa38ebdc5fb697d6515b9beaaf /mail/p5-Email-Date
parent77f152a8358530051cd25fbf7373c769fe81f94e (diff)
downloadports-e68b94fa0801ac021037399be304d6cc977fbc7b.tar.gz
ports-e68b94fa0801ac021037399be304d6cc977fbc7b.zip
Add p5-Email-Date 1.02, find and Format Date Headers.
Notes
Notes: svn path=/head/; revision=114814
Diffstat (limited to 'mail/p5-Email-Date')
-rw-r--r--mail/p5-Email-Date/Makefile30
-rw-r--r--mail/p5-Email-Date/distinfo2
-rw-r--r--mail/p5-Email-Date/pkg-descr4
-rw-r--r--mail/p5-Email-Date/pkg-plist4
4 files changed, 40 insertions, 0 deletions
diff --git a/mail/p5-Email-Date/Makefile b/mail/p5-Email-Date/Makefile
new file mode 100644
index 000000000000..543019ee990b
--- /dev/null
+++ b/mail/p5-Email-Date/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Email-Date
+# Date created: 2004-07-26
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Email-Date
+PORTVERSION= 1.02
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Email
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Find and Format Date Headers
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Email/Abstract.pm:${PORTSDIR}/mail/p5-Email-Abstract \
+ ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece \
+ ${SITE_PERL}/Time/Local.pm:${PORTSDIR}/devel/p5-Time-Local \
+ ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Email::Date.3
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-Date/distinfo b/mail/p5-Email-Date/distinfo
new file mode 100644
index 000000000000..0a0cfe043705
--- /dev/null
+++ b/mail/p5-Email-Date/distinfo
@@ -0,0 +1,2 @@
+MD5 (Email-Date-1.02.tar.gz) = b53d253c0d2c9d94f1527ce36faef1f9
+SIZE (Email-Date-1.02.tar.gz) = 2928
diff --git a/mail/p5-Email-Date/pkg-descr b/mail/p5-Email-Date/pkg-descr
new file mode 100644
index 000000000000..768b6d50a855
--- /dev/null
+++ b/mail/p5-Email-Date/pkg-descr
@@ -0,0 +1,4 @@
+[description of the port]
+
+Author: Author's name and e-mail address
+WWW: http://port.home.page/
diff --git a/mail/p5-Email-Date/pkg-plist b/mail/p5-Email-Date/pkg-plist
new file mode 100644
index 000000000000..1b4c021ca17c
--- /dev/null
+++ b/mail/p5-Email-Date/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Email/Date.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Date/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/Date
+@unexec rmdir %D/Email 2>/dev/null ||true