aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Email-Find
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-31 05:13:24 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-31 05:13:24 +0000
commita041248ae130386010e6476cbe61ddd0acec4328 (patch)
treea715ce2adbf038e0a545f195d0f5dbf310ec6c60 /mail/p5-Email-Find
parenta087a6cdd6510b55a78f49d1d544756c357a2ccc (diff)
downloadports-a041248ae130386010e6476cbe61ddd0acec4328.tar.gz
ports-a041248ae130386010e6476cbe61ddd0acec4328.zip
Add p5-Email-Find 0.02, a perl module to find RFC 822 email addresses in
plain text. PR: 23915 Submitted by: Anton Berezin <tobez@tobez.org>
Notes
Notes: svn path=/head/; revision=36491
Diffstat (limited to 'mail/p5-Email-Find')
-rw-r--r--mail/p5-Email-Find/Makefile25
-rw-r--r--mail/p5-Email-Find/distinfo1
-rw-r--r--mail/p5-Email-Find/pkg-comment1
-rw-r--r--mail/p5-Email-Find/pkg-descr11
-rw-r--r--mail/p5-Email-Find/pkg-plist4
5 files changed, 42 insertions, 0 deletions
diff --git a/mail/p5-Email-Find/Makefile b/mail/p5-Email-Find/Makefile
new file mode 100644
index 000000000000..9ad5f094364b
--- /dev/null
+++ b/mail/p5-Email-Find/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mail/p5-Email-Find
+# Date created: 28 December 2000
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Email-Find
+PORTVERSION= 0.02
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Email
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Email/Valid.pm:${PORTSDIR}/mail/p5-Email-Valid
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= Email::Find.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-Find/distinfo b/mail/p5-Email-Find/distinfo
new file mode 100644
index 000000000000..3f309f6b209e
--- /dev/null
+++ b/mail/p5-Email-Find/distinfo
@@ -0,0 +1 @@
+MD5 (Email-Find-0.02.tar.gz) = a8be98965f6178b7763305f30874c892
diff --git a/mail/p5-Email-Find/pkg-comment b/mail/p5-Email-Find/pkg-comment
new file mode 100644
index 000000000000..a0906b1250fd
--- /dev/null
+++ b/mail/p5-Email-Find/pkg-comment
@@ -0,0 +1 @@
+Find RFC 822 email addresses in plain text
diff --git a/mail/p5-Email-Find/pkg-descr b/mail/p5-Email-Find/pkg-descr
new file mode 100644
index 000000000000..cc4628918e0a
--- /dev/null
+++ b/mail/p5-Email-Find/pkg-descr
@@ -0,0 +1,11 @@
+This is a module for finding a subset of RFC 822 email addresses in
+arbitrary text. The addresses it finds are not guaranteed to exist or
+even actually be email addresses at all, but they will be valid RFC 822
+syntax.
+
+Email::Find will perform some heuristics to avoid some of the more
+obvious red herrings and false addresses, but there's only so much which
+can be done without a human.
+
+-Anton
+<tobez@tobez.org>
diff --git a/mail/p5-Email-Find/pkg-plist b/mail/p5-Email-Find/pkg-plist
new file mode 100644
index 000000000000..4dffab750954
--- /dev/null
+++ b/mail/p5-Email-Find/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Email/Find/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Email/Find.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Email/Find
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Email 2>/dev/null || true