aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Email-LocalDelivery
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-09-01 20:25:41 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-09-01 20:25:41 +0000
commitbcc645405bf6ae96ee35e6eb5626a7c54577cff5 (patch)
tree546e0878f1072da32c3b36ed5683afcff5ba4585 /mail/p5-Email-LocalDelivery
parent9299b8ec6cd9c0f982c4fce99350ca739d446111 (diff)
downloadports-bcc645405bf6ae96ee35e6eb5626a7c54577cff5.tar.gz
ports-bcc645405bf6ae96ee35e6eb5626a7c54577cff5.zip
- New port mail/p5-Email-LocalDelivery
This is the second module produced by the "Perl Email Project", a reaction against the complexity and increasing bugginess of the Mail::* modules. It delivers an email to a list of mailboxes. PR: 56267 Submitted by: Lars Thegler <lars@thegler.dk>
Notes
Notes: svn path=/head/; revision=88305
Diffstat (limited to 'mail/p5-Email-LocalDelivery')
-rw-r--r--mail/p5-Email-LocalDelivery/Makefile29
-rw-r--r--mail/p5-Email-LocalDelivery/distinfo1
-rw-r--r--mail/p5-Email-LocalDelivery/files/patch-LocalDelivery.pm15
-rw-r--r--mail/p5-Email-LocalDelivery/pkg-descr5
-rw-r--r--mail/p5-Email-LocalDelivery/pkg-plist8
5 files changed, 58 insertions, 0 deletions
diff --git a/mail/p5-Email-LocalDelivery/Makefile b/mail/p5-Email-LocalDelivery/Makefile
new file mode 100644
index 000000000000..2a3422a8a14d
--- /dev/null
+++ b/mail/p5-Email-LocalDelivery/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Email-LocalDelivery
+# Date created: August 31 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Email-LocalDelivery
+PORTVERSION= 0.05
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Email
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Deliver a piece of email - simply
+
+BUILD_DEPENDS= ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
+ ${SITE_PERL}/Email/FolderType.pm:${PORTSDIR}/mail/p5-Email-FolderType
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Email::LocalDelivery.3
+
+test:
+ cd ${WRKSRC} ; make test
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Email-LocalDelivery/distinfo b/mail/p5-Email-LocalDelivery/distinfo
new file mode 100644
index 000000000000..45047558d702
--- /dev/null
+++ b/mail/p5-Email-LocalDelivery/distinfo
@@ -0,0 +1 @@
+MD5 (Email-LocalDelivery-0.05.tar.gz) = 73249763b6619750f3d657b149179059
diff --git a/mail/p5-Email-LocalDelivery/files/patch-LocalDelivery.pm b/mail/p5-Email-LocalDelivery/files/patch-LocalDelivery.pm
new file mode 100644
index 000000000000..1414e0e186db
--- /dev/null
+++ b/mail/p5-Email-LocalDelivery/files/patch-LocalDelivery.pm
@@ -0,0 +1,15 @@
+--- LocalDelivery.pm.orig Mon Sep 1 20:36:31 2003
++++ LocalDelivery.pm Mon Sep 1 20:30:45 2003
+@@ -1,11 +1,10 @@
+ package Email::LocalDelivery;
+
+-require 5.005_62;
+ use strict;
+-use warnings;
+ use Email::FolderType qw(folder_type);
+ use Carp;
+-our $VERSION = '0.05';
++use vars qw($VERSION);
++$VERSION = '0.05';
+
+ =head1 NAME
diff --git a/mail/p5-Email-LocalDelivery/pkg-descr b/mail/p5-Email-LocalDelivery/pkg-descr
new file mode 100644
index 000000000000..39812ad1ce6d
--- /dev/null
+++ b/mail/p5-Email-LocalDelivery/pkg-descr
@@ -0,0 +1,5 @@
+This is the second module produced by the "Perl Email Project", a
+reaction against the complexity and increasing bugginess of the Mail::*
+modules. It delivers an email to a list of mailboxes.
+
+WWW: http://search.cpan.org/dist/Email-LocalDelivery
diff --git a/mail/p5-Email-LocalDelivery/pkg-plist b/mail/p5-Email-LocalDelivery/pkg-plist
new file mode 100644
index 000000000000..c0d481573216
--- /dev/null
+++ b/mail/p5-Email-LocalDelivery/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Email/LocalDelivery.pm
+%%SITE_PERL%%/Email/LocalDelivery/Maildir.pm
+%%SITE_PERL%%/Email/LocalDelivery/Mbox.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/LocalDelivery/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Email/LocalDelivery
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Email 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Email/LocalDelivery 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Email 2>/dev/null || true