aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Email-LocalDelivery
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2004-06-01 20:22:15 +0000
committerLars Thegler <lth@FreeBSD.org>2004-06-01 20:22:15 +0000
commitc36c2609cee9f3e2a290c8ce6e5138eef023e4f3 (patch)
treeafad6f91ab4810ea9e6699c6ea51156af92b96e4 /mail/p5-Email-LocalDelivery
parent9968b6382a73379f2c137d38d7369fc36ca7d1e0 (diff)
downloadports-c36c2609cee9f3e2a290c8ce6e5138eef023e4f3.tar.gz
ports-c36c2609cee9f3e2a290c8ce6e5138eef023e4f3.zip
- Update to 0.08
- Fix for perl 5.005_03 Approved by: erwin (mentor)
Notes
Notes: svn path=/head/; revision=110618
Diffstat (limited to 'mail/p5-Email-LocalDelivery')
-rw-r--r--mail/p5-Email-LocalDelivery/Makefile14
-rw-r--r--mail/p5-Email-LocalDelivery/distinfo4
-rw-r--r--mail/p5-Email-LocalDelivery/files/5.005-LocalDelivery.pm16
-rw-r--r--mail/p5-Email-LocalDelivery/files/5.005-LocalDelivery::Maildir.pm11
-rw-r--r--mail/p5-Email-LocalDelivery/files/5.005-LocalDelivery::Mbox.pm36
5 files changed, 72 insertions, 9 deletions
diff --git a/mail/p5-Email-LocalDelivery/Makefile b/mail/p5-Email-LocalDelivery/Makefile
index 120bec4d7760..134dd8c91d20 100644
--- a/mail/p5-Email-LocalDelivery/Makefile
+++ b/mail/p5-Email-LocalDelivery/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Email-LocalDelivery
-PORTVERSION= 0.07
+PORTVERSION= 0.08
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Email
@@ -27,13 +27,13 @@ MAN3= Email::LocalDelivery.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
+
+EXTRA_PATCHES= ${FILESDIR}/5.005-LocalDelivery.pm \
+ ${FILESDIR}/5.005-LocalDelivery::Maildir.pm \
+ ${FILESDIR}/5.005-LocalDelivery::Mbox.pm
+
post-patch:
- ${PERL} -pi -e '$$_="" if /require 5/;' \
- -e '$$_="" if /use warnings/;' \
- -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);$$1/;' \
- ${WRKSRC}/LocalDelivery.pm \
- ${WRKSRC}/LocalDelivery/Maildir.pm \
- ${WRKSRC}/LocalDelivery/Mbox.pm
+ ${FIND} ${WRKSRC} -name \*.orig -delete
post-configure:
${PERL} -pi -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/Makefile
diff --git a/mail/p5-Email-LocalDelivery/distinfo b/mail/p5-Email-LocalDelivery/distinfo
index 475063b7a54b..614b3fa5767f 100644
--- a/mail/p5-Email-LocalDelivery/distinfo
+++ b/mail/p5-Email-LocalDelivery/distinfo
@@ -1,2 +1,2 @@
-MD5 (Email-LocalDelivery-0.07.tar.gz) = f59cc917a1b87189c5f1b0c3e4be9959
-SIZE (Email-LocalDelivery-0.07.tar.gz) = 4048
+MD5 (Email-LocalDelivery-0.08.tar.gz) = 61dd51f919705734fd7da32b506595d6
+SIZE (Email-LocalDelivery-0.08.tar.gz) = 4178
diff --git a/mail/p5-Email-LocalDelivery/files/5.005-LocalDelivery.pm b/mail/p5-Email-LocalDelivery/files/5.005-LocalDelivery.pm
new file mode 100644
index 000000000000..4ee645aebfcd
--- /dev/null
+++ b/mail/p5-Email-LocalDelivery/files/5.005-LocalDelivery.pm
@@ -0,0 +1,16 @@
+--- LocalDelivery.pm.orig Tue Jun 1 20:04:19 2004
++++ LocalDelivery.pm Tue Jun 1 20:05:12 2004
+@@ -1,12 +1,10 @@
+ package Email::LocalDelivery;
+
+-require 5.005_62;
+ use strict;
+-use warnings;
+ use File::Path::Expand qw(expand_filename);
+ use Email::FolderType qw(folder_type);
+ use Carp;
+-our $VERSION = '0.08';
++use vars qw($VERSION); $VERSION = '0.08';
+
+ =head1 NAME
+
diff --git a/mail/p5-Email-LocalDelivery/files/5.005-LocalDelivery::Maildir.pm b/mail/p5-Email-LocalDelivery/files/5.005-LocalDelivery::Maildir.pm
new file mode 100644
index 000000000000..1bbad2c88345
--- /dev/null
+++ b/mail/p5-Email-LocalDelivery/files/5.005-LocalDelivery::Maildir.pm
@@ -0,0 +1,11 @@
+--- LocalDelivery/Maildir.pm.orig Tue Jun 1 20:04:43 2004
++++ LocalDelivery/Maildir.pm Tue Jun 1 20:06:01 2004
+@@ -3,7 +3,7 @@
+ use Email::Simple;
+ use File::Path;
+
+-our $VERSION = "1.06";
++use vars qw($VERSION); $VERSION = "1.06";
+ my $maildir_time = 0;
+ my $maildir_counter = 0;
+ use Sys::Hostname; (my $HOSTNAME = hostname) =~ s/\..*//;
diff --git a/mail/p5-Email-LocalDelivery/files/5.005-LocalDelivery::Mbox.pm b/mail/p5-Email-LocalDelivery/files/5.005-LocalDelivery::Mbox.pm
new file mode 100644
index 000000000000..839364ab8822
--- /dev/null
+++ b/mail/p5-Email-LocalDelivery/files/5.005-LocalDelivery::Mbox.pm
@@ -0,0 +1,36 @@
+--- LocalDelivery/Mbox.pm.orig Fri Nov 14 10:04:24 2003
++++ LocalDelivery/Mbox.pm Tue Jun 1 20:03:37 2004
+@@ -4,7 +4,7 @@
+ use Email::Simple;
+ use Fcntl ':flock';
+
+-our $VERSION = "1.07";
++use vars qw($VERSION); $VERSION = "1.07";
+
+ sub deliver {
+ my ($class, $mail, @files) = @_;
+@@ -13,15 +13,15 @@
+ my $dir = dirname($file);
+ next if ! -d $dir and not mkpath($dir);
+
+- open my $fh, ">> $file" or next;
+- $class->getlock($fh) || next;
+- seek $fh, 0, 2;
+- print $fh "\n" if tell($fh) > 0;
+- print $fh $class->_from_line(\$mail); # Avoid passing $mail where poss.
+- print $fh $class->_escape_from_body(\$mail);
+- print $fh "\n" unless $mail =~ /\n$/;
+- $class->unlock($fh) || next;
+- close $fh or next;
++ open FH, ">> $file" or next;
++ $class->getlock(FH) || next;
++ seek FH, 0, 2;
++ print FH "\n" if tell(FH) > 0;
++ print FH $class->_from_line(\$mail); # Avoid passing $mail where poss.
++ print FH $class->_escape_from_body(\$mail);
++ print FH "\n" unless $mail =~ /\n$/;
++ $class->unlock(FH) || next;
++ close FH or next;
+ push @rv, $file
+ }
+ return @rv;