aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Email-LocalDelivery
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-02 10:13:30 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-02 10:13:30 +0000
commitfa89266b6535b73d6b28a959fc403ac47650f15e (patch)
treea3af8a84f0b956f282d5b291b1d2bfe258cc7ea0 /mail/p5-Email-LocalDelivery
parentec9188d56fb4fc09832642e8451028060415d3c4 (diff)
downloadports-fa89266b6535b73d6b28a959fc403ac47650f15e.tar.gz
ports-fa89266b6535b73d6b28a959fc403ac47650f15e.zip
- Update to 0.06
- Now works with perl 5.005_03 PR: 58817 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=92830
Diffstat (limited to 'mail/p5-Email-LocalDelivery')
-rw-r--r--mail/p5-Email-LocalDelivery/Makefile24
-rw-r--r--mail/p5-Email-LocalDelivery/distinfo2
-rw-r--r--mail/p5-Email-LocalDelivery/files/patch-LocalDelivery.pm15
3 files changed, 21 insertions, 20 deletions
diff --git a/mail/p5-Email-LocalDelivery/Makefile b/mail/p5-Email-LocalDelivery/Makefile
index 2a3422a8a14d..8384ecdddbc9 100644
--- a/mail/p5-Email-LocalDelivery/Makefile
+++ b/mail/p5-Email-LocalDelivery/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Email-LocalDelivery
-PORTVERSION= 0.05
+PORTVERSION= 0.06
CATEGORIES= mail perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Email
@@ -16,14 +16,30 @@ MAINTAINER= lars@thegler.dk
COMMENT= Deliver a piece of email - simply
BUILD_DEPENDS= ${SITE_PERL}/Email/Simple.pm:${PORTSDIR}/mail/p5-Email-Simple \
- ${SITE_PERL}/Email/FolderType.pm:${PORTSDIR}/mail/p5-Email-FolderType
+ ${SITE_PERL}/Email/FolderType.pm:${PORTSDIR}/mail/p5-Email-FolderType \
+ ${SITE_PERL}/File/Path/Expand.pm:${PORTSDIR}/devel/p5-File-Path-Expand
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Email::LocalDelivery.3
-test:
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ ${PERL} -pi -e '$$_="" if /require 5/;' \
+ -e '$$_="" if /use warnings/;' \
+ -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);$$1/;' \
+ ${WRKSRC}/LocalDelivery.pm \
+ ${WRKSRC}/LocalDelivery/Maildir.pm \
+ ${WRKSRC}/LocalDelivery/Mbox.pm
+
+post-configure:
+ ${PERL} -pi -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/Makefile
+.endif
+
+test: build
cd ${WRKSRC} ; make test
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Email-LocalDelivery/distinfo b/mail/p5-Email-LocalDelivery/distinfo
index 45047558d702..3944e59f2086 100644
--- a/mail/p5-Email-LocalDelivery/distinfo
+++ b/mail/p5-Email-LocalDelivery/distinfo
@@ -1 +1 @@
-MD5 (Email-LocalDelivery-0.05.tar.gz) = 73249763b6619750f3d657b149179059
+MD5 (Email-LocalDelivery-0.06.tar.gz) = 97d29eb9b5dfd0ec8f7eb4e170b4d078
diff --git a/mail/p5-Email-LocalDelivery/files/patch-LocalDelivery.pm b/mail/p5-Email-LocalDelivery/files/patch-LocalDelivery.pm
deleted file mode 100644
index 1414e0e186db..000000000000
--- a/mail/p5-Email-LocalDelivery/files/patch-LocalDelivery.pm
+++ /dev/null
@@ -1,15 +0,0 @@
---- LocalDelivery.pm.orig Mon Sep 1 20:36:31 2003
-+++ LocalDelivery.pm Mon Sep 1 20:30:45 2003
-@@ -1,11 +1,10 @@
- package Email::LocalDelivery;
-
--require 5.005_62;
- use strict;
--use warnings;
- use Email::FolderType qw(folder_type);
- use Carp;
--our $VERSION = '0.05';
-+use vars qw($VERSION);
-+$VERSION = '0.05';
-
- =head1 NAME