aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-FuzzyOcr-devel
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-11-06 00:26:03 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-11-06 00:26:03 +0000
commit7adf889c08e920a6273be1a77cb58891c6dc56fc (patch)
tree2b00eeee83fa38e2144c4e023b656a74b6f8e864 /mail/p5-FuzzyOcr-devel
parentb717658289141606ce86f006aea3b04c1f01a2a1 (diff)
downloadports-7adf889c08e920a6273be1a77cb58891c6dc56fc.tar.gz
ports-7adf889c08e920a6273be1a77cb58891c6dc56fc.zip
FuzzyOcr is a SpamAssassin plugin which uses an Optical Character
Recognition (OCR) program to scan image attachments for spammy content. It works!
Notes
Notes: svn path=/head/; revision=176565
Diffstat (limited to 'mail/p5-FuzzyOcr-devel')
-rw-r--r--mail/p5-FuzzyOcr-devel/Makefile75
-rw-r--r--mail/p5-FuzzyOcr-devel/distinfo3
-rw-r--r--mail/p5-FuzzyOcr-devel/files/pkg-message.in5
-rw-r--r--mail/p5-FuzzyOcr-devel/pkg-descr12
4 files changed, 95 insertions, 0 deletions
diff --git a/mail/p5-FuzzyOcr-devel/Makefile b/mail/p5-FuzzyOcr-devel/Makefile
new file mode 100644
index 000000000000..73ceb3f9aca7
--- /dev/null
+++ b/mail/p5-FuzzyOcr-devel/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: FuzzyOcr
+# Date Created: 2006-11-03
+# Whom: Shaun Amott <shaun@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= FuzzyOcr
+DISTVERSION= 2.3rc1
+CATEGORIES= mail perl5
+MASTER_SITES= http://users.own-hero.net/~decoder/${PORTNAME:L}/ \
+ http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME:L}-${DISTVERSION}
+
+MAINTAINER= shaun@FreeBSD.org
+COMMENT= Plugin for SpamAssassin which scans image attachments for spam
+
+RUN_DEPENDS= giftopnm:${PORTSDIR}/graphics/netpbm \
+ import:${PORTSDIR}/graphics/ImageMagick \
+ gocr:${PORTSDIR}/graphics/gocr \
+ gif2ps:${PORTSDIR}/graphics/libungif \
+ spamassassin:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/String/Approx.pm:${PORTSDIR}/devel/p5-String-Approx
+
+USE_PERL5= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}
+
+PORTDOCS= FAQ samples
+PORTDOCS_F= FAQ samples/README samples/animated-gif.eml \
+ samples/corrupted-gif.eml samples/jpeg.eml samples/png.eml
+
+SUB_FILES= pkg-message
+
+#-----------------------------------------------------------------------
+# The plugin is installed twice: once where it should go, and once where
+# it actually works from. This will hopefully be fixed at some point.
+#-----------------------------------------------------------------------
+
+SA_PLUGINDIR?= Mail/SpamAssassin/Plugin
+SA_CONFIGDIR?= etc/mail/spamassassin
+
+PLIST_FILES= ${SA_CONFIGDIR}/FuzzyOcr.pm \
+ %%SITE_PERL%%/${SA_PLUGINDIR}/FuzzyOcr.pm \
+ %%EXAMPLESDIR%%/FuzzyOcr.cf %%EXAMPLESDIR%%/FuzzyOcr.words
+PLIST_DIRS= %%EXAMPLESDIR%%
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/bin,${LOCALBASE}/bin,g' \
+ -e 's,/bin/grep,/usr/bin/grep,g' \
+ -e 's,/etc/mail,${LOCALBASE}/etc/mail,g' \
+ ${WRKSRC}/FuzzyOcr.??
+ @${REINPLACE_CMD} -e 's,$$ENV{HOME},($$ENV{HOME} ? $$ENV{HOME} : "/nonexistent"),g' \
+ ${WRKSRC}/FuzzyOcr.pm
+
+do-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/FuzzyOcr.pm ${SITE_PERL}/${SA_PLUGINDIR}
+ ${INSTALL_DATA} ${WRKSRC}/FuzzyOcr.pm ${PREFIX}/${SA_CONFIGDIR}
+ ${INSTALL_DATA} ${WRKSRC}/FuzzyOcr.cf ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/FuzzyOcr.words.sample ${EXAMPLESDIR}/FuzzyOcr.words
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}/samples
+. for f in ${PORTDOCS_F}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/${f}
+. endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/mail/p5-FuzzyOcr-devel/distinfo b/mail/p5-FuzzyOcr-devel/distinfo
new file mode 100644
index 000000000000..a0ae182da04f
--- /dev/null
+++ b/mail/p5-FuzzyOcr-devel/distinfo
@@ -0,0 +1,3 @@
+MD5 (fuzzyocr-2.3rc1.tar.gz) = 43879c3f30045b0067d21f9e44b90697
+SHA256 (fuzzyocr-2.3rc1.tar.gz) = bdd8c3524e6445ea79968497c84a9d5e58491ccab9e05aa0784179bec8c24131
+SIZE (fuzzyocr-2.3rc1.tar.gz) = 75295
diff --git a/mail/p5-FuzzyOcr-devel/files/pkg-message.in b/mail/p5-FuzzyOcr-devel/files/pkg-message.in
new file mode 100644
index 000000000000..11e9ed3223d2
--- /dev/null
+++ b/mail/p5-FuzzyOcr-devel/files/pkg-message.in
@@ -0,0 +1,5 @@
+------------------------------------------------------------------------
+ To complete the install of FuzzyOcr, copy FuzzyOcr.cf and
+ FuzzyOcr.words from %%EXAMPLESDIR%% into your
+ SpamAssassin configuration directory.
+------------------------------------------------------------------------
diff --git a/mail/p5-FuzzyOcr-devel/pkg-descr b/mail/p5-FuzzyOcr-devel/pkg-descr
new file mode 100644
index 000000000000..a7069d137cbd
--- /dev/null
+++ b/mail/p5-FuzzyOcr-devel/pkg-descr
@@ -0,0 +1,12 @@
+FuzzyOcr is a plugin for SpamAssassin which scans image attachments for
+spam keywords, using an Optical Character Recognition program.
+
+This plugin can be used to detect spam that puts all the real spam
+content in an attached image. The mail itself only random text and
+random html, without any URLs or identifiable information.
+
+It is also able to do approximate matches on words, so errors in
+recognition or attempts to obfuscate the text inside the image will not
+cause the detection to fail.
+
+WWW: http://wiki.apache.org/spamassassin/FuzzyOcrPlugin