aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-MIME-Fast
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-12-08 15:04:26 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-12-08 15:04:26 +0000
commitb285e1b08653375ad8f9ac65d19fdf9cd1be2397 (patch)
tree99e055ddba1744f31fd0fe1aa2fc69f069ff8dbf /mail/p5-MIME-Fast
parent4bdc4819e6edde3c6d7417edc698cf9c00e470bc (diff)
downloadports-b285e1b08653375ad8f9ac65d19fdf9cd1be2397.tar.gz
ports-b285e1b08653375ad8f9ac65d19fdf9cd1be2397.zip
Add p5-MIME-Fast 1.4,
create, edit and parse MIME messages (via gmime2 C library).
Notes
Notes: svn path=/head/; revision=123458
Diffstat (limited to 'mail/p5-MIME-Fast')
-rw-r--r--mail/p5-MIME-Fast/Makefile33
-rw-r--r--mail/p5-MIME-Fast/distinfo2
-rw-r--r--mail/p5-MIME-Fast/files/patch-Makefile.PL17
-rw-r--r--mail/p5-MIME-Fast/pkg-descr8
-rw-r--r--mail/p5-MIME-Fast/pkg-plist9
5 files changed, 69 insertions, 0 deletions
diff --git a/mail/p5-MIME-Fast/Makefile b/mail/p5-MIME-Fast/Makefile
new file mode 100644
index 000000000000..9e2f50c7fed7
--- /dev/null
+++ b/mail/p5-MIME-Fast/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: MIME-Fast
+# Date created: 08 December 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MIME-Fast
+PORTVERSION= 1.4
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= MIME
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Create, edit and parse MIME messages (via gmime2 C library)
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+LIB_DEPENDS= gmime-2.0:${PORTSDIR}/mail/gmime2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CONFIGURE_ENV= PREFIX="${PREFIX}" CCFLAGS="${CCFLAGS} ${PTHREAD_CFLAGS}"
+
+MAN3= MIME::Fast.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= "Perl 5.8 or newer required. Install lang/perl5.8 and try again."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-MIME-Fast/distinfo b/mail/p5-MIME-Fast/distinfo
new file mode 100644
index 000000000000..858be213e129
--- /dev/null
+++ b/mail/p5-MIME-Fast/distinfo
@@ -0,0 +1,2 @@
+MD5 (MIME-Fast-1.4.tar.gz) = ae477eeeb5d6c198d221ae9205a3be22
+SIZE (MIME-Fast-1.4.tar.gz) = 52885
diff --git a/mail/p5-MIME-Fast/files/patch-Makefile.PL b/mail/p5-MIME-Fast/files/patch-Makefile.PL
new file mode 100644
index 000000000000..4c82af272a40
--- /dev/null
+++ b/mail/p5-MIME-Fast/files/patch-Makefile.PL
@@ -0,0 +1,17 @@
+--- Makefile.PL.orig Thu Oct 16 13:01:46 2003
++++ Makefile.PL Wed Dec 8 17:56:57 2004
+@@ -6,6 +6,7 @@
+
+ # my $libs = `pkg-config --libs gmime-2.0`;
+ my $libs = `gmime-config --libs`;
++$libs =~ s/\-lgthread\-\d\.\d//;
+ my $vers = `gmime-config --version`;
+
+ if ($libs eq '') {
+@@ -78,5 +79,5 @@
+ },
+ 'clean' => { FILES => "gmime-version.h" },
+ # 'INC' => `pkg-config --cflags gmime-2.0` # e.g., '-I/usr/include/other'
+- 'INC' => "-I. -Icinclude " . `gmime-config --cflags`,
++ 'INC' => "-I. -Icinclude -I$ENV{PREFIX}/include " . `gmime-config --cflags`,
+ );
diff --git a/mail/p5-MIME-Fast/pkg-descr b/mail/p5-MIME-Fast/pkg-descr
new file mode 100644
index 000000000000..4e98f5391d80
--- /dev/null
+++ b/mail/p5-MIME-Fast/pkg-descr
@@ -0,0 +1,8 @@
+MIME::Fast is a perl module for creating, editing and parsing MIME
+messages. This module is based on the very good C library called gmime
+(currently in development). MIME::Fast outght to be faster and should
+use less memory and CPU resources than standard MIME (perl module),
+because MIME::Fast is the wrapper for C functions (calling C function is
+much, much less expensive than calling perl function).
+
+WWW: http://search.cpan.org/dist/MIME-Fast/
diff --git a/mail/p5-MIME-Fast/pkg-plist b/mail/p5-MIME-Fast/pkg-plist
new file mode 100644
index 000000000000..9d3480bc7ffc
--- /dev/null
+++ b/mail/p5-MIME-Fast/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/MIME/Fast.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/MIME/Fast.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MIME/Fast/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MIME/Fast/Fast.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MIME/Fast/Fast.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MIME/Fast/autosplit.ix
+@unexec rmdir %D/%%SITE_PERL%%/MIME 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MIME/Fast
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/MIME 2>/dev/null || true