aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-MIME-Lite-TT-HTML/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-26 17:18:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-26 17:18:29 +0000
commit2d9b6596051029ad0f804914a000951fd9c135cd (patch)
treec095f434eabf7d03f3333c091956c047bc4f550f /mail/p5-MIME-Lite-TT-HTML/Makefile
parent2e705988bacca8b2f0cfbaefcf33439005105920 (diff)
downloadports-2d9b6596051029ad0f804914a000951fd9c135cd.tar.gz
ports-2d9b6596051029ad0f804914a000951fd9c135cd.zip
Notes
Diffstat (limited to 'mail/p5-MIME-Lite-TT-HTML/Makefile')
-rw-r--r--mail/p5-MIME-Lite-TT-HTML/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/mail/p5-MIME-Lite-TT-HTML/Makefile b/mail/p5-MIME-Lite-TT-HTML/Makefile
new file mode 100644
index 000000000000..c67770792911
--- /dev/null
+++ b/mail/p5-MIME-Lite-TT-HTML/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mail/p5-MIME-Lite-TT-HTML
+# Date created: 22 March 2008
+# Whom: Tuc <freebsd-ports@t-b-o-h.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MIME-Lite-TT-HTML
+PORTVERSION= 0.04
+CATEGORIES= mail perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= freebsd-ports@t-b-o-h.net
+COMMENT= Create html mail with MIME::Lite and TT
+
+BUILD_DEPENDS= ${SITE_PERL}/mach/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/DateTime/Format/Mail.pm:${PORTSDIR}/devel/p5-DateTime-Format-Mail \
+ ${SITE_PERL}/MIME/Words.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+ ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
+ ${SITE_PERL}/HTML/FormatText/WithLinks.pm:${PORTSDIR}/textproc/p5-HTML-FormatText-WithLinks
+RUN_DEPENDS= ${SITE_PERL}/mach/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/DateTime/Format/Mail.pm:${PORTSDIR}/devel/p5-DateTime-Format-Mail \
+ ${SITE_PERL}/MIME/Words.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+ ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
+ ${SITE_PERL}/HTML/FormatText/WithLinks.pm:${PORTSDIR}/textproc/p5-HTML-FormatText-WithLinks
+
+PERL_CONFIGURE= yes
+PERL_MODBUILD= yes
+
+MAN3= MIME::Lite::TT::HTML.3
+
+.include <bsd.port.mk>