aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-Ezmlm/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-08-09 19:09:03 +0000
committerWill Andrews <will@FreeBSD.org>2000-08-09 19:09:03 +0000
commitaf0a37232f18cde6f06945f24e39cd20f749610f (patch)
tree289823a3cd49e8bc285f1ea478bf9cc3bff1d06d /mail/p5-Mail-Ezmlm/Makefile
parent5d20bc51087e290e2dd050adebae018836bf803a (diff)
downloadports-af0a37232f18cde6f06945f24e39cd20f749610f.tar.gz
ports-af0a37232f18cde6f06945f24e39cd20f749610f.zip
Add p5-Mail-Ezmlm, a perl module that provides object methods for ezmlm
mailing lists. PR: 20443 Submitted by: Guy Antony Halse <guy@rucus.ru.za.za>
Notes
Notes: svn path=/head/; revision=31456
Diffstat (limited to 'mail/p5-Mail-Ezmlm/Makefile')
-rw-r--r--mail/p5-Mail-Ezmlm/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/mail/p5-Mail-Ezmlm/Makefile b/mail/p5-Mail-Ezmlm/Makefile
new file mode 100644
index 000000000000..6d9aedadac20
--- /dev/null
+++ b/mail/p5-Mail-Ezmlm/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Mail::Ezmlm
+# Date Created: 18 May 2000
+# Whom: Guy Antony Halse <guy@rucus.ru.za.za>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail-Ezmlm
+PORTVERSION= 0.02.1
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mail
+PKGNAMEPREFIX= p5-
+DISTNAME= Ezmlm-${PORTVERSION}
+
+MAINTAINER= guy-ezmlm@rucus.ru.ac.za
+
+BUILD_DEPENDS= ${EZMLM_DIR}/bin/ezmlm-idx:${PORTSDIR}/mail/ezmlm-idx
+
+EZMLM_DIR?= ${LOCALBASE}
+USE_PERL5= YES
+MAN3= Mail::Ezmlm.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+# For this version, since it is a bugfix
+WRKSRC= ${WRKDIR}/Ezmlm-0.02
+
+do-configure:
+.if defined(BATCH)
+ @cd ${WRKSRC}; ${SETENV} BSD_BATCH_INSTALL=yes ${PERL5} Makefile.PL
+.else
+ @cd ${WRKSRC}; ${PERL5} Makefile.PL
+.endif
+
+.include <bsd.port.mk>