aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-IMAPTalk
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-24 19:27:32 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-24 19:27:32 +0000
commitc8962b1150530d368fb0edcdc82e32f3d507dbe6 (patch)
tree5bff300dcbf0f38a295240cb1e3b5cb80bc29b09 /mail/p5-Mail-IMAPTalk
parent071e5a80bdd2fd69a64d33d2bab1afc81c31b642 (diff)
downloadports-c8962b1150530d368fb0edcdc82e32f3d507dbe6.tar.gz
ports-c8962b1150530d368fb0edcdc82e32f3d507dbe6.zip
Adding port mail/p5-Mail-IMAPTalk, a pure-Perl, full-featured IMAP protocol library.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163303
Diffstat (limited to 'mail/p5-Mail-IMAPTalk')
-rw-r--r--mail/p5-Mail-IMAPTalk/Makefile28
-rw-r--r--mail/p5-Mail-IMAPTalk/distinfo3
-rw-r--r--mail/p5-Mail-IMAPTalk/pkg-descr29
-rw-r--r--mail/p5-Mail-IMAPTalk/pkg-plist5
4 files changed, 65 insertions, 0 deletions
diff --git a/mail/p5-Mail-IMAPTalk/Makefile b/mail/p5-Mail-IMAPTalk/Makefile
new file mode 100644
index 000000000000..303b03ce678c
--- /dev/null
+++ b/mail/p5-Mail-IMAPTalk/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Mail-IMAPTalk
+# Date created: 24 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail-IMAPTalk
+PORTVERSION= 1.03
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mail
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= IMAP client interface with lots of features
+
+MAN3= Mail::IMAPTalk.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6.0. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Mail-IMAPTalk/distinfo b/mail/p5-Mail-IMAPTalk/distinfo
new file mode 100644
index 000000000000..c70ea51eb656
--- /dev/null
+++ b/mail/p5-Mail-IMAPTalk/distinfo
@@ -0,0 +1,3 @@
+MD5 (Mail-IMAPTalk-1.03.tar.gz) = 54bdcb07d1e9a1930ea61d09fc89bb1a
+SHA256 (Mail-IMAPTalk-1.03.tar.gz) = 6cfd98720f6175e80f315ebaee94841a81bc86ed52c855cfcb5395530dc5a30c
+SIZE (Mail-IMAPTalk-1.03.tar.gz) = 30878
diff --git a/mail/p5-Mail-IMAPTalk/pkg-descr b/mail/p5-Mail-IMAPTalk/pkg-descr
new file mode 100644
index 000000000000..b7904cdbad19
--- /dev/null
+++ b/mail/p5-Mail-IMAPTalk/pkg-descr
@@ -0,0 +1,29 @@
+This module communicates with an IMAP server. Each IMAP server command is
+mapped to a method of this object.
+
+Although other IMAP modules exist on CPAN, this has several advantages
+over other modules.
+
+ * It parses the more complex IMAP structures like envelopes and body
+structures into nice Perl data structures.
+ * It correctly supports atoms, quoted strings and literals at any
+point. Some parsers in other modules aren't fully IMAP compatiable and may
+break at odd times with certain messages on some servers.
+ * It allows large return values (eg. attachments on a message) to be
+read directly into a file, rather than into memory.
+ * It includes some helper functions to find the actual text/plain or
+text/html part of a message out of a complex MIME structure. It also can
+find a list of attachements, and CID links for HTML messages with attached
+images.
+ * It supports decoding of MIME headers to Perl utf-8 strings
+automatically, so you don't have to deal with MIME encoded headers
+(enabled optionally).
+
+While the IMAP protocol does allow for asynchronous running of commands,
+this module is designed to be used in a synchronous manner. That is, you
+issue a command by calling a method, and the command will block until the
+appropriate response is returned. The method will then return the parsed
+results from the given command.
+
+WWW: http://search.cpan.org/dist/Mail-IMAPTalk
+Author: Rob Mueller <cpan@robm.fastmail.fm>
diff --git a/mail/p5-Mail-IMAPTalk/pkg-plist b/mail/p5-Mail-IMAPTalk/pkg-plist
new file mode 100644
index 000000000000..a920e430f823
--- /dev/null
+++ b/mail/p5-Mail-IMAPTalk/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Mail/IMAPTalk.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mail/IMAPTalk/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Mail/IMAPTalk
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Mail
+@dirrmtry %%SITE_PERL%%/Mail