aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-Mbox-MessageParser
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-10-30 17:48:29 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-10-30 17:48:29 +0000
commit969e4927577e073a787340acf0a7e757587981ed (patch)
tree1edd82aec278a8d216220a5367c2bc78feb27a3d /mail/p5-Mail-Mbox-MessageParser
parentc4ca9246e62484b03b62382a259299a75eec59ad (diff)
downloadports-969e4927577e073a787340acf0a7e757587981ed.tar.gz
ports-969e4927577e073a787340acf0a7e757587981ed.zip
Add p5-Mail-Mbox-MessageParser 1.12,
a fast and simple mbox folder reader. PR: 58674 Submitted by: Cheng-Lung Sung <clsung@dragon2.net>
Notes
Notes: svn path=/head/; revision=92647
Diffstat (limited to 'mail/p5-Mail-Mbox-MessageParser')
-rw-r--r--mail/p5-Mail-Mbox-MessageParser/Makefile35
-rw-r--r--mail/p5-Mail-Mbox-MessageParser/distinfo1
-rw-r--r--mail/p5-Mail-Mbox-MessageParser/files/patch-Makefile.PL27
-rw-r--r--mail/p5-Mail-Mbox-MessageParser/pkg-descr7
-rw-r--r--mail/p5-Mail-Mbox-MessageParser/pkg-plist11
5 files changed, 81 insertions, 0 deletions
diff --git a/mail/p5-Mail-Mbox-MessageParser/Makefile b/mail/p5-Mail-Mbox-MessageParser/Makefile
new file mode 100644
index 000000000000..b4a7715fc7c1
--- /dev/null
+++ b/mail/p5-Mail-Mbox-MessageParser/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mail/p5-Mail-Mbox-MessageParser
+# Date created: Oct 28 2003
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Mail-Mbox-MessageParser
+PORTVERSION= 1.12
+CATEGORIES= mail perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Mail
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= A fast and simple mbox folder reader
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/FileHandle/Unget.pm:${PORTSDIR}/devel/p5-FileHandle-Unget
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Mail::Mbox::MessageParser.3 \
+ Mail::Mbox::MessageParser::Cache.3 \
+ Mail::Mbox::MessageParser::Grep.3 \
+ Mail::Mbox::MessageParser::Perl.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/p5-Mail-Mbox-MessageParser/distinfo b/mail/p5-Mail-Mbox-MessageParser/distinfo
new file mode 100644
index 000000000000..6ac3701e80e1
--- /dev/null
+++ b/mail/p5-Mail-Mbox-MessageParser/distinfo
@@ -0,0 +1 @@
+MD5 (Mail-Mbox-MessageParser-1.12.tar.gz) = 2c09b48d8e6283dc16c41f9d25763f13
diff --git a/mail/p5-Mail-Mbox-MessageParser/files/patch-Makefile.PL b/mail/p5-Mail-Mbox-MessageParser/files/patch-Makefile.PL
new file mode 100644
index 000000000000..be1b4609a1c7
--- /dev/null
+++ b/mail/p5-Mail-Mbox-MessageParser/files/patch-Makefile.PL
@@ -0,0 +1,27 @@
+--- Makefile.PL.orig Wed Oct 22 11:08:40 2003
++++ Makefile.PL Wed Oct 29 14:52:36 2003
+@@ -208,14 +208,6 @@
+
+ return %programs if grep {/^(DIFF|GREP|TZIP|GZIP|BZIP2?)=/} @args;
+
+- print<<EOF;
+-You must now specify the location of external programs for decompressing
+-compressed folders. You must specify the full path--otherwise you may
+-accidentally execute a trojan version of the decompression program. You can
+-enter "none" to disable support for decompressing files of a given type.
+-
+-EOF
+-
+ my @path = split /$Config{path_sep}/, $ENV{PATH};
+
+ foreach my $program (sort keys %programs)
+@@ -227,8 +219,7 @@
+
+ $full_path = 'none' if !defined $full_path || $full_path eq '';
+
+- my $choice = ExtUtils::MakeMaker::prompt(
+- "Where can I find your \"$program\" executable?" => $full_path);
++ my $choice = $full_path;
+
+ $programs{$program} = undef, next if $choice eq 'none';
+
diff --git a/mail/p5-Mail-Mbox-MessageParser/pkg-descr b/mail/p5-Mail-Mbox-MessageParser/pkg-descr
new file mode 100644
index 000000000000..daf214464f8b
--- /dev/null
+++ b/mail/p5-Mail-Mbox-MessageParser/pkg-descr
@@ -0,0 +1,7 @@
+Mail::Mbox::MessageParser is a feature-poor but very fast mbox parser. It uses
+the best of three strategies for parsing a mailbox: either using cached folder
+information, GNU grep, or highly optimized Perl.
+
+WWW: http://m-m-msgparser.sourceforge.net/
+
+Author: David Coppit <david@coppit.org>
diff --git a/mail/p5-Mail-Mbox-MessageParser/pkg-plist b/mail/p5-Mail-Mbox-MessageParser/pkg-plist
new file mode 100644
index 000000000000..b3607be910cd
--- /dev/null
+++ b/mail/p5-Mail-Mbox-MessageParser/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Mail/Mbox/MessageParser.pm
+%%SITE_PERL%%/Mail/Mbox/MessageParser/Cache.pm
+%%SITE_PERL%%/Mail/Mbox/MessageParser/Grep.pm
+%%SITE_PERL%%/Mail/Mbox/MessageParser/Perl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mail/Mbox/MessageParser/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto//Mail/Mbox/MessageParser
+@dirrm %%SITE_PERL%%/Mail/Mbox/MessageParser
+@dirrm %%SITE_PERL%%/Mail/Mbox/
+@unexec rmdir %D/%%SITE_PERL%%/Mail/Mbox/MessageParser 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Mail/Mbox 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Mail/Mbox/MessageParser 2>/dev/null || true