aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Mail-POP3Client
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 13:44:51 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 13:44:51 +0000
commit2810a628f9b95f0f9ffe4c65e649786feba8bf34 (patch)
tree7b2d5dffa9d83d20decdd77d1d48cd1801806159 /mail/p5-Mail-POP3Client
parenta63707796065d81528162c60d09e53eafa884b6f (diff)
downloadports-2810a628f9b95f0f9ffe4c65e649786feba8bf34.tar.gz
ports-2810a628f9b95f0f9ffe4c65e649786feba8bf34.zip
perl5 module to talk to a POP3 (RFC1081) server
Notes
Notes: svn path=/head/; revision=4143
Diffstat (limited to 'mail/p5-Mail-POP3Client')
-rw-r--r--mail/p5-Mail-POP3Client/Makefile34
-rw-r--r--mail/p5-Mail-POP3Client/distinfo1
-rw-r--r--mail/p5-Mail-POP3Client/pkg-comment1
-rw-r--r--mail/p5-Mail-POP3Client/pkg-descr16
-rw-r--r--mail/p5-Mail-POP3Client/pkg-plist4
5 files changed, 56 insertions, 0 deletions
diff --git a/mail/p5-Mail-POP3Client/Makefile b/mail/p5-Mail-POP3Client/Makefile
new file mode 100644
index 000000000000..e8422b08b38e
--- /dev/null
+++ b/mail/p5-Mail-POP3Client/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Mail-POP3Client
+# Version required: 1.14
+# Date created: October 24th 1996
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id: Makefile,v 1.2 1996/10/24 09:58:34 jfitz Exp $
+#
+
+DISTNAME= POP3Client-1_14
+PKGNAME= p5-Mail-POP3Client-1.14
+CATEGORIES+= mail
+MASTER_SITES= ftp://ftp.digital.com/pub/plan/perl/CPAN/modules/by-module/Mail/ \
+ ftp://ftp.cdrom.com/pub/perl/CPAN/modules/by-module/Mail/ \
+ ftp://ftp.cis.ufl.edu/pub/perl/CPAN/modules/by-module/Mail/ \
+ ftp://ftp.leo.org/pub/comp/programming/languages/perl/CPAN/modules/by-module/Mail/ \
+ ftp://ftp.demon.co.uk/pub/mirrors/perl/CPAN/modules/by-module/Mail/ \
+ ftp://ftp.lab.kdd.co.jp/lang/perl/CPAN/modules/by-module/Mail/
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5
+RUN_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ @ for file in Mail::POP3Client; do \
+ gzip -9nf ${PREFIX}/lib/perl5/man/man3/$$file.3; \
+ done
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/p5-Mail-POP3Client/distinfo b/mail/p5-Mail-POP3Client/distinfo
new file mode 100644
index 000000000000..85feba458637
--- /dev/null
+++ b/mail/p5-Mail-POP3Client/distinfo
@@ -0,0 +1 @@
+MD5 (POP3Client-1_14.tar.gz) = a3d4b784ecb510bf73dd2b0aa97efe28
diff --git a/mail/p5-Mail-POP3Client/pkg-comment b/mail/p5-Mail-POP3Client/pkg-comment
new file mode 100644
index 000000000000..6f119ccc4e83
--- /dev/null
+++ b/mail/p5-Mail-POP3Client/pkg-comment
@@ -0,0 +1 @@
+perl5 module to talk to a POP3 (RFC1081) server
diff --git a/mail/p5-Mail-POP3Client/pkg-descr b/mail/p5-Mail-POP3Client/pkg-descr
new file mode 100644
index 000000000000..0322fecfa6f3
--- /dev/null
+++ b/mail/p5-Mail-POP3Client/pkg-descr
@@ -0,0 +1,16 @@
+DESCRIPTION
+
+This module implements an Object-Oriented interface to a POP3 server. It is
+based on RFC1081.
+
+USAGE
+
+Here is a simple example to list out the headers in your remote mailbox:
+
+#!/usr/local/bin/perl
+
+use Mail::POP3Client;
+$pop = new Mail::POP3Client("me", "mypassword", "pop3.do.main");
+for ($i = 1; $i <= $pop->Count; $i++) {
+ print $pop->Head($i), "\n";
+} \ No newline at end of file
diff --git a/mail/p5-Mail-POP3Client/pkg-plist b/mail/p5-Mail-POP3Client/pkg-plist
new file mode 100644
index 000000000000..3fb89937a33e
--- /dev/null
+++ b/mail/p5-Mail-POP3Client/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/man/man3/Mail::POP3Client.3.gz
+lib/perl5/site_perl/Mail/POP3Client.pm
+lib/perl5/site_perl/i386-freebsd/auto/Mail/POP3Client/.packlist
+@dirrm lib/perl5/site_perl/i386-freebsd/auto/Mail/POP3Client