aboutsummaryrefslogtreecommitdiff
path: root/mail/p5-Net-SMTP-Server
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2014-08-29 17:48:07 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2014-08-29 17:48:07 +0000
commit1b7f41fa74a1323ed618e586d50ef5aa104ada7c (patch)
tree6e02f8ff7ea83c0b9200d81ee4d122e1b2adbb17 /mail/p5-Net-SMTP-Server
parent82463a7e915659906f88729ddbba064f3d379960 (diff)
downloadports-1b7f41fa74a1323ed618e586d50ef5aa104ada7c.tar.gz
ports-1b7f41fa74a1323ed618e586d50ef5aa104ada7c.zip
- Fix run time errors (upstream bugs: 80682, 37731)
- Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=366545
Diffstat (limited to 'mail/p5-Net-SMTP-Server')
-rw-r--r--mail/p5-Net-SMTP-Server/Makefile4
-rw-r--r--mail/p5-Net-SMTP-Server/files/patch-Server__Client.pm11
-rw-r--r--mail/p5-Net-SMTP-Server/files/patch-Server__Relay.pm11
3 files changed, 26 insertions, 0 deletions
diff --git a/mail/p5-Net-SMTP-Server/Makefile b/mail/p5-Net-SMTP-Server/Makefile
index 71fdd8bcd31c..9441b0db728e 100644
--- a/mail/p5-Net-SMTP-Server/Makefile
+++ b/mail/p5-Net-SMTP-Server/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Net-SMTP-Server
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= mail perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,6 +12,9 @@ DISTNAME= SMTP-Server-${PORTVERSION}
MAINTAINER= perl@FreeBSD.org
COMMENT= Native Perl SMTP Server
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
BUILD_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/mail/p5-Net-SMTP-Server/files/patch-Server__Client.pm b/mail/p5-Net-SMTP-Server/files/patch-Server__Client.pm
new file mode 100644
index 000000000000..91526c3e4731
--- /dev/null
+++ b/mail/p5-Net-SMTP-Server/files/patch-Server__Client.pm
@@ -0,0 +1,11 @@
+--- ./Server/Client.pm.orig 2014-08-29 12:27:51.000000000 -0400
++++ ./Server/Client.pm 2014-08-29 12:28:35.000000000 -0400
+@@ -126,7 +126,7 @@
+ return 1;
+ }
+
+- if(!defined(@{$self->{TO}})) {
++ if(!@{$self->{TO}}) {
+ $self->_put("503 You want me to read your mind? Tell me who to send it to!");
+ return 1;
+ }
diff --git a/mail/p5-Net-SMTP-Server/files/patch-Server__Relay.pm b/mail/p5-Net-SMTP-Server/files/patch-Server__Relay.pm
new file mode 100644
index 000000000000..2675be2efaec
--- /dev/null
+++ b/mail/p5-Net-SMTP-Server/files/patch-Server__Relay.pm
@@ -0,0 +1,11 @@
+--- ./Server/Relay.pm.orig 2014-08-29 12:29:32.000000000 -0400
++++ ./Server/Relay.pm 2014-08-29 12:30:08.000000000 -0400
+@@ -24,7 +24,7 @@
+ # Loop through the recipient list.
+ foreach $target (@{$self->{TO}}) {
+ my $rr;
+- my $domain = /@(.*)/;
++ my $domain = ($target =~ /@(.*)/) ? $1 : hostdomain;
+ my $res = new Net::DNS::Resolver;
+ my @mx = mx($res, defined($1) ? $1 : hostdomain);
+