aboutsummaryrefslogtreecommitdiff
path: root/mail/pear-MIME_Type
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-20 15:08:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-20 15:08:19 +0000
commit794e1823fc99e1dcf693c65ddbecfcaa630099d5 (patch)
tree3327dcd940196980bdd08e5f1152648240ef30a2 /mail/pear-MIME_Type
parent3b7617676b728145d6d7607905f479bc4f5a33c4 (diff)
downloadports-794e1823fc99e1dcf693c65ddbecfcaa630099d5.tar.gz
ports-794e1823fc99e1dcf693c65ddbecfcaa630099d5.zip
New port: mail/pear-MIME_Type PEAR class for dealing with MIME types
PEAR::MIME_Type provides functionality for dealing with MIME types. PR: ports/80066 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net>
Notes
Notes: svn path=/head/; revision=133785
Diffstat (limited to 'mail/pear-MIME_Type')
-rw-r--r--mail/pear-MIME_Type/Makefile47
-rw-r--r--mail/pear-MIME_Type/distinfo2
-rw-r--r--mail/pear-MIME_Type/pkg-descr10
3 files changed, 59 insertions, 0 deletions
diff --git a/mail/pear-MIME_Type/Makefile b/mail/pear-MIME_Type/Makefile
new file mode 100644
index 000000000000..87c79a6b654f
--- /dev/null
+++ b/mail/pear-MIME_Type/Makefile
@@ -0,0 +1,47 @@
+# Ports collection makefile for: pear-MIME_Type
+# Date created: 18 April 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= MIME_Type
+PORTVERSION= 1.0.0
+CATEGORIES= mail www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class for dealing with MIME types
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LATEST_LINK= pear-${PORTNAME}
+OPTIONS= PEAR_SYSTEM_COMMAND "PEAR::System_Command support" off
+
+USE_REINPLACE= yes
+
+CATEGORY= MIME
+FILES= Type.php Type/Parameter.php
+EXAMPLES= example.php
+_EXAMPLESDIR= .
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/Type
+ @${MV} ${WRKSRC}/Parameter.php ${WRKSRC}/Type
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PEAR_SYSTEM_COMMAND)
+RUN_DEPENDS+= ${PEARDIR}/System/Command.php:${PORTSDIR}/devel/pear-System_Command
+.endif
+
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+
+post-patch:
+.for file in ${FILES}
+ @${REINPLACE_CMD} -e "s|@version@|${PORTVERSION}|" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e "s|@package@|${PORTNAME}|" ${WRKSRC}/${file}
+.endfor
+ @${REINPLACE_CMD} -e "s|@doc_dir@|${EXAMPLESDIR}|" ${WRKSRC}/${EXAMPLES}
+
+.include <bsd.port.post.mk>
diff --git a/mail/pear-MIME_Type/distinfo b/mail/pear-MIME_Type/distinfo
new file mode 100644
index 000000000000..6df345dc5bd4
--- /dev/null
+++ b/mail/pear-MIME_Type/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/MIME_Type-1.0.0.tgz) = dc2d377a121c6410d5f5c46e8ec32c03
+SIZE (PEAR/MIME_Type-1.0.0.tgz) = 4404
diff --git a/mail/pear-MIME_Type/pkg-descr b/mail/pear-MIME_Type/pkg-descr
new file mode 100644
index 000000000000..b44ae969e32e
--- /dev/null
+++ b/mail/pear-MIME_Type/pkg-descr
@@ -0,0 +1,10 @@
+PEAR::MIME_Type provides functionality for dealing with MIME types.
+
+* Parse MIME type.
+* Supports full RFC2045 specification.
+* Many utility functions for working with and determining info about types.
+* Most functions can be called statically.
+* Autodetect a file's mime-type, either with mime_content_type() or the 'file'
+command.
+
+WWW: http://pear.php.net/package/MIME_Type/