aboutsummaryrefslogtreecommitdiff
path: root/mail/perdition
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2013-01-09 10:43:22 +0000
committerJason E. Hale <jhale@FreeBSD.org>2013-01-09 10:43:22 +0000
commit226ace8158dcbb3a618c013d00599db8c0c23335 (patch)
tree4923bdb68c73e6ad97e0a8564259bca8aab94799 /mail/perdition
parent0b617f4cc666d2d394eddb1273d7aa9f60083158 (diff)
downloadports-226ace8158dcbb3a618c013d00599db8c0c23335.tar.gz
ports-226ace8158dcbb3a618c013d00599db8c0c23335.zip
- Use MLINKS to register additional manpages to plist [1]
- Remove leftover SSL option [2] - Use more standard LDAP option instead of OPENLDAP [2] - Use new generic NIS description and drop "backend" from GDBM description so it looks like the other database options - Bump PORTREVISON due to MLINKS change Reported by: Redports QAT [1], bapt [2]
Notes
Notes: svn path=/head/; revision=310134
Diffstat (limited to 'mail/perdition')
-rw-r--r--mail/perdition/Makefile22
-rw-r--r--mail/perdition/pkg-plist10
2 files changed, 18 insertions, 14 deletions
diff --git a/mail/perdition/Makefile b/mail/perdition/Makefile
index 038346a6c280..d77275c85f4f 100644
--- a/mail/perdition/Makefile
+++ b/mail/perdition/Makefile
@@ -3,6 +3,7 @@
PORTNAME= perdition
PORTVERSION= 1.18
+PORTREVISION= 1
CATEGORIES= mail net security
MASTER_SITES= http://horms.net/projects/perdition/download/${PORTVERSION}/
@@ -16,7 +17,11 @@ LIB_DEPENDS= popt:${PORTSDIR}/devel/popt \
MAN5= perditiondb.5
MAN8= perdition.8
-
+MLINKS= perdition.8 perdition.imap4.8 \
+ perdition.8 perdition.imap4s.8 \
+ perdition.8 perdition.imaps.8 \
+ perdition.8 perdition.pop3.8 \
+ perdition.8 perdition.pop3s.8
MANCOMPRESSED= no
USE_AUTOTOOLS= libtool
@@ -31,13 +36,12 @@ USE_LDCONFIG= yes
USE_RC_SUBR= perdition perdition.pop3 perdition.pop3s \
perdition.imap4 perdition.imap4s perdition.imaps
-OPTIONS_DEFINE= BDB DAEMON_MAP GDBM MYSQL NIS ODBC OPENLDAP OPENSSL PGSQL POSIX_REGEX SSL
-OPTIONS_DEFAULT= GDBM POSIX_REGEX SSL
+OPTIONS_DEFINE= BDB DAEMON_MAP DOCS GDBM LDAP MYSQL NIS ODBC \
+ OPENSSL PGSQL POSIX_REGEX
+OPTIONS_DEFAULT= GDBM OPENSSL POSIX_REGEX
DAEMON_MAP_DESC= Daemon Map support
-GDBM_DESC= GDBM database backend
-NIS_DESC= NIS database backend
-OPENLDAP_DESC= OpenLDAP database backend
+GDBM_DESC= GDBM database
POSIX_REGEX_DESC= Native regex support
.include <bsd.port.options.mk>
@@ -115,16 +119,16 @@ CONFIGURE_ARGS+= --disable-pg
PLIST_SUB+= PGSQL="@comment "
.endif
-.if ${PORT_OPTIONS:MOPENLDAP}
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --enable-ldap \
--with-ldap-schema-directory=${LOCALBASE}/etc/openldap/schema/ \
--disable-ldap-doc
-PLIST_SUB+= OPENLDAP=""
+PLIST_SUB+= LDAP=""
MAN8+= perditiondb_ldap_makedb.8
.else
CONFIGURE_ARGS+= --disable-ldap
-PLIST_SUB+= OPENLDAP="@comment "
+PLIST_SUB+= LDAP="@comment "
.endif
.if ${PORT_OPTIONS:MODBC}
diff --git a/mail/perdition/pkg-plist b/mail/perdition/pkg-plist
index 19b494be8373..60b7e3aa6c6f 100644
--- a/mail/perdition/pkg-plist
+++ b/mail/perdition/pkg-plist
@@ -1,6 +1,6 @@
%%GDBM%%bin/makegdbm
%%BDB%%bin/makebdb
-%%OPENLDAP%%sbin/perditiondb_ldap_makedb
+%%LDAP%%sbin/perditiondb_ldap_makedb
%%ODBC%%sbin/perditiondb_odbc_makedb
%%MYSQL%%sbin/perditiondb_mysql_makedb
%%PGSQL%%sbin/perditiondb_postgresql_makedb
@@ -21,10 +21,10 @@ etc/perdition/Makefile
%%GDBM%%lib/libperditiondb_gdbm.so
%%GDBM%%lib/libperditiondb_gdbm.la
%%GDBM%%lib/libperditiondb_gdbm.a
-%%OPENLDAP%%lib/libperditiondb_ldap.so.0
-%%OPENLDAP%%lib/libperditiondb_ldap.so
-%%OPENLDAP%%lib/libperditiondb_ldap.la
-%%OPENLDAP%%lib/libperditiondb_ldap.a
+%%LDAP%%lib/libperditiondb_ldap.so.0
+%%LDAP%%lib/libperditiondb_ldap.so
+%%LDAP%%lib/libperditiondb_ldap.la
+%%LDAP%%lib/libperditiondb_ldap.a
%%MYSQL%%lib/libperditiondb_mysql.so.0
%%MYSQL%%lib/libperditiondb_mysql.so
%%MYSQL%%lib/libperditiondb_mysql.la