aboutsummaryrefslogtreecommitdiff
path: root/mail/php73-imap
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2018-10-08 08:52:51 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2018-10-08 08:52:51 +0000
commit3a5533b48d284380e9a3a97b953e1a555242caf2 (patch)
treeadfd6b20496941d7ab22cbbb81aacdf0db2ffbe3 /mail/php73-imap
parentefe5dba5fb2dfc94a3bb101e8b9920b0ab69c2c3 (diff)
downloadports-3a5533b48d284380e9a3a97b953e1a555242caf2.tar.gz
ports-3a5533b48d284380e9a3a97b953e1a555242caf2.zip
Notes
Diffstat (limited to 'mail/php73-imap')
-rw-r--r--mail/php73-imap/Makefile11
-rw-r--r--mail/php73-imap/files/patch-config.m442
2 files changed, 53 insertions, 0 deletions
diff --git a/mail/php73-imap/Makefile b/mail/php73-imap/Makefile
new file mode 100644
index 000000000000..adfe95ecf964
--- /dev/null
+++ b/mail/php73-imap/Makefile
@@ -0,0 +1,11 @@
+# $FreeBSD$
+
+CATEGORIES= mail
+
+MASTERDIR= ${.CURDIR}/../../lang/php73
+
+PKGNAMESUFFIX= -imap
+
+TEST_TARGET= test
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/php73-imap/files/patch-config.m4 b/mail/php73-imap/files/patch-config.m4
new file mode 100644
index 000000000000..ab7120b2c8c8
--- /dev/null
+++ b/mail/php73-imap/files/patch-config.m4
@@ -0,0 +1,42 @@
+--- config.m4.orig 2010-02-07 14:06:54.000000000 +0100
++++ config.m4 2010-03-08 11:56:24.000000000 +0100
+@@ -103,6 +103,8 @@
+ PHP_ARG_WITH(imap-ssl,for IMAP SSL support,
+ [ --with-imap-ssl[=DIR] IMAP: Include SSL support. DIR is the OpenSSL install prefix], no, no)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir IMAP: pcre install prefix], no, no)
+
+ if test "$PHP_IMAP" != "no"; then
+ PHP_SUBST(IMAP_SHARED_LIBADD)
+@@ -119,6 +121,30 @@
+ fi
+ done
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ dnl Check for c-client version 2004
+ AC_EGREP_HEADER(mail_fetch_overview_sequence, $IMAP_INC_DIR/mail.h, [
+ AC_DEFINE(HAVE_IMAP2004,1,[ ])