aboutsummaryrefslogtreecommitdiff
path: root/mail/pop3vscan/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-06-03 07:54:47 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-06-03 07:54:47 +0000
commit4c1f40498ee7afcf70d8245ba3904abb2abcc134 (patch)
treeab6fc266282d513484a1304fcbd23a7b2b42b66b /mail/pop3vscan/Makefile
parent3273442a2482cd4ae3659ccc7c0ccbc62ec7cdf0 (diff)
downloadports-4c1f40498ee7afcf70d8245ba3904abb2abcc134.tar.gz
ports-4c1f40498ee7afcf70d8245ba3904abb2abcc134.zip
Notes
Diffstat (limited to 'mail/pop3vscan/Makefile')
-rw-r--r--mail/pop3vscan/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/mail/pop3vscan/Makefile b/mail/pop3vscan/Makefile
new file mode 100644
index 000000000000..bacb63668c15
--- /dev/null
+++ b/mail/pop3vscan/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: pop3vscan
+# Date created: 01 June 2003
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pop3vscan
+PORTVERSION= 0.4
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= A transparent POP3-Proxy with virus-scanning capabilities
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+
+.if !defined(WITHOUT_UVSCAN)
+RUN_DEPENDS= uvscan:${PORTSDIR}/security/vscan
+.endif
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+
+pre-fetch:
+.if !defined(WITHOUT_UVSCAN)
+ @${ECHO}
+ @${ECHO} "Type \"make WITHOUT_UVSCAN=yes\" if you DONT use UVSCAN."
+ @${ECHO}
+.endif
+
+post-extract:
+ @${RM} ${WRKSRC}/ripmime/ripmime.a
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,g' ${WRKSRC}/*.c
+ @${REINPLACE_CMD} -e 's,#endif.*,#endif,g' ${WRKSRC}/*.h
+ @${REINPLACE_CMD} -e 's,make,${GMAKE},g' ${WRKSRC}/ripmime/build_tnef
+ @${REINPLACE_CMD} -e 's,=4321,=_BYTE_ORDER -include machine/endian.h,g' \
+ ${WRKSRC}/ripmime/tnef/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pop3vscan ${PREFIX}/sbin/
+ ${INSTALL_DATA} ${WRKSRC}/pop3vscan.conf ${PREFIX}/etc/pop3vscan.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/pop3vscan.mail ${PREFIX}/etc/pop3vscan.mail.sample
+ ${INSTALL_SCRIPT} ${FILESDIR}/pop3vscan.sh ${PREFIX}/etc/rc.d/
+
+post-install:
+ @${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${SED} -e 's,PREFIX,${PREFIX},g' ${PKGMESSAGE}
+
+.include <bsd.port.mk>