aboutsummaryrefslogtreecommitdiff
path: root/mail/popa3d
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-02-24 16:31:26 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-02-24 16:31:26 +0000
commit781d06feb31772ceb3a48894ce39cbfd68b48398 (patch)
tree2db9ffd0511e673f3fe3ace28597e7fe0a698d2f /mail/popa3d
parent4ab61366a2a703608af15655c60d124a96d26bcd (diff)
downloadports-781d06feb31772ceb3a48894ce39cbfd68b48398.tar.gz
ports-781d06feb31772ceb3a48894ce39cbfd68b48398.zip
- suppress pkg-message when STANDALONE_POP3 is defined (while building)
PR: 63309 Submitted by: Linh Pham - suppress pkg-message and pkg-deinstall when STANDALONE_POP3 is defined so the package will print neither. - adds CONFLICTS with own variants.
Notes
Notes: svn path=/head/; revision=101998
Diffstat (limited to 'mail/popa3d')
-rw-r--r--mail/popa3d/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/mail/popa3d/Makefile b/mail/popa3d/Makefile
index 3675d7061229..b7bef9d2341d 100644
--- a/mail/popa3d/Makefile
+++ b/mail/popa3d/Makefile
@@ -25,16 +25,21 @@ ALL_TARGET= popa3d
MAN8= popa3d.8
PLIST= ${WRKDIR}/.PLIST.more
CFLAGS+= -DPREFIX=${PREFIX}
+.if defined(STANDALONE_POP3)
+PLIST_SUB+= STANDALONE_POP3=""
+CONFLICTS?= popa3d-0.* popa3d-before-sendmail-0.*
+PKGMESSAGE= ${NONEXISTENT}
+PKGDEINSTALL= ${NONEXISTENT}
+.else
+PLIST_SUB+= STANDALONE_POP3="@comment "
+.endif
.if defined(SMTP_AFTER_POP3)
EXTRA_PATCHES+= ${FILESDIR}/pop-before-sendmail.patch
PLIST_SUB+= SMTP_AFTER_POP3=""
+CONFLICTS?= popa3d-0.* popa3d-standalone-0.*
.else
PLIST_SUB+= SMTP_AFTER_POP3="@comment "
-.endif
-.if defined(STANDALONE_POP3)
-PLIST_SUB+= STANDALONE_POP3=""
-.else
-PLIST_SUB+= STANDALONE_POP3="@comment "
+CONFLICTS?= popa3d-standalone-0.* popa3d-before-sendmail-0.*
.endif
.if defined(STANDALONE_POP3)
@@ -85,8 +90,10 @@ do-install:
.endif
.endif
+.if !defined(STANDALONE_POP3)
post-install:
@ ${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.mk>