aboutsummaryrefslogtreecommitdiff
path: root/mail/popd/files
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2002-01-18 14:41:58 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2002-01-18 14:41:58 +0000
commita75a8789a0ef241e64cc228aa597ef6cbafd39ad (patch)
treeb7e9505589c47fa4239ba037715a30212f7bf915 /mail/popd/files
parent793e6d3d8943a5f054350b99c2ffb827af25abaa (diff)
downloadports-a75a8789a0ef241e64cc228aa597ef6cbafd39ad.tar.gz
ports-a75a8789a0ef241e64cc228aa597ef6cbafd39ad.zip
Notes
Diffstat (limited to 'mail/popd/files')
-rw-r--r--mail/popd/files/patch-lib::Makefile16
-rw-r--r--mail/popd/files/patch-mbox_maildir.c10
-rw-r--r--mail/popd/files/patch-mbox_mbf.c11
-rw-r--r--mail/popd/files/patch-popd.823
-rw-r--r--mail/popd/files/patch-popd.c19
-rw-r--r--mail/popd/files/patch-src::Makefile27
6 files changed, 43 insertions, 63 deletions
diff --git a/mail/popd/files/patch-lib::Makefile b/mail/popd/files/patch-lib::Makefile
new file mode 100644
index 000000000000..51db44aff5a8
--- /dev/null
+++ b/mail/popd/files/patch-lib::Makefile
@@ -0,0 +1,16 @@
+--- lib/Makefile.orig Fri Dec 7 15:34:54 2001
++++ lib/Makefile Fri Jan 18 15:48:02 2002
+@@ -3,10 +3,11 @@
+ LIB=poputil
+ SRCS= funcs.c lockfile.c mailbox.c mbox_maildir.c mbox_mailidx.c mbox_mbf.c
+ INCS=poputil.h
+-CFLAGS = -g -Wall -O -pipe -fPIC -shared -DUSE_SSL
++CFLAGS+= -Wall -DUSE_SSL
+ SHLIB_MAJOR= 1
+ SHLIB_MINOR= 0
+-DESTDIR=/usr/local/
++DESTDIR= ${PREFIX}/
++PREFIX?= /usr/local
+ LIBDIR=lib
+ INCDIR=include
+
diff --git a/mail/popd/files/patch-mbox_maildir.c b/mail/popd/files/patch-mbox_maildir.c
deleted file mode 100644
index 699ad6697708..000000000000
--- a/mail/popd/files/patch-mbox_maildir.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- mbox_maildir.c.orig Tue Apr 17 05:09:26 2001
-+++ mbox_maildir.c Wed May 16 08:52:34 2001
-@@ -212,6 +212,7 @@
- continue;
- }
- }
-+ facility = LOG_INFO;
- syslog(facility, "%s: retr %d leave %d %d byte%s %d error%s D%d(%d) "
- "E%d(%d) R%d(%d)",
- user->auth_string, ret, user->mbx.mail.num - del - exp - rem,
diff --git a/mail/popd/files/patch-mbox_mbf.c b/mail/popd/files/patch-mbox_mbf.c
deleted file mode 100644
index 0df30b9d0baa..000000000000
--- a/mail/popd/files/patch-mbox_mbf.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- mbox_mbf.c.orig Tue Apr 17 05:09:26 2001
-+++ mbox_mbf.c Wed May 16 08:52:34 2001
-@@ -178,7 +178,7 @@
- size_t left, bytes, len;
- char buffer[MAXBUFLEN];
-
-- facility = LOG_NOTICE;
-+ facility = LOG_INFO;
- ret = del = exp = rem = errors = 0;
- dst = -1;
- for (i = 0; i <= user->mbx.num; i++) {
diff --git a/mail/popd/files/patch-popd.8 b/mail/popd/files/patch-popd.8
deleted file mode 100644
index 30f94acc8100..000000000000
--- a/mail/popd/files/patch-popd.8
+++ /dev/null
@@ -1,23 +0,0 @@
---- popd.8 2001/04/09 12:16:39 1.16
-+++ popd.8 2001/05/30 08:36:04
-@@ -538,6 +538,20 @@
- Exit status as defined in
- .Xr sysexits 3
- are returned.
-+.Pp
-+.Nm
-+reports status messages, warnings and errors via
-+.Xr syslog 3
-+using the
-+.Dv LOG_DAEMON
-+facility.
-+Warnings and errors are logged using the
-+.Dv LOG_NOTICE
-+and
-+.Dv LOG_CRIT
-+priorities,
-+while connections, authentication and sessions are logged at
-+.Dv LOG_INFO .
- .Sh HISTORY
- .Nm
- was originally written for UUNET South Africa in 1999.
diff --git a/mail/popd/files/patch-popd.c b/mail/popd/files/patch-popd.c
deleted file mode 100644
index 6176902ed794..000000000000
--- a/mail/popd/files/patch-popd.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- popd.c.orig Tue Apr 17 05:09:26 2001
-+++ popd.c Wed May 16 09:00:39 2001
-@@ -501,6 +503,7 @@
- closesigpipe();
- opensigpipe();
- setsignals();
-+ facility = LOG_INFO;
- if (config.daemonise || config.debug)
- getnameinfo((struct sockaddr *)&addr, addr.ss_len,
- ip, sizeof(ip), NULL, 0,
-@@ -518,6 +521,8 @@
- sendline("+OK %s ready %s", IDENT, config.timestamp);
- switch (authenticate(&user)) {
- case TRUE:
-+ syslog(facility, "Login user=%s host=[%s]",
-+ user->username, ip);
- if (!config.proxy)
- transaction(user);
- else
diff --git a/mail/popd/files/patch-src::Makefile b/mail/popd/files/patch-src::Makefile
new file mode 100644
index 000000000000..0da20f3c36f4
--- /dev/null
+++ b/mail/popd/files/patch-src::Makefile
@@ -0,0 +1,27 @@
+--- src/Makefile.orig Thu Dec 27 12:13:00 2001
++++ src/Makefile Fri Jan 18 16:14:29 2002
+@@ -3,14 +3,19 @@
+ #
+
+ PROG= popd
+-CFLAGS+= -Wall -Werror -pedantic -I../lib -L../lib -L/usr/local/lib \
++CFLAGS+= -Wall -Werror -pedantic -I../lib -L../lib \
+ -DUSE_SSL -DUSE_IPV6
+ LDADD= -lcrypt -lmd -lradius -lpoputil -lssl -lcrypto
+-DPSDD= ${LIBCRYPT} ${LIBMD}
++DPADD= ${LIBCRYPT} ${LIBMD} ${LIBRADIUS} ${LIBSSL} ${LIBCRYPTO} \
++ ../lib/libpoputil.a
+ SRCS= popd.c authenticate.c transaction.c signals.c proxy.c
+ MAN8= popd.8
+-DESTDIR=/usr/local/
+-BINDIR=bin
+-MANDIR=share/man
++DESTDIR= ${PREFIX}/
++PREFIX?= /usr/local
++BINDIR=libexec
++MANDIR=man/man
++
++popd.8: popd.mdoc
++ sed -e "s,XX_PREFIX_XX,${PREFIX},g" < popd.mdoc > popd.8
+
+ .include <bsd.prog.mk>