aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-logwatch/Makefile
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2011-08-23 03:18:46 +0000
committerSahil Tandon <sahil@FreeBSD.org>2011-08-23 03:18:46 +0000
commit693a7f2e5da6847aec50e311d80d7ebb1b9d6545 (patch)
treefafe6df71d2791cc5d1e8c7766b9bf55e886d451 /mail/postfix-logwatch/Makefile
parent63309d266bc370804245d8e282ef51c36f38a8aa (diff)
downloadports-693a7f2e5da6847aec50e311d80d7ebb1b9d6545.tar.gz
ports-693a7f2e5da6847aec50e311d80d7ebb1b9d6545.zip
The postfix-logwatch(1) utility is a Postfix MTA log parser
that produces summaries, details, and statistics regarding the operation of Postfix. A key feature of postfix-logwatch is its ability to produce a very wide range of reports with data grouped and sorted as much as possible to reduce noise and highlight patterns. Brief summary reports provide a quick overview of general Postfix operations and message delivery, calling out warnings that may require attention. Detailed reports provide easy to scan, hierarchically-arranged and organized information, with as much or little detail as desired. WWW: http://logreporters.sourceforge.net/ PR: ports/159988 Submitted by: Alexander Moisseev <moiseev@mezonplus.ru>
Notes
Notes: svn path=/head/; revision=280235
Diffstat (limited to 'mail/postfix-logwatch/Makefile')
-rw-r--r--mail/postfix-logwatch/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/mail/postfix-logwatch/Makefile b/mail/postfix-logwatch/Makefile
new file mode 100644
index 000000000000..efead3760b7c
--- /dev/null
+++ b/mail/postfix-logwatch/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: postfix-logwatch
+# Date created: 2011-08-19
+# Whom: Alexander Moisseev <moiseev@mezonplus.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postfix-logwatch
+PORTVERSION= 1.39.05
+CATEGORIES= mail
+MASTER_SITES= SF/logreporters/${PORTNAME}/release/${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= moiseev@mezonplus.ru
+COMMENT= Postfix MTA log parser
+
+LICENSE= GPLv2
+
+PORTDOCS= Bugs Changes README
+PORTEXAMPLES= ${PORTNAME}.conf ${PORTNAME}.conf-topn
+
+MAN1= ${PORTNAME}.1
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+post-patch:
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e '\
+ s!/usr/local/etc!${ETCDIR}! \
+ ' ${PORTNAME} ${PORTNAME}.1 README
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ @${CP} ${WRKSRC}/${PORTNAME}.conf ${WRKSRC}/${PORTNAME}.conf.sample
+ @${MKDIR} ${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample ${ETCDIR}
+
+post-install:
+ @if [ ! -f ${ETCDIR}/${PORTNAME}.conf ]; then \
+ ${CP} -p ${ETCDIR}/${PORTNAME}.conf.sample ${ETCDIR}/${PORTNAME}.conf; \
+ fi
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>