aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-logwatch/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-07-15 16:14:15 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-07-15 16:14:15 +0000
commit99afccd1ce89497265f41f1d5227f29ef3c490e9 (patch)
tree8016e5f5a18362984e9d2e003efd51fd5fc95cc4 /mail/postfix-logwatch/Makefile
parentfe802debc78394a4c926286c651336c7f88f2fed (diff)
downloadports-99afccd1ce89497265f41f1d5227f29ef3c490e9.tar.gz
ports-99afccd1ce89497265f41f1d5227f29ef3c490e9.zip
Add DOCS to OPTIONS_DEFINE to ports that check for PORT_OPTIONS:MDOCS.
Notes
Notes: svn path=/head/; revision=361961
Diffstat (limited to 'mail/postfix-logwatch/Makefile')
-rw-r--r--mail/postfix-logwatch/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/mail/postfix-logwatch/Makefile b/mail/postfix-logwatch/Makefile
index adbdb298f774..8bec84bf7728 100644
--- a/mail/postfix-logwatch/Makefile
+++ b/mail/postfix-logwatch/Makefile
@@ -22,12 +22,12 @@ USE_PERL5= run
NO_BUILD= yes
SHEBANG_FILES= ${PORTNAME}
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
post-patch:
- @cd ${WRKSRC} && ${REINPLACE_CMD} -e '\
- s!/usr/local/etc!${ETCDIR}! \
- ' ${PORTNAME} ${PORTNAME}.1 README
+ @(cd ${WRKSRC} && \
+ ${REINPLACE_CMD} -e 's!/usr/local/etc!${ETCDIR}' \
+ ${PORTNAME} ${PORTNAME}.1 README)
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
@@ -36,16 +36,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${STAGEDIR}${ETCDIR}/${PORTNAME}.conf.sample
post-install:
- @if [ ! -f ${ETCDIR}/${PORTNAME}.conf ]; then \
- ${CP} -p ${STAGEDIR}${ETCDIR}/${PORTNAME}.conf.sample ${STAGEDIR}${ETCDIR}/${PORTNAME}.conf; \
- fi
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
-.endif
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>