aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-logwatch
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-06-21 21:50:43 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-06-21 21:50:43 +0000
commitcc76e2af16aaf33f3c694f68d631c4a5b16fe634 (patch)
treeb4263849b68b6fed7f246906d848f22c21d76cdb /mail/postfix-logwatch
parent47c0b3dea0647ff91b000a98b85618da7ab107aa (diff)
downloadports-cc76e2af16aaf33f3c694f68d631c4a5b16fe634.tar.gz
ports-cc76e2af16aaf33f3c694f68d631c4a5b16fe634.zip
- Fix regex handling with the new perl version [1]
[1] Unescaped left brace in regex is deprecated, passed through in regex PR: 227895 Submitted by: zeising Pull Request:
Notes
Notes: svn path=/head/; revision=473005
Diffstat (limited to 'mail/postfix-logwatch')
-rw-r--r--mail/postfix-logwatch/Makefile1
-rw-r--r--mail/postfix-logwatch/files/patch-postfix-logwatch22
2 files changed, 23 insertions, 0 deletions
diff --git a/mail/postfix-logwatch/Makefile b/mail/postfix-logwatch/Makefile
index 2d61b3f2f2c7..326447437056 100644
--- a/mail/postfix-logwatch/Makefile
+++ b/mail/postfix-logwatch/Makefile
@@ -3,6 +3,7 @@
PORTNAME= postfix-logwatch
PORTVERSION= 1.40.03
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF/logreporters/${PORTNAME}/release/${PORTVERSION}
diff --git a/mail/postfix-logwatch/files/patch-postfix-logwatch b/mail/postfix-logwatch/files/patch-postfix-logwatch
new file mode 100644
index 000000000000..3d07be9ec19b
--- /dev/null
+++ b/mail/postfix-logwatch/files/patch-postfix-logwatch
@@ -0,0 +1,22 @@
+--- postfix-logwatch.orig 2018-05-01 12:00:39 UTC
++++ postfix-logwatch
+@@ -1377,6 +1377,10 @@ sub print_summary_report (\@) {
+ sprintf "$fmt %-42s %6.2f%%\n", $total, $desc,
+ $$divisor == $Totals{$keyname} ? 100.00 : $Totals{$keyname} * 100 / $$divisor;
+ }
++ elsif ($extra eq '') {
++ push @{$lines[$cur_level]},
++ sprintf "$fmt %-23s\n", $total, $desc;
++ }
+ else {
+ push @{$lines[$cur_level]},
+ sprintf "$fmt %-23s $extra\n", $total, $desc, commify ($Totals{$keyname});
+@@ -1847,7 +1851,7 @@ sub postfix_policy_spf($) {
+ # KeyboardInterrupt
+ $line =~ /^Read line: "/ or
+ $line =~ /^Found the end of entry$/ or
+- $line =~ /^Config: {/ or
++ $line =~ /^Config: \{/ or
+ $line =~ /^spfcheck: pyspf result/ or
+ $line =~ /^Starting$/ or
+ $line =~ /^Normal exit$/ or