aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix-policyd-weight
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-05-24 08:00:32 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-05-24 08:00:32 +0000
commitd99ce327a56c893e0fe5ebbdc55bbf73f47b2e59 (patch)
tree8edfb0178d7efefa3066000c6bacacefec2c342a /mail/postfix-policyd-weight
parent888ac9b253670a1ddd4c4c4b97cb6f4f858a8e0f (diff)
downloadports-d99ce327a56c893e0fe5ebbdc55bbf73f47b2e59.tar.gz
ports-d99ce327a56c893e0fe5ebbdc55bbf73f47b2e59.zip
- fix build with changed Net::DNS API
in version Net::DNS v0.52 netdns_dn_expand was added as replacement for dn_expand in version Net::DNS v0.74 dn_expand was removed - bump PORTREVISION Tanks to Herbert J. Skuhra for notify about the Net::DNS issue on ports@
Notes
Notes: svn path=/head/; revision=354999
Diffstat (limited to 'mail/postfix-policyd-weight')
-rw-r--r--mail/postfix-policyd-weight/Makefile3
-rw-r--r--mail/postfix-policyd-weight/files/patch-policyd-weight20
2 files changed, 21 insertions, 2 deletions
diff --git a/mail/postfix-policyd-weight/Makefile b/mail/postfix-policyd-weight/Makefile
index 3686e587c19e..87e4325008dc 100644
--- a/mail/postfix-policyd-weight/Makefile
+++ b/mail/postfix-policyd-weight/Makefile
@@ -3,6 +3,7 @@
PORTNAME= policyd-weight
PORTVERSION= 0.1.15.2
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.policyd-weight.org/releases/ \
LOCAL/ohauer
@@ -13,7 +14,7 @@ COMMENT= Weighted policy daemon for postfix
LICENSE= GPLv2
-RUN_DEPENDS= p5-Net-DNS>0:${PORTSDIR}/dns/p5-Net-DNS \
+RUN_DEPENDS= p5-Net-DNS>=0.52:${PORTSDIR}/dns/p5-Net-DNS \
p5-Net-IP>0:${PORTSDIR}/net-mgmt/p5-Net-IP
SUB_FILES= pkg-message
diff --git a/mail/postfix-policyd-weight/files/patch-policyd-weight b/mail/postfix-policyd-weight/files/patch-policyd-weight
index 0fa75ec7f040..0a3b4cc74195 100644
--- a/mail/postfix-policyd-weight/files/patch-policyd-weight
+++ b/mail/postfix-policyd-weight/files/patch-policyd-weight
@@ -1,5 +1,14 @@
--- ./policyd-weight.orig 2011-09-03 15:55:02.000000000 +0200
-+++ ./policyd-weight 2014-03-15 17:15:33.000000000 +0100
++++ ./policyd-weight 2014-05-24 07:46:02.000000000 +0200
+@@ -69,7 +69,7 @@
+ use Sys::Syslog qw(:DEFAULT setlogsock);
+ use Net::DNS;
+ use Net::IP;
+-use Net::DNS::Packet qw(dn_expand);
++use Net::DNS::Packet qw(netdns_dn_expand);
+ use IO::Socket::INET;
+ use IO::Socket::UNIX;
+ use IO::Select;
@@ -320,7 +320,7 @@
my $DEBUG = 0; # 1 or 0 - don't comment
@@ -133,6 +142,15 @@
{
mylog(warning=>"cache: couldn't change GID to user $GROUP: $!");
}
+@@ -3588,7 +3587,7 @@
+ my ($id, $bf, $qc, $anc, $nsc, $arc, $qb) =
+ unpack('n n n n n n a*', $buf);
+
+- my ($dn, $offset) = dn_expand(\$qb, 0);
++ my ($dn, $offset) = netdns_dn_expand(\$qb, 0);
+
+ if(($id && $anc) && ($id == $oid) && ($query eq $dn))
+ {
@@ -3842,7 +3841,7 @@
my $helo = shift;
my $ip = shift;