aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix1
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-01-24 20:11:07 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-01-24 20:11:07 +0000
commit35bf8b1ccbbc7b664d0e05cbd1f67a1bd74c7939 (patch)
treeb1d55b3eec60ed5b4f9b2877ae31311c91ab2366 /mail/postfix1
parent21ad94c8e6f0e4c96731ed2af08092568fc0f535 (diff)
downloadports-35bf8b1ccbbc7b664d0e05cbd1f67a1bd74c7939.tar.gz
ports-35bf8b1ccbbc7b664d0e05cbd1f67a1bd74c7939.zip
Notes
Diffstat (limited to 'mail/postfix1')
-rw-r--r--mail/postfix1/Makefile33
-rw-r--r--mail/postfix1/pkg-plist168
-rw-r--r--mail/postfix1/scripts/configure.postfix4
3 files changed, 102 insertions, 103 deletions
diff --git a/mail/postfix1/Makefile b/mail/postfix1/Makefile
index 1c87798c4522..ba5ee4456e2d 100644
--- a/mail/postfix1/Makefile
+++ b/mail/postfix1/Makefile
@@ -32,7 +32,6 @@ COMMENT= An alternative to widely-used Sendmail
CONFLICTS= courier-0.* postfix-2.* sendmail-8.* sendmail-*-8.* smail-3.* zmailer-2.*
LATEST_LINK= postfix1
USE_SUBMAKE= yes
-USE_REINPLACE= yes
USE_RC_SUBR= postfix.sh
PATCH_STRIP= -p1
@@ -87,24 +86,24 @@ READMEDIR=${PREFIX}/share/doc/postfix
SUB_LIST+= REQUIRE="${_REQUIRE}"
pre-patch:
-.for file in ${MAN1}
+.for f in ${MAN1}
@${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
- ${WRKSRC}/man/man1/${file} ${WRKSRC}/html/${file}.html
+ ${WRKSRC}/man/man1/${f} ${WRKSRC}/html/${f}.html
.endfor
-.for file in ${MAN5}
+.for f in ${MAN5}
@${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
- ${WRKSRC}/man/man5/${file} ${WRKSRC}/html/${file}.html
+ ${WRKSRC}/man/man5/${f} ${WRKSRC}/html/${f}.html
.endfor
-.for file in ${MAN8base}
+.for f in ${MAN8base}
@${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
- ${WRKSRC}/man/man8/${file} ${WRKSRC}/html/${file}.html
+ ${WRKSRC}/man/man8/${f} ${WRKSRC}/html/${f}.html
.endfor
-.for file in faq rate rewrite uce
+.for f in faq rate rewrite uce
@${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" \
- ${WRKSRC}/html/${file}.html
+ ${WRKSRC}/html/${f}.html
.endfor
-.for file in ${CONF1}
- @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" ${WRKSRC}/conf/${file}
+.for f in ${CONF1}
+ @${REINPLACE_CMD} -e "s|/etc/postfix|${PREFIX}/etc/postfix|g" ${WRKSRC}/conf/${f}
.endfor
post-patch:
@@ -121,7 +120,7 @@ pre-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
- cd ${WRKSRC}; sh postfix-install -non-interactive install_root=/ tempdir=/tmp \
+ cd ${WRKSRC}; ${SH} postfix-install -non-interactive install_root=/ tempdir=/tmp \
config_directory=${PREFIX}/etc/postfix \
daemon_directory=${PREFIX}/libexec/postfix \
command_directory=${PREFIX}/sbin \
@@ -135,9 +134,9 @@ do-install:
sample_directory=${PREFIX}/etc/postfix \
readme_directory=${READMEDIR}
-.for file in ${CONF1}
- ${INSTALL_DATA} ${WRKSRC}/conf/${file} \
- ${PREFIX}/etc/postfix/sample-${file}
+.for f in ${CONF1}
+ ${INSTALL_DATA} ${WRKSRC}/conf/${f} \
+ ${PREFIX}/etc/postfix/sample-${f}
.endfor
@${INSTALL_SCRIPT} \
@@ -145,9 +144,9 @@ do-install:
${PREFIX}/bin/rmail
# optional TEST binaries
-.for file in ${BIN1}
+.for f in ${BIN1}
@${INSTALL_PROGRAM} \
- ${WRKSRC}/src/smtpstone/${file} \
+ ${WRKSRC}/src/smtpstone/${f} \
${PREFIX}/sbin
.endfor
diff --git a/mail/postfix1/pkg-plist b/mail/postfix1/pkg-plist
index 8291aa7f2d28..7a37ab352bfa 100644
--- a/mail/postfix1/pkg-plist
+++ b/mail/postfix1/pkg-plist
@@ -86,88 +86,88 @@ bin/newaliases
bin/mailq
%%SUB_TEST%%sbin/smtp-sink
%%SUB_TEST%%sbin/smtp-source
-%%PORTDOCS%%share/doc/postfix/DB_README
-%%PORTDOCS%%share/doc/postfix/DEBUG_README
-%%PORTDOCS%%share/doc/postfix/ETRN_README
-%%PORTDOCS%%share/doc/postfix/FILTER_README
-%%PORTDOCS%%share/doc/postfix/INSTALL
-%%PORTDOCS%%share/doc/postfix/LDAP_README
-%%PORTDOCS%%share/doc/postfix/LINUX_README
-%%PORTDOCS%%share/doc/postfix/LMTP_README
-%%PORTDOCS%%share/doc/postfix/MACOSX_README
-%%PORTDOCS%%share/doc/postfix/MYSQL_README
-%%PORTDOCS%%share/doc/postfix/NFS_README
-%%PORTDOCS%%share/doc/postfix/PACKAGE_README
-%%PORTDOCS%%share/doc/postfix/PCRE_README
-%%PORTDOCS%%share/doc/postfix/QMQP_README
-%%PORTDOCS%%share/doc/postfix/RESTRICTION_CLASS_README
-%%PORTDOCS%%share/doc/postfix/SASL_README
-%%PORTDOCS%%share/doc/postfix/ULTRIX_README
-%%PORTDOCS%%share/doc/postfix/UUCP_README
-%%PORTDOCS%%share/doc/postfix/VERP_README
-%%PORTDOCS%%share/doc/postfix/VIRTUAL_README
-%%PORTDOCS%%share/doc/postfix/access.5.html
-%%PORTDOCS%%share/doc/postfix/aliases.5.html
-%%PORTDOCS%%share/doc/postfix/architecture.html
-%%PORTDOCS%%share/doc/postfix/backstage.html
-%%PORTDOCS%%share/doc/postfix/basic.html
-%%PORTDOCS%%share/doc/postfix/big-picture.gif
-%%PORTDOCS%%share/doc/postfix/big-picture.html
-%%PORTDOCS%%share/doc/postfix/bounce.8.html
-%%PORTDOCS%%share/doc/postfix/canonical.5.html
-%%PORTDOCS%%share/doc/postfix/cleanup.8.html
-%%PORTDOCS%%share/doc/postfix/commands.html
-%%PORTDOCS%%share/doc/postfix/defer.8.html
-%%PORTDOCS%%share/doc/postfix/delivering.html
-%%PORTDOCS%%share/doc/postfix/error.8.html
-%%PORTDOCS%%share/doc/postfix/faq.html
-%%PORTDOCS%%share/doc/postfix/flush.8.html
-%%PORTDOCS%%share/doc/postfix/goals.html
-%%PORTDOCS%%share/doc/postfix/inbound.gif
-%%PORTDOCS%%share/doc/postfix/index.html
-%%PORTDOCS%%share/doc/postfix/lmtp.8.html
-%%PORTDOCS%%share/doc/postfix/local.8.html
-%%PORTDOCS%%share/doc/postfix/mailq.1.html
-%%PORTDOCS%%share/doc/postfix/master.8.html
-%%PORTDOCS%%share/doc/postfix/motivation.html
-%%PORTDOCS%%share/doc/postfix/newaliases.1.html
-%%PORTDOCS%%share/doc/postfix/nqmgr.8.html
-%%PORTDOCS%%share/doc/postfix/outbound.gif
-%%PORTDOCS%%share/doc/postfix/pcre_table.5.html
-%%PORTDOCS%%share/doc/postfix/pickup.8.html
-%%PORTDOCS%%share/doc/postfix/pipe.8.html
-%%PORTDOCS%%share/doc/postfix/postalias.1.html
-%%PORTDOCS%%share/doc/postfix/postcat.1.html
-%%PORTDOCS%%share/doc/postfix/postconf.1.html
-%%PORTDOCS%%share/doc/postfix/postdrop.1.html
-%%PORTDOCS%%share/doc/postfix/postfix.1.html
-%%PORTDOCS%%share/doc/postfix/postkick.1.html
-%%PORTDOCS%%share/doc/postfix/postlock.1.html
-%%PORTDOCS%%share/doc/postfix/postlog.1.html
-%%PORTDOCS%%share/doc/postfix/postmap.1.html
-%%PORTDOCS%%share/doc/postfix/postqueue.1.html
-%%PORTDOCS%%share/doc/postfix/postsuper.1.html
-%%PORTDOCS%%share/doc/postfix/qmgr.8.html
-%%PORTDOCS%%share/doc/postfix/qmqpd.8.html
-%%PORTDOCS%%share/doc/postfix/queuing.html
-%%PORTDOCS%%share/doc/postfix/rate.html
-%%PORTDOCS%%share/doc/postfix/receiving.html
-%%PORTDOCS%%share/doc/postfix/regexp_table.5.html
-%%PORTDOCS%%share/doc/postfix/relocated.5.html
-%%PORTDOCS%%share/doc/postfix/resource.html
-%%PORTDOCS%%share/doc/postfix/rewrite.html
-%%PORTDOCS%%share/doc/postfix/security.html
-%%PORTDOCS%%share/doc/postfix/sendmail.1.html
-%%PORTDOCS%%share/doc/postfix/showq.8.html
-%%PORTDOCS%%share/doc/postfix/small-picture.gif
-%%PORTDOCS%%share/doc/postfix/smtp.8.html
-%%PORTDOCS%%share/doc/postfix/smtpd.8.html
-%%PORTDOCS%%share/doc/postfix/spawn.8.html
-%%PORTDOCS%%share/doc/postfix/transport.5.html
-%%PORTDOCS%%share/doc/postfix/trivial-rewrite.8.html
-%%PORTDOCS%%share/doc/postfix/uce.html
-%%PORTDOCS%%share/doc/postfix/virtual.5.html
-%%PORTDOCS%%share/doc/postfix/virtual.8.html
-%%PORTDOCS%%@dirrm share/doc/postfix
+%%PORTDOCS%%%%DOCSDIR%%/DB_README
+%%PORTDOCS%%%%DOCSDIR%%/DEBUG_README
+%%PORTDOCS%%%%DOCSDIR%%/ETRN_README
+%%PORTDOCS%%%%DOCSDIR%%/FILTER_README
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LDAP_README
+%%PORTDOCS%%%%DOCSDIR%%/LINUX_README
+%%PORTDOCS%%%%DOCSDIR%%/LMTP_README
+%%PORTDOCS%%%%DOCSDIR%%/MACOSX_README
+%%PORTDOCS%%%%DOCSDIR%%/MYSQL_README
+%%PORTDOCS%%%%DOCSDIR%%/NFS_README
+%%PORTDOCS%%%%DOCSDIR%%/PACKAGE_README
+%%PORTDOCS%%%%DOCSDIR%%/PCRE_README
+%%PORTDOCS%%%%DOCSDIR%%/QMQP_README
+%%PORTDOCS%%%%DOCSDIR%%/RESTRICTION_CLASS_README
+%%PORTDOCS%%%%DOCSDIR%%/SASL_README
+%%PORTDOCS%%%%DOCSDIR%%/ULTRIX_README
+%%PORTDOCS%%%%DOCSDIR%%/UUCP_README
+%%PORTDOCS%%%%DOCSDIR%%/VERP_README
+%%PORTDOCS%%%%DOCSDIR%%/VIRTUAL_README
+%%PORTDOCS%%%%DOCSDIR%%/access.5.html
+%%PORTDOCS%%%%DOCSDIR%%/aliases.5.html
+%%PORTDOCS%%%%DOCSDIR%%/architecture.html
+%%PORTDOCS%%%%DOCSDIR%%/backstage.html
+%%PORTDOCS%%%%DOCSDIR%%/basic.html
+%%PORTDOCS%%%%DOCSDIR%%/big-picture.gif
+%%PORTDOCS%%%%DOCSDIR%%/big-picture.html
+%%PORTDOCS%%%%DOCSDIR%%/bounce.8.html
+%%PORTDOCS%%%%DOCSDIR%%/canonical.5.html
+%%PORTDOCS%%%%DOCSDIR%%/cleanup.8.html
+%%PORTDOCS%%%%DOCSDIR%%/commands.html
+%%PORTDOCS%%%%DOCSDIR%%/defer.8.html
+%%PORTDOCS%%%%DOCSDIR%%/delivering.html
+%%PORTDOCS%%%%DOCSDIR%%/error.8.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/flush.8.html
+%%PORTDOCS%%%%DOCSDIR%%/goals.html
+%%PORTDOCS%%%%DOCSDIR%%/inbound.gif
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/lmtp.8.html
+%%PORTDOCS%%%%DOCSDIR%%/local.8.html
+%%PORTDOCS%%%%DOCSDIR%%/mailq.1.html
+%%PORTDOCS%%%%DOCSDIR%%/master.8.html
+%%PORTDOCS%%%%DOCSDIR%%/motivation.html
+%%PORTDOCS%%%%DOCSDIR%%/newaliases.1.html
+%%PORTDOCS%%%%DOCSDIR%%/nqmgr.8.html
+%%PORTDOCS%%%%DOCSDIR%%/outbound.gif
+%%PORTDOCS%%%%DOCSDIR%%/pcre_table.5.html
+%%PORTDOCS%%%%DOCSDIR%%/pickup.8.html
+%%PORTDOCS%%%%DOCSDIR%%/pipe.8.html
+%%PORTDOCS%%%%DOCSDIR%%/postalias.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postcat.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postconf.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postdrop.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postfix.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postkick.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postlock.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postlog.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postmap.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postqueue.1.html
+%%PORTDOCS%%%%DOCSDIR%%/postsuper.1.html
+%%PORTDOCS%%%%DOCSDIR%%/qmgr.8.html
+%%PORTDOCS%%%%DOCSDIR%%/qmqpd.8.html
+%%PORTDOCS%%%%DOCSDIR%%/queuing.html
+%%PORTDOCS%%%%DOCSDIR%%/rate.html
+%%PORTDOCS%%%%DOCSDIR%%/receiving.html
+%%PORTDOCS%%%%DOCSDIR%%/regexp_table.5.html
+%%PORTDOCS%%%%DOCSDIR%%/relocated.5.html
+%%PORTDOCS%%%%DOCSDIR%%/resource.html
+%%PORTDOCS%%%%DOCSDIR%%/rewrite.html
+%%PORTDOCS%%%%DOCSDIR%%/security.html
+%%PORTDOCS%%%%DOCSDIR%%/sendmail.1.html
+%%PORTDOCS%%%%DOCSDIR%%/showq.8.html
+%%PORTDOCS%%%%DOCSDIR%%/small-picture.gif
+%%PORTDOCS%%%%DOCSDIR%%/smtp.8.html
+%%PORTDOCS%%%%DOCSDIR%%/smtpd.8.html
+%%PORTDOCS%%%%DOCSDIR%%/spawn.8.html
+%%PORTDOCS%%%%DOCSDIR%%/transport.5.html
+%%PORTDOCS%%%%DOCSDIR%%/trivial-rewrite.8.html
+%%PORTDOCS%%%%DOCSDIR%%/uce.html
+%%PORTDOCS%%%%DOCSDIR%%/virtual.5.html
+%%PORTDOCS%%%%DOCSDIR%%/virtual.8.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm libexec/postfix
-@dirrmtry etc/postfix
+@dirrmtry etc/postfix
diff --git a/mail/postfix1/scripts/configure.postfix b/mail/postfix1/scripts/configure.postfix
index 2acf13289114..dd6434ce5f26 100644
--- a/mail/postfix1/scripts/configure.postfix
+++ b/mail/postfix1/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix1/scripts/Attic/configure.postfix,v 1.43 2006-01-12 16:23:08 mnag Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix1/scripts/Attic/configure.postfix,v 1.44 2006-01-24 20:11:07 mnag Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -89,7 +89,7 @@ for i; do
TLS)
echo "MAN8+= tlsmgr.8"
echo "POSTFIX_CCARGS+= -DHAS_SSL -I/usr/include/openssl"
- echo "POSTFIX_AUXLIBS+= -lssl -lcrypto"
+ echo "POSTFIX_AUXLIBS+= -L\${OPENSSLLIB} \${LDFLAGS} -lssl -lcrypto"
echo "DISTFILES+= \${DISTNAME}.tar.gz pfixtls-0.8.11a-1.1.11-0.9.6g.tar.gz"
echo "EXTRA_PATCHES+= \${WRKDIR}/pfixtls-0.8.11a-1.1.11-0.9.6g/pfixtls.diff"
echo "TLS_SUFFIX= +tls"