aboutsummaryrefslogtreecommitdiff
path: root/mail/postfix
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-09-13 02:09:35 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-09-13 02:09:35 +0000
commit5552f65cdc2244f8ae6dbc04225f4102b3ddce65 (patch)
treec147c28fe59ee73b5d4bdc3deccb297e23db9dab /mail/postfix
parent8d552f9d00eafb58bd41cae4b461cd4f9161ae9a (diff)
downloadports-5552f65cdc2244f8ae6dbc04225f4102b3ddce65.tar.gz
ports-5552f65cdc2244f8ae6dbc04225f4102b3ddce65.zip
Notes
Diffstat (limited to 'mail/postfix')
-rw-r--r--mail/postfix/Makefile33
-rw-r--r--mail/postfix/distinfo9
-rw-r--r--mail/postfix/files/postfix.sh.in1
-rw-r--r--mail/postfix/pkg-plist1
4 files changed, 33 insertions, 11 deletions
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 4bfbcbb9f7c2..9be74627f70b 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -16,13 +16,12 @@ MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/ \
ftp://ftp.samurai.com/pub/postfix/official/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/mail/postfix/official/&,}
MASTER_SITE_SUBDIR= . old related/postfix
-DISTNAME= postfix-${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= sahil@FreeBSD.org
COMMENT= A secure alternative to widely-used Sendmail
-VDAVERSION= 2.6.5
+VDAVERSION= 2.7.0
CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-68-9].* postfix-current-2.* \
sendmail-8.* sendmail-*-8.* smail-3.* zmailer-2.*
@@ -32,7 +31,7 @@ SCRIPTS_ENV+= POSTFIX_DEFAULT_MTA="${POSTFIX_DEFAULT_MTA}"
# back compat pull in settings from POSTFIX_OPTIONS for convenience when
# make config is run (happens first time port is built, too)
-.for o in SASL2 SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test
+.for o in SASL2 SASLKRB5 SASLKRB5MIT TLS BDB MySQL PgSQL OpenLDAP CDB NIS VDA Test SPF
STATUS_${o}=off
.endfor
.if defined(POSTFIX_OPTIONS)
@@ -55,6 +54,7 @@ OPTIONS= PCRE "Perl Compatible Regular Expressions" on \
NIS "NIS maps lookups" ${STATUS_NIS} \
VDA "VDA (Virtual Delivery Agent 32Bit)" ${STATUS_VDA} \
TEST "SMTP/LMTP test server and generator" ${STATUS_Test} \
+ SPF "SPF support (via libspf2 1.2.x)" ${STATUS_SPF} \
INST_BASE "Install into /usr and /etc/postfix" off
.include <bsd.port.options.mk>
@@ -150,6 +150,19 @@ POSTFIX_CCARGS+= -DUSE_TLS -I${OPENSSLINC}
POSTFIX_AUXLIBS+= -L${OPENSSLLIB} ${LDFLAGS} -lssl -lcrypto
.endif
+.if defined(WITH_SPF)
+LIB_DEPENDS+= spf2.3:${PORTSDIR}/mail/libspf2
+PATCH_SITES+= ${MASTER_SITE_LOCAL}
+PATCH_SITE_SUBDIR= mm
+PATCHFILES+= postfix-2.7.1-libspf2-1.2.x.patch.gz
+PATCH_DIST_STRIP= -p1
+POSTFIX_CCARGS+= -DHAVE_NS_TYPE -I${LOCALBASE}/include
+POSTFIX_AUXLIBS+= -L${LOCALBASE}/lib -lspf2
+PLIST_SUB+= SPF=""
+.else
+PLIST_SUB+= SPF="@comment "
+.endif
+
.if defined(WITH_BDB)
USE_BDB= yes
POSTFIX_CCARGS+= -I${BDB_INCLUDE_DIR}
@@ -193,12 +206,12 @@ _REQUIRE+= ypserv
# 32Bit VDA patch (64Bit has different patch)
.if defined(WITH_VDA)
-PATCH_SITES+= http://vda.sourceforge.net/VDA/
-PATCHFILES+= postfix-${VDAVERSION}-vda-ng.patch.gz
+PATCH_SITES+= http://vda.sourceforge.net/VDA/:vda
+PATCHFILES+= postfix-vda-${VDAVERSION}.patch:vda
PATCH_DIST_STRIP= -p1
-PLIST_SUB+= VDA=""
+PLIST_SUB+= VDA=""
.else
-PLIST_SUB+= VDA="@comment "
+PLIST_SUB+= VDA="@comment "
.endif
.if defined(WITH_TEST)
@@ -295,6 +308,12 @@ post-patch:
@${ECHO} '$$html_directory/$f:f:root:-:644' \
>> ${WRKSRC}/conf/postfix-files
.endfor
+.if defined(WITH_SPF)
+ @${ECHO} '$$readme_directory/SPF_README:f:root:-:644' \
+ >> ${WRKSRC}/conf/postfix-files
+ @${REINPLACE_CMD} -E -e '${REINPLACE}' \
+ ${WRKSRC}/README_FILES/SPF_README
+.endif
.if defined(WITH_VDA)
@${ECHO} '$$readme_directory/VDA_README:f:root:-:644' \
>> ${WRKSRC}/conf/postfix-files
diff --git a/mail/postfix/distinfo b/mail/postfix/distinfo
index 2ac66e5c3d8f..f178687a16b6 100644
--- a/mail/postfix/distinfo
+++ b/mail/postfix/distinfo
@@ -1,6 +1,9 @@
MD5 (postfix/postfix-2.7.1.tar.gz) = b7a5c3ccd309156a65d6f8d2683d4fa1
SHA256 (postfix/postfix-2.7.1.tar.gz) = 12301aa8dae18d333c8c96dbf7673f8f05139f10406e7afe278cfd4a1f132df0
SIZE (postfix/postfix-2.7.1.tar.gz) = 3418747
-MD5 (postfix/postfix-2.6.5-vda-ng.patch.gz) = 43e54d0a1a016b90d15a1bd231e6fa38
-SHA256 (postfix/postfix-2.6.5-vda-ng.patch.gz) = e1c04e9d268dc84832334997e1f593af9877dbd5030708280427a0dc4452e797
-SIZE (postfix/postfix-2.6.5-vda-ng.patch.gz) = 12435
+MD5 (postfix/postfix-2.7.1-libspf2-1.2.x.patch.gz) = 28261fa4db230433cade2ebbee629a18
+SHA256 (postfix/postfix-2.7.1-libspf2-1.2.x.patch.gz) = 98e39c8494bb20a2e790ca3e1452eec94446eb858c628e33bf4d3730fb31150d
+SIZE (postfix/postfix-2.7.1-libspf2-1.2.x.patch.gz) = 7074
+MD5 (postfix/postfix-vda-2.7.0.patch) = f73d119fc9e00f31f23599176554e763
+SHA256 (postfix/postfix-vda-2.7.0.patch) = 6a81aadc21ddd9ffa22fd3a64c924a241b92fc5f2b3bafd352075e830e086e0b
+SIZE (postfix/postfix-vda-2.7.0.patch) = 59667
diff --git a/mail/postfix/files/postfix.sh.in b/mail/postfix/files/postfix.sh.in
index 91e765d14cad..849e6c1f9bd6 100644
--- a/mail/postfix/files/postfix.sh.in
+++ b/mail/postfix/files/postfix.sh.in
@@ -28,7 +28,6 @@ load_rc_config $name
: ${postfix_enable:="NO"}
: ${postfix_pidfile:="/var/spool/postfix/pid/master.pid"}
: ${postfix_procname:="%%PREFIX%%/libexec/postfix/master"}
-: ${postfix_flags:=""}
start_cmd=${name}_start
stop_cmd=${name}_stop
diff --git a/mail/postfix/pkg-plist b/mail/postfix/pkg-plist
index 4fe188422fc0..e47028c3d537 100644
--- a/mail/postfix/pkg-plist
+++ b/mail/postfix/pkg-plist
@@ -132,6 +132,7 @@ sbin/sendmail
%%PORTDOCS%%%%DOCSDIR%%/SMTPD_PROXY_README.html
%%PORTDOCS%%%%DOCSDIR%%/SOHO_README
%%PORTDOCS%%%%DOCSDIR%%/SOHO_README.html
+%%SPF%%%%PORTDOCS%%%%DOCSDIR%%/SPF_README
%%PORTDOCS%%%%DOCSDIR%%/STANDARD_CONFIGURATION_README
%%PORTDOCS%%%%DOCSDIR%%/STANDARD_CONFIGURATION_README.html
%%PORTDOCS%%%%DOCSDIR%%/STRESS_README