aboutsummaryrefslogtreecommitdiff
path: root/mail/postfixadmin/Makefile
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2015-09-11 23:18:00 +0000
committerCarlo Strub <cs@FreeBSD.org>2015-09-11 23:18:00 +0000
commit8f5451ae43c3821516210a7b3de4f0394d6a5c9c (patch)
tree7a8eedae89d8698503183d834b7eb53dac635480 /mail/postfixadmin/Makefile
parent8b8ce2fcfa1509f2793e59d334914525a149c020 (diff)
downloadports-8f5451ae43c3821516210a7b3de4f0394d6a5c9c.tar.gz
ports-8f5451ae43c3821516210a7b3de4f0394d6a5c9c.zip
Notes
Diffstat (limited to 'mail/postfixadmin/Makefile')
-rw-r--r--mail/postfixadmin/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/mail/postfixadmin/Makefile b/mail/postfixadmin/Makefile
index 9235bf2964ac..932819044032 100644
--- a/mail/postfixadmin/Makefile
+++ b/mail/postfixadmin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= postfixadmin
PORTVERSION= 2.3.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -13,7 +13,13 @@ COMMENT= PHP web-based management tool for Postfix virtual domains and users
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/GPL-LICENSE.TXT
-USES= cpe
+RUN_DEPENDS= p5-Email-Valid>=0.12:${PORTSDIR}/mail/p5-Email-Valid \
+ p5-Log-Dispatch>=1.79:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Log-Log4perl>=0.26:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Mail-Sender>=0.7.04:${PORTSDIR}/mail/p5-Mail-Sender \
+ p5-MIME-EncWords>=0.040:${PORTSDIR}/mail/p5-MIME-EncWords
+
+USES= cpe perl5 shebangfix
CPE_VENDOR= postfix_admin_project
CPE_PRODUCT= postfix_admin
@@ -31,6 +37,8 @@ OPTIONS_DEFAULT= MYSQL
OPTIONS_DEFINE= DOCS
+USES_PERL5= run
+
.include <bsd.port.options.mk>
USE_PHP= pcre session mbstring spl xmlrpc