aboutsummaryrefslogtreecommitdiff
path: root/mail/postgrey/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-11-05 17:35:38 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-11-05 17:35:38 +0000
commitea2f6e254b7c15c6beed6a52fe2eadfa339d367e (patch)
treefd7b8a2d03c507f3d19c50aa999b484aef91e197 /mail/postgrey/Makefile
parentadfa6917d00e27a7971c4ceac2046a2dcacace2e (diff)
downloadports-ea2f6e254b7c15c6beed6a52fe2eadfa339d367e.tar.gz
ports-ea2f6e254b7c15c6beed6a52fe2eadfa339d367e.zip
Notes
Diffstat (limited to 'mail/postgrey/Makefile')
-rw-r--r--mail/postgrey/Makefile50
1 files changed, 29 insertions, 21 deletions
diff --git a/mail/postgrey/Makefile b/mail/postgrey/Makefile
index 53a94a316ecb..77a3ad1a0edd 100644
--- a/mail/postgrey/Makefile
+++ b/mail/postgrey/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= postgrey
-PORTVERSION= 1.34
-PORTREVISION= 8
+PORTVERSION= 1.35
CATEGORIES= mail
MASTER_SITES= http://postgrey.schweikert.ch/pub/ \
http://postgrey.schweikert.ch/pub/old/
@@ -11,6 +10,8 @@ MASTER_SITES= http://postgrey.schweikert.ch/pub/ \
MAINTAINER= ports.maintainer@evilphi.com
COMMENT= Greylisting policy server for Postfix
+LICENSE= GPLv2
+
RUN_DEPENDS= p5-Net-Server>=0:${PORTSDIR}/net/p5-Net-Server \
p5-IO-Multiplex>=0:${PORTSDIR}/devel/p5-IO-Multiplex \
p5-Parse-Syslog>=0:${PORTSDIR}/textproc/p5-Parse-Syslog \
@@ -22,21 +23,27 @@ USE_RC_SUBR= ${PORTNAME}
NO_BUILD= yes
POD2MAN?= pod2man
PORTDOCS= README Changes README.exim
-SUB_FILES= pkg-install
-PLIST_SUB= USER=${PGY_USERNAME} \
- GROUP=${PGY_GROUPNAME}
-SUB_LIST= USER=${PGY_USERNAME} \
- GROUP=${PGY_GROUPNAME} \
- ETCFILES="${ETCFILES}" \
- POSTGREYDIR=${PGY_DIR}
+
+PG_DBDIR?= /var/db/postgrey
+PG_GROUP?= postgrey
+PG_RUNDIR?= /var/run/postgrey
+PG_USER?= postgrey
+
+SUB_LIST= PG_DBDIR=${PG_DBDIR} \
+ PG_RUNDIR=${PG_RUNDIR}
+
+PLIST_SUB+= PG_DBDIR=${PG_DBDIR} \
+ PG_GROUP=${PG_GROUP} \
+ PG_RUNDIR=${PG_RUNDIR} \
+ PG_USER=${PG_USER}
+
+USERS= ${PG_USER}
+GROUPS= ${PG_GROUP}
+
+MANPAGES= postgrey.1 policy-test.1 postgreyreport.1
ETCFILES= whitelist_clients whitelist_recipients
-PGY_USERNAME?= postgrey
-PGY_GROUPNAME?= postgrey
-PGY_DIR?= /var/db/postgrey
-USERS= ${PGY_USERNAME}
-GROUPS= ${PGY_GROUPNAME}
-MPAGES= postgrey.1 policy-test.1 postgreyreport.1
+USE_RC_SUBR= postgrey
USES= shebangfix perl5
SHEBANG_FILES= postgrey policy-test contrib/postgreyreport
@@ -46,25 +53,26 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's#nogroup#${PGY_GROUPNAME}#' \
+ @${REINPLACE_CMD} -e 's#nogroup#${PG_GROUP}#' \
-e 's#/etc/main.cf#/etc/postfix/main.cf#' ${WRKSRC}/postgrey
@${REINPLACE_CMD} -e 's#/etc/postfix#${PREFIX}&#' \
${WRKSRC}/postgrey ${WRKSRC}/postgrey_whitelist_*
- @${REINPLACE_CMD} -e 's#/var/spool/postfix/postgrey#${PGY_DIR}#' \
+ @${REINPLACE_CMD} -e 's#/var/spool/postfix/postgrey#${PG_DBDIR}#' \
${WRKSRC}/postgrey ${WRKSRC}/contrib/postgreyreport
do-install:
- ${POD2MAN} ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.1
+ ${POD2MAN} ${WRKSRC}/postgrey ${WRKSRC}/postgrey.1
${POD2MAN} ${WRKSRC}/policy-test ${WRKSRC}/policy-test.1
${POD2MAN} ${WRKSRC}/contrib/postgreyreport ${WRKSRC}/postgreyreport.1
${INSTALL_SCRIPT} ${WRKSRC}/postgrey ${STAGEDIR}${PREFIX}/sbin
${INSTALL_SCRIPT} ${WRKSRC}/policy-test ${STAGEDIR}${PREFIX}/sbin
${INSTALL_SCRIPT} ${WRKSRC}/contrib/postgreyreport \
${STAGEDIR}${PREFIX}/sbin
- @${MKDIR} ${STAGEDIR}${PREFIX}/etc/postfix ${STAGEDIR}/${PGY_DIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/postfix ${STAGEDIR}/${PG_DBDIR} \
+ ${STAGEDIR}/${PG_RUNDIR}
.for i in ${ETCFILES}
${INSTALL_DATA} ${WRKSRC}/postgrey_${i} \
- ${STAGEDIR}${PREFIX}/etc/postfix/dist-postgrey_${i}
+ ${STAGEDIR}${PREFIX}/etc/postfix/postgrey_${i}.sample
.endfor
.if ${PORT_OPTIONS:MDOCS}
@@ -72,6 +80,6 @@ do-install:
@cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
@cd ${WRKSRC} && \
- ${INSTALL_MAN} ${MPAGES} ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${MANPAGES} ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>