aboutsummaryrefslogtreecommitdiff
path: root/mail/postgrey
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-10-27 11:49:41 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-10-27 11:49:41 +0000
commitb32a9ef01021b08fca5d5813eeea681dc93d4f5f (patch)
tree143fcc85ab4c1838f33286742ae96393dd0973f1 /mail/postgrey
parentf3ccb979fbbce894520406e41c70cb63dce28fed (diff)
downloadports-b32a9ef01021b08fca5d5813eeea681dc93d4f5f.tar.gz
ports-b32a9ef01021b08fca5d5813eeea681dc93d4f5f.zip
- Update to 1.31
- Fix pkg-plist PR: ports/117470 Submitted by: Harold Paulson <haroldp@internal.org> (maintainer) Approved by: sat (mentor)
Notes
Notes: svn path=/head/; revision=202131
Diffstat (limited to 'mail/postgrey')
-rw-r--r--mail/postgrey/Makefile24
-rw-r--r--mail/postgrey/distinfo6
-rw-r--r--mail/postgrey/files/postgrey.in2
-rw-r--r--mail/postgrey/pkg-plist1
4 files changed, 23 insertions, 10 deletions
diff --git a/mail/postgrey/Makefile b/mail/postgrey/Makefile
index b327a24a63fb..177c8b875b23 100644
--- a/mail/postgrey/Makefile
+++ b/mail/postgrey/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= postgrey
-PORTVERSION= 1.30
-PORTREVISION= 1
+PORTVERSION= 1.31
CATEGORIES= mail
MASTER_SITES= http://postgrey.schweikert.ch/pub/ LOCAL/beech
@@ -16,12 +15,15 @@ COMMENT= Greylisting policy server for Postfix
RUN_DEPENDS= ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
${SITE_PERL}/IO/Multiplex.pm:${PORTSDIR}/devel/p5-IO-Multiplex \
+ ${SITE_PERL}/Parse/Syslog.pm:${PORTSDIR}/textproc/p5-Parse-Syslog \
${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB \
${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
USE_PERL5_RUN= yes
USE_RC_SUBR= postgrey
NO_BUILD= yes
+POD2MAN?= pod2man
+PORTDOCS= README Changes README.exim
SUB_FILES= pkg-install
SUB_LIST= USER=${PGY_USERNAME} UID=${PGY_USERID} GROUP=${PGY_GROUPNAME} \
GID=${PGY_GROUPID} ETCFILES="${ETCFILES}" \
@@ -32,6 +34,7 @@ PGY_USERID?= 225
PGY_GROUPNAME?= ${PGY_USERNAME}
PGY_GROUPID?= ${PGY_USERID}
PGY_DIR?= /var/db/postgrey
+MAN1= ${PORTNAME}.1 policy-test.1 postgreyreport.1
post-patch:
@${REINPLACE_CMD} -e "s#/etc/#${PREFIX}/etc/#" ${WRKSRC}/postgrey
@@ -42,14 +45,23 @@ pre-install:
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/postgrey ${PREFIX}/sbin
- ${INSTALL_SCRIPT} ${WRKSRC}/policy-test ${PREFIX}/sbin
- ${INSTALL_SCRIPT} ${WRKSRC}/contrib/postgreyreport ${PREFIX}/sbin
- ${MKDIR} ${PREFIX}/etc/postfix
+ @${POD2MAN} ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.1
+ @${POD2MAN} ${WRKSRC}/policy-test ${WRKSRC}/policy-test.1
+ @${POD2MAN} ${WRKSRC}/contrib/postgreyreport ${WRKSRC}/postgreyreport.1
+ @${INSTALL_SCRIPT} ${WRKSRC}/postgrey ${PREFIX}/sbin
+ @${INSTALL_SCRIPT} ${WRKSRC}/policy-test ${PREFIX}/sbin
+ @${INSTALL_SCRIPT} ${WRKSRC}/contrib/postgreyreport ${PREFIX}/sbin
+ @${INSTALL} -d ${PREFIX}/etc/postfix
.for i in ${ETCFILES}
${INSTALL_DATA} ${WRKSRC}/postgrey_${i} ${PREFIX}/etc/postfix/dist-postgrey_${i}
.endfor
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+ @cd ${WRKSRC} && ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1
+
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/mail/postgrey/distinfo b/mail/postgrey/distinfo
index dbffeadbeb65..f5042d643d7d 100644
--- a/mail/postgrey/distinfo
+++ b/mail/postgrey/distinfo
@@ -1,3 +1,3 @@
-MD5 (postgrey-1.30.tar.gz) = 5698c196a5874eb963a374d8aab183ca
-SHA256 (postgrey-1.30.tar.gz) = d96b59b3bd1c31d33592359d0395b2b24bcd2232f1a7f99c6b29aec8d1bfb1f8
-SIZE (postgrey-1.28.tar.gz) = 34109
+MD5 (postgrey-1.31.tar.gz) = b7a8a6fc9f1ad802c5a516a3be34bb29
+SHA256 (postgrey-1.31.tar.gz) = d458701bc0e1ffa900492c853c5fb5d254a12e223c3c58ca3f445eee0c3d6e6a
+SIZE (postgrey-1.31.tar.gz) = 34895
diff --git a/mail/postgrey/files/postgrey.in b/mail/postgrey/files/postgrey.in
index 64f45981a2c2..c64a58ce8095 100644
--- a/mail/postgrey/files/postgrey.in
+++ b/mail/postgrey/files/postgrey.in
@@ -36,7 +36,7 @@ stop_postcmd()
postgrey_enable=${postgrey_enable:-"NO"}
postgrey_pidfile=${postgrey_pidfile:-"/var/run/postgrey.pid"}
postgrey_flags=${postgrey_flags:-"--pidfile=${postgrey_pidfile} \
- --inet=10023 -d --user=postgrey --group=postgrey --dbdir=/var/db/postgrey"}
+ --inet=10023 -d --user=%%USER%% --group=%%GROUP%% --dbdir=/var/db/postgrey"}
pidfile="${postgrey_pidfile}"
diff --git a/mail/postgrey/pkg-plist b/mail/postgrey/pkg-plist
index cf8b3648ba25..bd83ebbf8647 100644
--- a/mail/postgrey/pkg-plist
+++ b/mail/postgrey/pkg-plist
@@ -6,3 +6,4 @@ sbin/postgreyreport
etc/postfix/dist-postgrey_whitelist_recipients
etc/postfix/dist-postgrey_whitelist_clients
@dirrmtry etc/postfix
+@unexec rmdir /var/db/postgrey 2>/dev/null || true \ No newline at end of file