aboutsummaryrefslogtreecommitdiff
path: root/mail/prepflog/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-16 09:53:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-16 09:53:30 +0000
commitf88e0bbc02ab0f58982e0c4999e73e5f96fca315 (patch)
tree510b4d471f9e610c3f3988c6c620fe598b80efba /mail/prepflog/Makefile
parent9baae60769005dc5af0b8f68eb2a6d72d6564716 (diff)
downloadports-f88e0bbc02ab0f58982e0c4999e73e5f96fca315.tar.gz
ports-f88e0bbc02ab0f58982e0c4999e73e5f96fca315.zip
The script processes mail log files that are to be passed to pflogsumm
or awstats disregarding the lines relating to the re-injection of messages into postfix. It is very useful for a postfix setup which uses amavis for virus filtering. WWW: http://www.gufonero.com/postfix/prepflog.html PR: ports/119646 Submitted by: Terry Sposato
Notes
Notes: svn path=/head/; revision=207295
Diffstat (limited to 'mail/prepflog/Makefile')
-rw-r--r--mail/prepflog/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/mail/prepflog/Makefile b/mail/prepflog/Makefile
new file mode 100644
index 000000000000..eda665c6c7d9
--- /dev/null
+++ b/mail/prepflog/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: prepflog
+# Date created: 14 January 2008
+# Whom: Terry Sposato
+#
+# $FreeBSD$
+#
+
+PORTNAME= prepflog
+PORTVERSION= 0.3
+CATEGORIES= mail
+MASTER_SITES= http://www.gufonero.com/postfix/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= terry@sucked-in.com
+COMMENT= Prepares logfiles in a sanitised format for pflogsumm and awstats
+
+PLIST_FILES= bin/prepflog
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>