aboutsummaryrefslogtreecommitdiff
path: root/mail/procmail
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-21 01:59:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-21 01:59:23 +0000
commit20585f8e5be96069cb6736f57a8d2790dd327f71 (patch)
treef36677804d003caa7e02a726b1adae4080c4b4b6 /mail/procmail
parentc9b4419cbfc78fed5366adb561300b4de32b1643 (diff)
downloadports-20585f8e5be96069cb6736f57a8d2790dd327f71.tar.gz
ports-20585f8e5be96069cb6736f57a8d2790dd327f71.zip
- Stage support
Notes
Notes: svn path=/head/; revision=345306
Diffstat (limited to 'mail/procmail')
-rw-r--r--mail/procmail/Makefile20
-rw-r--r--mail/procmail/files/patch-aa2
2 files changed, 9 insertions, 13 deletions
diff --git a/mail/procmail/Makefile b/mail/procmail/Makefile
index b17be8c7dd6d..e83670b30087 100644
--- a/mail/procmail/Makefile
+++ b/mail/procmail/Makefile
@@ -19,16 +19,16 @@ COMMENT= Local mail delivery agent
INSTALL_TARGET= install-suid install.man
-MAN1= formail.1 lockfile.1 procmail.1
-MAN5= procmailex.5 procmailrc.5 procmailsc.5
-PLIST_FILES= bin/formail bin/lockfile bin/mailstat bin/procmail
+PLIST_FILES= bin/formail bin/lockfile bin/mailstat bin/procmail \
+ man/man1/formail.1.gz man/man1/lockfile.1.gz \
+ man/man1/procmail.1.gz man/man5/procmailex.5.gz \
+ man/man5/procmailrc.5.gz man/man5/procmailsc.5.gz
PORTDOCS= FAQ FEATURES HISTORY KNOWN_BUGS README
PORTEXAMPLES= 1procmailrc 1rmail 2procmailrc 2rmail 3procmailrc 3rmail \
advanced dirname forward local_procmail_lmtp.m4 mailstat
OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@@ -38,13 +38,9 @@ post-patch:
-E 's|cd (.+); (\$$\(MAKE\))|\2 -C \1|'
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/mail/procmail/files/patch-aa b/mail/procmail/files/patch-aa
index b2bc9a255518..91a38924c475 100644
--- a/mail/procmail/files/patch-aa
+++ b/mail/procmail/files/patch-aa
@@ -13,7 +13,7 @@
# BASENAME should point to where the whole lot will be installed
# change BASENAME to your home directory if need be
-! BASENAME = $(PREFIX)
+! BASENAME = $(DESTDIR)$(PREFIX)
# For display in the man pages
VISIBLE_BASENAME= $(BASENAME)