aboutsummaryrefslogtreecommitdiff
path: root/mail/procmail
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2001-09-29 09:00:32 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2001-09-29 09:00:32 +0000
commit41b16dcb8b7eb984cb5bd63dd8e886454562e5b0 (patch)
treef093618da5442fa89801f4099a18b3e92ba3ff06 /mail/procmail
parentbc582f8d870747d5b4ced8e6ec189b076b9cc8bc (diff)
downloadports-41b16dcb8b7eb984cb5bd63dd8e886454562e5b0.tar.gz
ports-41b16dcb8b7eb984cb5bd63dd8e886454562e5b0.zip
Upgrade to 3.22
PR: 30881 Submitted by: Cyrille Lefevre <clefevre@citeweb.net>
Notes
Notes: svn path=/head/; revision=48263
Diffstat (limited to 'mail/procmail')
-rw-r--r--mail/procmail/Makefile69
-rw-r--r--mail/procmail/distinfo2
-rw-r--r--mail/procmail/files/patch-aa2
-rw-r--r--mail/procmail/files/patch-ab4
-rw-r--r--mail/procmail/pkg-descr20
-rw-r--r--mail/procmail/pkg-plist19
6 files changed, 103 insertions, 13 deletions
diff --git a/mail/procmail/Makefile b/mail/procmail/Makefile
index d3b74cf93532..821fe0b4cc49 100644
--- a/mail/procmail/Makefile
+++ b/mail/procmail/Makefile
@@ -6,26 +6,79 @@
#
PORTNAME= procmail
-PORTVERSION= 3.21
+PORTVERSION= 3.22
CATEGORIES= mail
MASTER_SITES= ftp://ftp.procmail.org/pub/procmail/ \
- ftp://ftp.informatik.rwth-aachen.de/pub/packages/procmail/
+ ftp://ftp.psg.com/pub/unix/procmail/ \
+ ftp://ftp.ucsb.edu/pub/mirrors/procmail/ \
+ ftp://ftp.informatik.rwth-aachen.de/pub/packages/procmail/ \
+ ftp://ftp.fu-berlin.de/pub/unix/mail/procmail/ \
+ ftp://ftp.net.ohio-state.edu/pub/networking/mail/procmail/ \
+ ftp://ftp.fdt.net/pub/unix/packages/procmail/ \
+ ftp://ftp.tamu.edu/pub/mirrors/procmail/ \
+ ftp://ftp.kfki.hu/pub/packages/mail/procmail/ \
+ ftp://giswitch.sggw.waw.pl/pub/unix/procmail/ \
+ ftp://ftp.solarisguide.com/pub/procmail/ \
+ ftp://ftp.win.ne.jp/pub/network/mail/procmail/ \
+ http://www.ring.gr.jp/archives/net/mail/procmail/ \
+ ftp://ftp.ring.gr.jp/pub/net/mail/procmail/ \
+ ftp://ftp.ayamura.org/pub/procmail/ \
+ ftp://sunsite.cnlab-switch.ch/mirror/procmail/ \
+ ftp://ftp.gigabell.net/pub/procmail/ \
+ ftp://ftp.linja.net/pub/mirrors/procmail/ \
+ ftp://ftp.stealth.net/pub/mirrors/ftp.procmail.org/pub/procmail/ \
+ ftp://ftp.mirror.ac.uk/sites/ftp.procmail.org/pub/procmail/
MAINTAINER= ache@FreeBSD.org
-INSTALL_TARGET= install-suid install.man
+# Global variables
+#
# It asks for list of directories to do test for file locking
# (defaults to /tmp and ".", so return should suffice in most cases).
-.if !defined(PACKAGE_BUILDING) # handled in patch-aa
+.if !defined(BATCH) # handled in patch-aa
IS_INTERACTIVE= yes
.endif
+
+INSTALL_TARGET= install-suid install.man
+
MAN1= procmail.1 formail.1 lockfile.1
MAN5= procmailex.5 procmailrc.5 procmailsc.5
-.include <bsd.port.pre.mk>
+# Local variables
+#
+
+DOC_FILES= FAQ FEATURES HISTORY KNOWN_BUGS README
-post-configure:
- @${PERL} -pi -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/config.h
+SAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+SAMPLE_FILES= 1procmailrc 1rmail 2procmailrc 2rmail 3procmailrc 3rmail \
+ advanced dirname forward local_procmail_lmtp.m4 mailstat
+
+# Post-configure
+#
+
+post-configure: patch-config
+
+patch-config:
+ @${PERL} -pi.fbsd -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/config.h
+
+# Post-install
+#
+
+post-install: install-sample install-doc
+
+install-sample:
+ @${MKDIR} ${SAMPLESDIR}
+.for file in ${SAMPLE_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/examples/${file} ${SAMPLESDIR}
+.endfor
+
+install-doc:
+.if !defined(NOPORTSDOC)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/procmail/distinfo b/mail/procmail/distinfo
index 63feb08fd2c2..875ce48c8adf 100644
--- a/mail/procmail/distinfo
+++ b/mail/procmail/distinfo
@@ -1 +1 @@
-MD5 (procmail-3.21.tar.gz) = 2a0491030e7bff3292257d02a93cbe91
+MD5 (procmail-3.22.tar.gz) = 1678ea99b973eb77eda4ecf6acae53f1
diff --git a/mail/procmail/files/patch-aa b/mail/procmail/files/patch-aa
index 6258b85dcd37..b2bc9a255518 100644
--- a/mail/procmail/files/patch-aa
+++ b/mail/procmail/files/patch-aa
@@ -23,7 +23,7 @@
# Makefile.0 - mark, don't (re)move this, a sed script needs it
-+ .if defined(PACKAGE_BUILDING)
++ .if defined(BATCH)
+ LOCKINGTEST=/tmp .
+ .else
LOCKINGTEST=__defaults__
diff --git a/mail/procmail/files/patch-ab b/mail/procmail/files/patch-ab
index 25bbf4d58922..6307181b6bbe 100644
--- a/mail/procmail/files/patch-ab
+++ b/mail/procmail/files/patch-ab
@@ -38,11 +38,11 @@
is not found, maildelivery will proceed as normal to the default
system mailbox. */
-! #define ETCRC "/usr/local/etc/procmailrc" /* optional global procmailrc startup
+! #define ETCRC "%%PREFIX%%/etc/procmailrc" /* optional global procmailrc startup
file (will only be read if procmail
is started with no rcfile on the command line). */
-! #define ETCRCS "/usr/local/etc/procmailrcs/" /* optional trusted path prefix for
+! #define ETCRCS "%%PREFIX%%/etc/procmailrcs/" /* optional trusted path prefix for
rcfiles which will be executed with
the uid of the owner of the rcfile (this only happens if procmail is
called with the -m option, without variable assignments on the command
diff --git a/mail/procmail/pkg-descr b/mail/procmail/pkg-descr
index 7f2ccbbcf7c6..341b17c6894d 100644
--- a/mail/procmail/pkg-descr
+++ b/mail/procmail/pkg-descr
@@ -1,3 +1,21 @@
-This is ProcMail, the ultimate incoming mail processor.
+The procmail mail processing program can be used to create mail-servers,
+mailing lists, sort your incoming mail into separate folders/files (real
+convenient when subscribing to one or more mailing lists or for prioritising
+your mail), preprocess your mail, start any programs upon mail arrival
+(e.g. to generate different chimes on your workstation for different
+types of mail) or selectively forward certain incoming mail automatically
+to someone.
+
+Procmail can be used:
+ - and installed by an unprivileged user (for himself only).
+ - as a drop in replacement for the local delivery agent /bin/mail
+ (with biff/comsat support).
+ - as a general mailfilter for whole groups of messages (e.g. when
+ called from within sendmail.cf rules).
+
+The accompanying formail program enables you to generate autoreplies,
+split up digests/mailboxes into the original messages, do some very
+simple header-munging/extraction, or force mail into mail-format (with
+leading From line).
WWW: http://www.procmail.org/
diff --git a/mail/procmail/pkg-plist b/mail/procmail/pkg-plist
index 619e20fd76b7..46917ba42ee4 100644
--- a/mail/procmail/pkg-plist
+++ b/mail/procmail/pkg-plist
@@ -1,4 +1,23 @@
+@comment $FreeBSD$
bin/procmail
bin/formail
bin/lockfile
bin/mailstat
+%%PORTDOCS%%share/doc/procmail/FAQ
+%%PORTDOCS%%share/doc/procmail/FEATURES
+%%PORTDOCS%%share/doc/procmail/HISTORY
+%%PORTDOCS%%share/doc/procmail/KNOWN_BUGS
+%%PORTDOCS%%share/doc/procmail/README
+share/examples/procmail/1procmailrc
+share/examples/procmail/1rmail
+share/examples/procmail/2procmailrc
+share/examples/procmail/2rmail
+share/examples/procmail/3procmailrc
+share/examples/procmail/3rmail
+share/examples/procmail/advanced
+share/examples/procmail/dirname
+share/examples/procmail/forward
+share/examples/procmail/local_procmail_lmtp.m4
+share/examples/procmail/mailstat
+@dirrm share/examples/procmail
+%%PORTDOCS%%@dirrm share/doc/procmail