aboutsummaryrefslogtreecommitdiff
path: root/mail/procmail
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-07-29 23:24:50 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-07-29 23:24:50 +0000
commit7f73be35f9d6a1043df7ef65b303af3860c25740 (patch)
treed973b7deb2eefb11ee94bc05054fed4cb3f7d251 /mail/procmail
parent7b2ebe81721d1136973e034d6210105a40311270 (diff)
downloadports-7f73be35f9d6a1043df7ef65b303af3860c25740.tar.gz
ports-7f73be35f9d6a1043df7ef65b303af3860c25740.zip
Fix collision with getline(3)
Obtained from: fedora
Notes
Notes: svn path=/head/; revision=419276
Diffstat (limited to 'mail/procmail')
-rw-r--r--mail/procmail/Makefile1
-rw-r--r--mail/procmail/files/procmail-3.22-getline.patch56
2 files changed, 57 insertions, 0 deletions
diff --git a/mail/procmail/Makefile b/mail/procmail/Makefile
index 373b5b56ef5c..cee9c152b415 100644
--- a/mail/procmail/Makefile
+++ b/mail/procmail/Makefile
@@ -23,6 +23,7 @@ OPTIONS_DEFINE= DOCS EXAMPLES
INSTALL_TARGET= install.bin install.man
USES= cpe
+EXTRA_PATCHES= ${FILESDIR}/procmail-3.22-getline.patch:-p1
PORTDOCS= FAQ FEATURES HISTORY KNOWN_BUGS README
PORTEXAMPLES= 1procmailrc 1rmail 2procmailrc 2rmail 3procmailrc 3rmail \
diff --git a/mail/procmail/files/procmail-3.22-getline.patch b/mail/procmail/files/procmail-3.22-getline.patch
new file mode 100644
index 000000000000..fb9a4ec6efb5
--- /dev/null
+++ b/mail/procmail/files/procmail-3.22-getline.patch
@@ -0,0 +1,56 @@
+diff -up procmail-3.22/src/fields.c.getline procmail-3.22/src/fields.c
+--- procmail-3.22/src/fields.c.getline 2001-09-11 06:57:08.000000000 +0200
++++ procmail-3.22/src/fields.c 2009-06-30 16:10:36.000000000 +0200
+@@ -110,16 +110,16 @@ void dispfield(p)register const struct f
+ /* try and append one valid field to rdheader from stdin */
+ int readhead P((void))
+ { int idlen;
+- getline();
++ get_line();
+ if((idlen=breakfield(buf,buffilled))<=0) /* not the start of a valid field */
+ return 0;
+ if(idlen==STRLEN(FROM)&&eqFrom_(buf)) /* it's a From_ line */
+ { if(rdheader)
+ return 0; /* the From_ line was a fake! */
+- for(;buflast=='>';getline()); /* gather continued >From_ lines */
++ for(;buflast=='>';get_line()); /* gather continued >From_ lines */
+ }
+ else
+- for(;;getline()) /* get the rest of the continued field */
++ for(;;get_line()) /* get the rest of the continued field */
+ { switch(buflast) /* will this line be continued? */
+ { case ' ':case '\t': /* yep, it sure is */
+ continue;
+diff -up procmail-3.22/src/formail.c.getline procmail-3.22/src/formail.c
+--- procmail-3.22/src/formail.c.getline 2009-06-30 16:00:40.000000000 +0200
++++ procmail-3.22/src/formail.c 2009-06-30 16:10:49.000000000 +0200
+@@ -819,7 +819,7 @@ splitit: { if(!lnl) /* did the p
+ { if(split) /* gobble up the next start separator */
+ { buffilled=0;
+ #ifdef sMAILBOX_SEPARATOR
+- getline();buffilled=0; /* but only if it's defined */
++ get_line();buffilled=0; /* but only if it's defined */
+ #endif
+ if(buflast!=EOF) /* if any */
+ goto splitit;
+diff -up procmail-3.22/src/formisc.c.getline procmail-3.22/src/formisc.c
+--- procmail-3.22/src/formisc.c.getline 2001-06-29 04:20:45.000000000 +0200
++++ procmail-3.22/src/formisc.c 2009-06-30 16:12:20.000000000 +0200
+@@ -115,7 +115,7 @@ void loadchar(c)const int c; /* a
+ buf[buffilled++]=c;
+ }
+
+-int getline P((void)) /* read a newline-terminated line */
++int get_line P((void)) /* read a newline-terminated line */
+ { if(buflast==EOF) /* at the end of our Latin already? */
+ { loadchar('\n'); /* fake empty line */
+ return EOF; /* spread the word */
+diff -up procmail-3.22/src/formisc.h.getline procmail-3.22/src/formisc.h
+--- procmail-3.22/src/formisc.h.getline 1999-04-19 08:42:15.000000000 +0200
++++ procmail-3.22/src/formisc.h 2009-06-30 16:10:02.000000000 +0200
+@@ -17,4 +17,4 @@ void
+ char*
+ skipwords P((char*start));
+ int
+- getline P((void));
++ get_line P((void));