aboutsummaryrefslogtreecommitdiff
path: root/mail/py-fuglu
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /mail/py-fuglu
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'mail/py-fuglu')
-rw-r--r--mail/py-fuglu/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/mail/py-fuglu/Makefile b/mail/py-fuglu/Makefile
index d8515ad72a33..9fd4bee2852b 100644
--- a/mail/py-fuglu/Makefile
+++ b/mail/py-fuglu/Makefile
@@ -13,9 +13,9 @@ COMMENT= Mail scanning daemon for Postfix written in Python
LICENSE= APACHE20
RUN_DEPENDS= postfix:mail/postfix \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
-USES= python:2.4+
+USES= python:2.7
USE_PYTHON= autoplist distutils
USE_RC_SUBR= fuglu
@@ -36,13 +36,13 @@ SPAMASSASSIN_DESC= Use SpamAssassin
SPF_DESC= Use SPF (in FuGlu)
SQL_DESC= Use SQL
-BEAUTIFULSOUP_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/bs4/__init__.py:www/py-beautifulsoup
+BEAUTIFULSOUP_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/bs4/__init__.py:www/py-beautifulsoup@${FLAVOR}
CLAMAV_RUN_DEPENDS= clamd:security/clamav
-DKIM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dkimpy>0:mail/py-dkimpy
-MAGIC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}magic>0:devel/py-magic
+DKIM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dkimpy>0:mail/py-dkimpy@${FLAVOR}
+MAGIC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}magic>0:devel/py-magic@${FLAVOR}
SPAMASSASSIN_RUN_DEPENDS= spamassassin>=0:mail/spamassassin
-SPF_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyspf>0:mail/py-pyspf
-SQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=1.0:databases/py-sqlalchemy10
+SPF_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyspf>0:mail/py-pyspf@${FLAVOR}
+SQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=1.0:databases/py-sqlalchemy10@${FLAVOR}
post-extract:
@${REINPLACE_CMD} -e "s|'/etc|'etc|g" ${WRKSRC}/setup.py